Not working on Start Up

Comments

20 comments

  • Avatar
    mattwilson9090

    What do you mean by a login to your OpenDNS account? How did you set things up?

    It sounds like you did things in a rather unconventional manner, and knowing more about what you've done and do will make it easier and quicker to sort things out.

    1
    Comment actions Permalink
  • Avatar
    rjoem

    Thanks for your response. I have realized that it doesn't make a difference signing in to my account or not (Just had the account  for 4 to 5 days now). What appears to be the problem is the initial lag time after booting up my computer. It seems to usually take 5 to 10 minutes afterward for the content filtering to work with my computer or any associated mobile devices connected to the WIFI. - It's a newer Dell computer using Windows 10. However, today it took close to an hour for it to start working perfectly fine. Why the Lag Time and any comments on fixes for that, would be greatly appreciated.

    Thanks!!!

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    Setting aside the question of what you mean by logging in to OpenDNS, you still have not said how you set things up. In other words, what did you do to set up OpenDNS? Are you using a router? Are you keeping your IP address updated with OpenDNS, and if so, how are you are doing that? There are many questions that could be asked, but information is needed before any feedback can be provided to you.

    Without additional information like what is being asked for there is really very little that I can say. I have suspicions but I'm not going to write what could amount to pages of speculation, guidance or suggestions that would amount to a complicated troubleshooting flowchart without enough information for me to reduce the number of possibilities

    1
    Comment actions Permalink
  • Avatar
    rjoem

    I configured the home router and it confirms that it is successful. Not sure if I'm keeping my IP address updated with OopenDNS (not too technical) but if you can tell me how I can check - I should be able to find it out.

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    That doesn't really tell me much, and there certainly are no details, such as what you mean by configuring the home router or what confirmed what was successful or a link to the instructions that you followed. Details really do matter in trying to troubleshoot a technical issue, generalities aren't of much help.

    The two primary means of keeping your IP address updated are by installing the OpenDNS Updater on one computer on your network (OpenDNS configuration instructions provide downloads links to this) or using functionality built into the router to update the address, either directly with OpenDNS, or indirectly with DNS-O-Matic. To check if your current IP address is registered for your account look on your dashboard at https://dashboard.opendns.com/settings/ If there is only one address displayed then it's current, if there is more than one address, with sort of a curved blue arrow "pointing" to both of them then it is not current and you can manually update by clicking on that arrow.

    1
    Comment actions Permalink
  • Avatar
    mattwilson9090

    Alternatively, instead of trying to describe what you did to configure OpenDNS, you could attach screenshots of where you configured things so we can look directly at it. (Note, attach using the Insert button in the toolbar where you are typing your reply. If you just link to a third-party file sharing site the odds are good that OpenDNS is blocking it for me for security reasons).

    1
    Comment actions Permalink
  • Avatar
    rjoem

    Thanks for sticking in there with me. I'll try to be more detailed.

    I followed the instructions on Individual router configurations from the Opendns article  from their website. I used the instructions from the listed CenturyLink ZyXEL C1100Z router. My router is actually a CenturyLink PK5001Z but the screen shots from their (PK5001Z non-centurylink) did not resemble my screen shot settings but the CenturyLink ZyXEL C1100Z  were similar.  

    1. I Logged into my router’s browser-based utility by entering 192.168.0.1
    2. I went into the "Advanced Setup" menu.
    3. I Logged into the router's configuration page
    4. I went into the WAN settings and changed the DNS Type to Dynamic, changed the Primary DNS to 208.67.222.222 and Secondary DNS to 208.67.220.220
    5. The ISP Protocol was left as Auto Select and the protocol selected remained at DHCP
    6. I hit “Apply” to save my settings
    7. I flushed my browser and DNS cache by following the following instructions: http://www.opendns.com/support/article/67

    I tested the settings and received the message  Welcome to OpenDNS!

    Your Internet is safer, faster, and smarter because you’re using OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Fine, this sounds good!  You're using OpenDNS Home.  Now, what is still open?

    You visit your dashboard at https://dashboard.opendns.com/settings/ and add a network with your public IP address.  You keep this IP address information current by running an updater.  You configure content filtering and other settings there as well.

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    @rjoem

    Thank you for the additional information. It eliminated a number of possibilities I was wondering about.

    As rotblitz mentioned you missed the steps required to update your IP address when it changes. At the settings link he included, on the left hand side of the page there is a "Learn more" link under "Dynamic IP addresses". Please make sure you install either the OpenDNS updater or use some other method for updating your address when it changes. I suspect that will take care of your issue of OpenDNS not working for you when you turn the computer on.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    "I set up the Family Shield"
    "changed the Primary DNS to 208.67.222.222 and Secondary DNS to 208.67.220.220"

    Then you did not set up OpenDNS FamilyShield, but OpenDNS Home.  If you want to use OpenDNS FamilyShield, without individual dashboard settings and updater, feel free to configure 208.67.222.123 and 208.67.220.123 instead of the addresses you applied.

    "I notice it doesn't initially filter adult content."

    If you configure the OpenDNS FamilyShield addresses, it will do what you expect it to do.  You simply got the wrong resolver addresses for your purpose.  OpenDNS Home doesn't filter anything by default.

    0
    Comment actions Permalink
  • Avatar
    rjoem

    With your comments and information I was able install  the OpenDNS updater and so far so good. The real test is when I shut down and boot up my computer a few times over the next days and check the family's mobile devices. I'll keep you posted but looks good so far. Really appreciate your help and support. I'm extremely grateful!

    0
    Comment actions Permalink
  • Avatar
    rjoem

    Still having problems as it is not initially filtering adult content, as it does not seem to filter on my desktop of mobile devices after 1 hour or logging on to my DNS account. not sure whats happening as I did install the DNS updater and it automatically verified the Network and the IP address that's on my dashbord. Any other advice would be very much appreciated, as I guess I'm still doing something wrong. 

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Did you follow my proposal to configure 208.67.222.123 and 208.67.220.123?

    When you run again into the situation that things are not filtered initially, then copy & paste the complete plain text outputs of the following diagnostic commands here, so that I may see what's going on.

    nslookup -type=txt debug.opendns.com.
    nslookup www.exampleadultsite.com.

     

    0
    Comment actions Permalink
  • Avatar
    rjoem

    I left as is, and did not set to the Family Shield configuration that you mentioned above. I guess that will be my next approach if the diagnostic command doesn't help. Here it is...........

    C:\Users\rmisy>nslookup -type=txt debug.opendns.com.

    Server:  PK5001Z.PK5001Z

    Address:  192.168.0.1

    Non-authoritative answer:

    debug.opendns.com       text =   "server m7.ash"

    debug.opendns.com       text =   "flags 20 0 70 7950800000000000000"

    debug.opendns.com       text =  "originid 0"

    debug.opendns.com       text =  "actype 0"

    debug.opendns.com       text =  "source 67.237.3.37:64798"

     

    C:\Users\rmisy>nslookup www.exampleadultsite.com.

    Server:  PK5001Z.PK5001Z

    Address:  192.168.0.1

    Non-authoritative answer:

    Name:    www.exampleadultsite.com

    Addresses:  146.112.61.106

              146.112.61.106

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    The first output shows that your IP address 67.237.3.37 was still not registered at https://dashboard.opendns.com/settings/ when you executed the command.  Under these circumstances  your dashboard settings do not take effect.  Do you run an Updater?  Or do you update your IP address information manually?

    However, the second output shows that adult sites are being blocked for you.  The returned IP address 146.112.61.106 (hit-adult.opendns.com) is correct for this purpose.  Your IP address information must have been updated in between at your dashboard.

    After all it looks like your update process is a bit delayed for whatever reason.

    0
    Comment actions Permalink
  • Avatar
    rjoem

    I did install the updater . Do I need to register the IP address 67 237 3 3 37 at https//dashboard opendns.com/settings/. Can you please tell me how to do that.

    I ran the diagnostic again this morning when I knew it was not initially filtering and this is what came back........

    C:\Users\rmisy>nslookup -type=txt debug.opendns.com.

    Server:  PK5001Z.PK5001Z

    Address:  192.168.0.1

    Non-authoritative answer:

    debug.opendns.com       text =         "server m9.ash"

    debug.opendns.com       text =          "flags 20 0 70 7950800000000000000"

    debug.opendns.com       text =         "originid 0"

    debug.opendns.com       text =         "actype 0"

    debug.opendns.com       text =         "source 67.237.4.147:46617"

     

    C:\Users\rmisy>nslookup www.exampleadultsite.com.

    Server:  PK5001Z.PK5001Z   Address:  192.168.0.1

    Non-authoritative answer:

    Name:    www.exampleadultsite.com

    Address:  67.215.92.210

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    It seems your ISP has changed your IP address in the meantime to 67.237.4.147, but this was not registered at https://dashboard.opendns.com/settings/ when you executed the command.  Also the DNS lookup to www.exampleadultsite.com shows that adult domains were not being blocked at that time.

    "Do I need to register the IP address 67 237 3 3 37 at https//dashboard opendns.com/settings/. Can you please tell me how to do that."

    The Updater is supposed to do these IP address information updates automatically, but this can take up to 5 minutes until the information is propagated to all OpenDNS servers.  And you can manually update the information at https://dashboard.opendns.com/settings/ where you should see the currently registered IP address beside the new IP address and a green arrows icon between them.  If you click the icon, the IP address information update will take effect.

    As you have installed the Updater, does it report any errors, or does the IP address update history show that everything went well?  (You right-click the systray icon to access the history.)

    0
    Comment actions Permalink
  • Avatar
    rjoem

    When I installed the updater it did not report any errors, but I just reinstalled anyway. The IP History shows the  date and IP Address for the last 8 days I've had it. I don't see any errors as well, just the last 3-5 digits of the IP Address changing daily - see sample below.

    "And you can manually update the information at https://dashboard.opendns.com/settings/ where you should see the currently registered IP address beside the new IP address and a green arrows icon between them.  If you click the icon, the IP address information update will take effect." 

    I do not see the green arrows in my dashboard settings you mentioned above. I just see the following..............

    You are currently using the OpenDNS Home package that allows for only 1 network. You are currently using 1 networks. Most home networks generally have only one IP address. Have more than one? You should contact support. If you're a business, you should upgrade to Umbrella Enterprise to add more networks and get more great features!

     Your networks

    Label

    IP

     

    Stats

     

    Home

    67.237.4.147

         

        

     Date                             IP Address

    2017-01-13 21:36      67.237.2.34

    2017-01-17 21:30     67.237.12.137

    2017-01-21 10:22     67.237.4.147

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I do not see the green arrows in my dashboard settings you mentioned above."

    This is good.  In this case your IP address information is already updated, and the IP address appears in bold font.  All good then.

    After all, it seems you are impacted by the update delay of up to 5 minutes where your dashboard settings do not take effect.  Also, you should be aware that the Updater can work only if the user who has installed it is actually logged in on the PC.  If this is not the case, then this gap is even increased.  If you want an Updater which already works when the PC is switched on but nobody is logged in, you would have to use something like Marc's Updater.  This runs as Windows service in the background as soon as the PC is powered on.

    To cover this short-term gap when the PC is still not running and the IP address is being changed by your ISP, configuring the FamilyShield addresses instead of the normal ones is definitely the solution, because when using those, adult domains and proxy/anonymizer domains are blocked by default, independent from your dashboard settings.  You can use your dashboard in addition, of course, to block more than FamilyShield can block, or to collect stats, but not to whitelist what is being blocked by FamilyShield.

    0
    Comment actions Permalink
  • Avatar
    rjoem

    Thanks rotblitz for your detailed and informative explanation. That does sound correct in often getting the 5 minute delay, which is the time frame that I usually confirm the filtering status. At times I also just boot up my desktop without logging on, only to use the WIFI, which you pointed out can increase that delay -

    "Also, you should be aware that the Updater can work only if the user who has installed it is actually logged in on the PC.  If this is not the case, then this gap is even increased." 

    So I think I'll skip the option of downloading an alternative Updater and go with your earlier proposal of configuring the Family Shield to 208.67.222.123 and 208.67.220.123. Hopefully, this will work from the boot-up and without having any further issues. I truly appreciate your patience and guidance. 

     

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.