Updating Multiple A-recods in a Single Service

Comments

7 comments

  • Avatar
    rotblitz

    "Trying to create a second service for each A record throws a "This service already exists" error."

    I cannot reproduce this problem.  I could create several entries.

     

    "If I use any single host (www, ftp, or @) it works properly.  If I use the wildcard * it updates everything except the second level domain example.com."

    Where do you "use" this?  What update client do you use to send to DNS-O-Matic?  No matter, do not use wildcards, neither with your authoritative DNS configuration, nor in conjunction with DDNS updates.  It causes you just troubles.  I'm saving to be more detailed about this yet.

    As I understand your message, you want to update all your NameCheap hostnames through DNS-O-Matic.  In this case you specify no hostname at all or a special hostname all.dnsomatic.com in your update client, as documented at https://www.dnsomatic.com/wiki/api

    Alternatively, if you want to update e.g. example.com, www.example.com and ftp.example.com, visit your DNS hosting service and make the subdomains CNAME records pointing at example.com and update only example.com. Do not configure non-A record hostnames/services in DNS-O-Matic.

    "Is this a problem at Namecheap only?"

    Nope, not this and not a problem at DNS-O-Matic, just a user error. ;-)

  • Avatar
    semicycler (Edited )

    So I tried to duplicated your results on the dnsomatic.com website.  Logged into my account, then clicked your services.  Click the add a service button and select NameCheap.  For host I used www, password for password, and example.com for domain.  Saves correctly with the "waiting for first update" status.  Then repeat, add a service button, NameCheap.  For the second host I used ftp, password for password, and example.com for domain.  Pressing update account info gives a "You already have a service with that info." error and does not save it.

     

    edit:  looks like you used your username in the host field, don't think that's correct for NameCheap.  It should be the host you want to update or '*' for all except the 2nd level domain.

  • Avatar
    rotblitz (Edited )

    Ah yes, you are correct.  I used my nickname from here for the hostname and different domain names.

    Investigating further, I found this thread where this has been discussed widely already since 3 years:
    https://support.opendns.com/hc/en-us/community/posts/220007527
    There are several useful approaches but not the solution one would expect to see.

    Also, what prevents you from using my CNAME solution proposed above?

    "then clicked your services"

    My services?  I don't offer such services, I just use them, like you.  You certainly meant Cisco/OpenDNS/DNS-O-Matic, right?  Or NameCheap?

  • Avatar
    semicycler (Edited )

    Clearing up some confusion:

    "Your Services" hyperlink on the dnsomatic website after logging in. Not "you" or "your" as in rotblitz the user :)

    I use an ASUS router's built in DDNS client pointing to dnsomatic. It works flawlessly connecting when needed. DNSomatic then updates my OpenDNS without errors. And dnsomatic also updates NameCheap without errors when there is a single A record to update at NameCheap.

     

    The failures occur between dnsomatic and NameCheap when there are more than one A record to update. If I try to list mulitple hosts in the host field to pass to NameCheap, Name cheap throws an "A record not found" error back to dnsomatic (delimited by commas, spaces, semicolons, -a, and so on all fail). If I try to list one host on dnsomatic then create a second service on dnsomatic with a different host but the same domain it errors out with "You already have a service with that info". Presumably this is because dnsomatic is only looking at the domain field and not the host/domain field combiniation.

    Ok, I was able to work around the scenario in post #1 here by reworking the DNS records at NameCheap. Now there is a single A record and multiple CNAME records pointing to it. This way dnsomatic only updates one A record at NameCheap.

    But it still leaves me with a problem when I have multiple A records at NameCheap and want to update only a subset of them using dnsomatic. I know dd-wrt's built in DDNS client can do it directly (delimit the multiple hosts with -a). NameCheap's windows client can do it too. But for some reason dnsomatic can only update one A record at NameCheap.  Or am I missing something?

  • Avatar
    rotblitz

    Now I fully agree with everything. This makes sense. And it is consistent with the other thread. Best would be to raise another ticket with OpenDNS. It would be useful you report the outcome back then. Thanks!

  • Avatar
    semicycler

    Well, they admit it's an error and further admit there are no plans to fix it, closing it as "solved".  Too bad for people using NameCheap I suppose.

    The original support ticket is ID #280446.  The final posting to the ticket is coped below for reference.

    --------------------------

    Ashley Williams

    Hi there,

    Thank you for your patience. Currently, DNS-O-Matic does not support that particular NameCheap API endpoint, such that you'd be able to specify multiple domains to update using the <hostname> -a <hostname> -a syntax.

    Additionally, DNS-O-Matic only checks the domain for the service, rather than the hostname/domain combination, as you've already noted. At this time, there are no plans to change the way that this is implemented.

    That said, I have raised your feedback to our development team to see if they'll consider adding these changes in a future iteration of DNS-O-Matic.

    At this time, I will be marking this case as tentatively Solved, but if you have any further questions or concerns, please don't hesitate to reach out.

    Best regards,

    Ashley Williams
    Technical Support Engineer
    Cisco Umbrella

  • Avatar
    rotblitz

    Thanks for reporting this back.

Please sign in to leave a comment.