OpenDNS with D-Link DSL-2885A Router

Comments

3 comments

  • Avatar
    rotblitz (Edited )

    You may have to wait forever for an OpenDNS user having the same router.

    According to your user manual, you visit Internet > IPv4 Settings > Advanced Settings
    and enter 208.67.222.222 as Primary DNS Server and 208.67.220.220 as Secondary DNS Server.

    In case you have IPv6 connectivity, you visit Internet > IPv6 Settings > Advanced Settings
    and enter ::ffff:d043:dedc as Primary DNS Server and ::ffff:d043:dcde as Secondary DNS Server.

    "the router seems unable to pass these manual DNS server addresses to devices on the LAN."

    Sure, it is not supposed to do this!  Never!  It should propagate its own IP address as DNS server address to the devices, of course!  The router is to act as DNS server and DNS forwarder for the devices, as should be.  Only if you configured the DNS resolver addresses on the LAN/DHCP side of the router, they would be propagated to the end user devices.  This would be suboptimal, because external DNS resolvers on the LAN side break or at least impact local name resolution, because a public DNS service cannot resolve your private network names.

    "in this instance it did not solve the issue."

    What issue?  You forgot to tell me what the issue is...

    "if OpenDNS is compatible with the DSL-2885A"

    "Compatible" is the wrong term.  The capability to configure DNS on a device has nothing to do with compatibility.  It's at best a feature which is there or amiss.

    "which brings me back to my original question: is anyone successfully using OpenDNS with a D-Link DSL-2885A router?"

    Yes, of course.  It's hopefully you now!!  Do you need anybody else?

    0
    Comment actions Permalink
  • Avatar
    kh_2010

    Dear rotblitz,

    Thank you for your input, and your obvious expertise in these matters

    I had already done what you recommended - i.e. "According to your user manual, you visit Internet > IPv4 Settings > Advanced Settings and enter 208.67.222.222 as Primary DNS Server and 208.67.220.220 as Secondary DNS Server."  My experience is that even though these have been set, the router ignores these settings and continues to use the Internet Service Provider's DNS server addresses, and this is also entirely regardless of the enabling or disabling of the DNS relay setting in the router.

    So are you saying that you have a D-Link DSL-2885A that works with OpenDNS?  Until someone can actually tell me from first-hand experience that they have this working, I hold the view that possibly there is a bug in the router firmware.

    Thanks.

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    No, I don't have this router, and yes, this is obviously a router firmware bug.  Your best bet is to refer to D-Link support then.

    To see if there may be other reasons for not working, you may want to copy & paste the complete plain text output of the following diagnostic commands here:

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    nslookup -type=txt which.opendns.com. 208.67.220.220
    ipconfig /all

     

    0
    Comment actions Permalink

Please sign in to leave a comment.