How to set up DNS-O-MATIC for Cloudflare (and the other way around) and a FritzBox

Comments

11 comments

  • Avatar
    rotblitz

    I should mention that I have no relationship to these CloudFlare forum articles...
    My name is not John Roberts.

    2
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    "After searching and e-mailing with the supports of Cloudflare and DNS-O-MATIC for days (months)"

    You could have saved the efforts.  I would have told you within minutes...

    Btw, the following update URL on the FRITZ!Box is already sufficient:

    https://updates.dnsomatic.com/nic/update?myip=<ipaddr>

    The other parameters are obsolete.  And as domain name you specify one of the real hostnames you're updating through DNS-O-Matic, else your FRITZ!Box will raise error messages.

    1
    Comment actions Permalink
  • Avatar
    Fabiano1994 (Edited )

    Thanks for the info. I’ve updated my post with your FRITZ!Box settings.

    Everything worked flawlessly until DNS-O-MATIC moved from Cloudflare’s API1 to API4. Neither DNS-O-MATIC support nor Cloudflare support could help me what I have to change. Your post at https://support.cloudflare.com/hc/en-us/articles/206142407-Using-DNS-O-Matic-dynamic-DNS-updates-with-CloudFlare- and another article at https://support.cloudflare.com/hc/en-us/articles/206142407-Using-DNS-O-Matic-dynamic-DNS-updates-with-CloudFlare- gave me the hint how it works.

    1
    Comment actions Permalink
  • Avatar
    Fabiano1994 (Edited )

    changed my comment from "and the article at" to "and another article at". Now it has a whole new meaning ;-P

    0
    Comment actions Permalink
  • Avatar
    Fabiano1994

    It's over and over again funny, that in every community/forum are some semi VIPs which feeling the urge to be super correct. I appreciate your help and your knowledge, but in this way… Thanks and good bye.

    0
    Comment actions Permalink
  • Avatar
    brandong777

    This worked great for me up until the point I added another host. Then dynamic AND the new host would get updated. I worked around this by just creating a CNAME record that pointed at another one of my dynamic hostnames (asuscomm.com).

    0
    Comment actions Permalink
  • Avatar
    ashar_sultan

    Were you able to connect dnsomatic to Cloudflare using an API Token (labelled A) generated for just that domain or did you use the Cloudflare global API key (labelled B)


    Because the Cloudflare global API key has the same access as a password has to an account

    0
    Comment actions Permalink
  • Avatar
    jack_yaz (Edited )

    You can do this more easily, use @ as the hostname in both cloudflare and dns-o-matic

    0
    Comment actions Permalink
  • Avatar
    opendns

    Hey everyone,

    Kudos to @Fabiano1994 for providing this short summary. Helped a lot!

    I´m trying to understand how this might work with multiple domains.

    i do have the following scenary at the moment and ideally I would like to update multiple domains using the FritzBox DynDNS feature if possible.

    • Domain A with DNS at ChangeIP (to be migrated to Cloudflare in the near future)
    • Domain B with DNS at Cloudflare
    • Corresponding records for both domains at DNS-O-Matic

    At the moment my FritzBox DynDNS settings include "Domain B" in the DYNDNS Domain Name field, but I´d like to achieve that both domains (A and B) are updated.

    Any idea how to achieve this? I do have the DDClient installed on a Pi but unfortunately I never got it to work properly with Cloudflare.... So I´d either use Fritzbox DYNDNS or DDCLient to update both domains

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    The domain name field on the FritzBox is not the domain which will be updated, but the domain where the FritzBox checks with if an update is needed, and after the update if the update was successful.  So you can use any of your hostnames configured at DNS-O-Matic for the FritzBox domain name field to make it work.

    In other words: it should already work as you want it to work if you have set it up as outlined above.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Hmm, I'm still seeing "Your post at...".

    -2
    Comment actions Permalink

Please sign in to leave a comment.