Anyone using AsusWrt successfully?

Comments

9 comments

  • Avatar
    mattwilson9090

    We can't tell you if your configuration settings are wrong since we have no idea what those settings are. Please tell us how you configured it. A screenshot might be useful (attach it within this forum, don't include a link to a 3rd party file sharing site since it's likely that it will be blocked by other users here for security purposes).

    You should also check the ASUS forums to see if they have any specific information on that firmware.

  • Avatar
    bluepill42 (Edited )

    Hi,

    I thought I'd just see if anyone on the forum has the device working before going into the configuration detail; but, since you asked:

    server = www.dnsomatic.com (note: this is from a drop down list; no option to type a server name in)

    host = all.dnsomatic.com (note: there is no other place to type the domain in)

    user name or email address = the email address I use to log into dnsomatic and opendns websites

    password = the password I use to log into dnsomatic and opendns websites

    enable wildcard = no

    wan ip and hostname verfication = no

    As you can see it looks like AsusWrt is meant to support dnsomatic however I always get errors.

    This is the log entries for the configuration:

    Mar 21 06:58:41 ddns update: ez-ipupdate: starting...
    Mar 21 06:58:41 ddns update: connected to updates.dnsomatic.com (67.215.92.215) on port 80.
    Mar 21 06:58:41 ddns update: invalid hostname: all.dnsomatic.com
    Mar 21 06:58:41 ddns update: asusddns_update: 2 

    All the information I have found says I should use all.dnsomatic.com  Is there something else I should be using?

    Asus is a pretty popular router so I'm hoping that someone else has it up and running and can assist with info on how their setup works.

  • Avatar
    rotblitz (Edited )

    "I thought I'd just see if anyone on the forum has the device working"

    Oh, from my experience you'll have to wait for months if not years...
    ...but I may be able to help you nevertheless, because I know the API quite well.

    "invalid hostname: all.dnsomatic.com"

    Try with an empty host name field (DNS-O-Matic doesn't require one), or in case OpenDNS is the only service you have defined at DNS-O-Matic, try with the Label of your OpenDNS network as host name.  The latter may not work, because your router seems to expect an existing host name for whatever reason.

    Just in case, can you also select something like "user defined" from your drop-down list?

  • Avatar
    bluepill42

    I'm thinking that there's something wrong with the Asus implementation.  I can't put nothing in the hostname field and everything that I try gives me the same error in the logs.

    btw, there isn't an option from the drop down for anything like "user defined"; it just has a bunch of well known ddns services listed.

  • Avatar
    rotblitz

    Contact Asus support then, or check for a later firmware version.

  • Avatar
    bluepill42

    I've posted on some Asus forums and I'll wait and see.  I may replace my router if I can find one that properly supports dnsomatic.  I noticed that there aren't any listed on the website; however, do you happen to know of any that work (without flashing to dd-wrt or tomato)?

  • Avatar
    rotblitz

    Yes, mine.  This is an AVM FRITZ!Box.

  • Avatar
    appu123

    this can be solved by not using any special characters in username and password..like @....i successfully configured it using * instead of @.....for that first create an account in dnsomatic and then login opendns using that username and password instead of email adddress..

Please sign in to leave a comment.