Configuration of wifi router

Comments

6 comments

  • Avatar
    rotblitz

    Do the devices connected via WiFi even use OpenDNS?  http://welcome.opendns.com/

    If not, you must configure your WiFi router to use OpenDNS.  If this is not possible, you still can configure OpenDNS on the devices.

    If you want me to analyze this further, copy & paste the complete plain text outputs of the following diagnostic commands to here, from a computer connected to your WiFi router:

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config
    0
    Comment actions Permalink
  • Avatar
    ikjijwij

    Hi,

    It seems indeed that my wifi-router is not configured to use OpenDNS; here are the results:

    1) When my computer is connected to the wif-router (which in turn is connected to my modem):

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com.
    Server: sitecom.router
    Address: 192.168.0.1

    Non-authoritative answer:
    debug.opendns.com text =

    "server m11.ams"
    debug.opendns.com text =

    "flags 20 0 8050 3950000000000000000"
    debug.opendns.com text =

    "originid 78005219"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 9784581"
    debug.opendns.com text =

    "source 83.83.45.10:10204"

    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    Server: sitecom.router
    Address: 192.168.0.1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 208.69.35.17


    C:\WINDOWS\system32>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.0.102
    Subnet Prefix: 192.168.0.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.0.1
    Gateway Metric: 0
    InterfaceMetric: 35
    DNS servers configured through DHCP: 192.168.0.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: 192.168.0.1

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

     

    2) When my computer is connected to the modem:

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    debug.opendns.com text =

    "server m11.ams"
    debug.opendns.com text =

    "flags 20 0 8050 3950000000000000000"
    debug.opendns.com text =

    "originid 78005219"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 9784581"
    debug.opendns.com text =

    "source 83.83.45.10:54449"

    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 208.69.35.19


    C:\WINDOWS\system32>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.178.11
    Subnet Prefix: 192.168.178.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.178.1
    Gateway Metric: 0
    InterfaceMetric: 35
    DNS servers configured through DHCP: 208.67.222.222
    208.67.220.220
    208.67.222.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

     

    I suppose that I need to reconfigure something in the router settings. If you can give me hint of what to change, I would be very grateful :)

     

    0
    Comment actions Permalink
  • Avatar
    ikjijwij

    Hi again,

     

    Indeed my computers are all wired connected (either via the wifi router or the modem) to the internet, and openDNS works perfectly fine for these computers. It's just the mobile phones and tablets that are connecting via the wifi-router, and are somehow "working around" the OpenDNS. 

    I can try to switch on the wirelessmode of the modem, and see if the mobile devices are using OpenDNS when they're connecting to the wifi of the modem.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Seeing that my last response went into "Pending Approval", so posting as a screen shot:

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "It's just the mobile phones and tablets that are connecting via the wifi-router, and are somehow "working around" the OpenDNS."

    This is new information!  Well, it's hard to do such diagnostics on mobile devices.  The initial test would still be to visit http://welcome.opendns.com/ on them.

    To see if the router is the culprit, you better connect a computer wireless to execute the above diagnostic commands again, so that I can see what's going on.

    If the TCP/IP settings on the WLAN are as expected, then similar applies as said above: if the devices run Android, you'll have to switch off the Data Saver in the Chrome browser.  Ensure that no VPN is configured and being used.  For iOS devices also ensure that no VPN is being used.

    0
    Comment actions Permalink
  • Avatar
    ikjijwij

    Hi,

    Thanks for your help so far! I will try the things you suggested in a while. First I'm gonna enjoy some sunshine!

    0
    Comment actions Permalink

Please sign in to leave a comment.