he.net DDNS not updating

Comments

9 comments

  • Avatar
    rotblitz

    You missed the most important information: what does DNS-O-Matic say?  Just saying that it does not work is useless, and nobody can work with this information.  I.e. what is the status for this service at DNS-O-Matic, and what does the detailed update log say?  Only this can tell why it does not work.

  • Avatar
    clairelyclaire

    Sorry - all I can see is "Waiting for first update". The history shows nothing for either HE or Tunnelbroker. So it doesn't sound like it's updating at all.

    I added both to my account yesterday, and today they're still stuck on "waiting for first update".

  • Avatar
    rotblitz

    Ah yes, this is what I was looking for.  Firstly, did your IP address change since yesterday?  If not, your local update client may not even have attempted to raise an update, because there was no reason for.  If your IP address has changed...

    What did you do to your local client to cover the HE and Tunnelbroker services at DNS-O-Matic?  In case you want to update all your services through DNS-O-Matic with the same IPv4 address, then the hostname at your local client would have to be none/empty or all.dnsomatic.com (for clients requiring a hostname).

    If you cannot get your update client to raise an update, because e.g. your IP address did not change, you can raise a manual update via browser by visiting https://updates.dnsomatic.com/nic/update
    (You'll be asked for your OpenDNS/DNS-O-Matic credentials, and it will update all your services.)

  • Avatar
    clairelyclaire

    I think I have two separate problems: updating the client through the force-update URL or my router's DDNS support, and seeing whether or not my he.net subdomain has been successfully updated by DNS-O-Matic

    My IP hasn't changed in awhile - the last time I think he.net actually updated was several months ago (I shelved trying to fix this for awhile), and the IP it has is still current. Perhaps that's why there hasn't been an update yet?

    I'm using an ASUS router for my home network with Asuswrt-Merlin installed, which has DDNS support baked in. That said, I also haven't gotten the DNS-O-Matic option to work. I also can't log in to that update URL, but I just verified that my user/pass combo lets me log in to the OpenDNS and DNS-O-Matic websites. Hmmmm.

  • Avatar
    rotblitz

    "the IP it has is still current. Perhaps that's why there hasn't been an update yet?"

    Well, the updates are based on the Dyn API, and this requires that an update has to take place only in case where the IP address has actually changed.  If the programmers of your Asuswrt-Merlin firmware did their job right, they would have adhered to this policy.  No reason to be concerned, rather to the contrary.

    "I also can't log in to that update URL"

    What does this mean?  Any error message?  Did you ensure that your password does not contain any special characters reserved for URL encoding/escaping?  It must not contain such characters, else DDNS updates will generally fail, with all such and similar services, not just with DNS-O-Matic or OpenDNS.

  • Avatar
    clairelyclaire

    When I configure Asuswrt-Merlin, it tells me authentication failed. I keep getting a cred prompt on the update URL until it eventually fails and tells me I don't have access.

    My password does have a non-alphanumeric character in it, so I'll set a different password and see if that works.

  • Avatar
    rotblitz

    "When I configure Asuswrt-Merlin, it tells me authentication failed."

    This is consistent then with the observation from the manual update URL and most likely because of this special character in the password.  Yes, try with another password.  Best is to use only letters, numbers, dash, dot and under-bar.

  • Avatar
    clairelyclaire

    Finally got around to looking at this again - I used an underscore instead of an apostrophe, and sure enough, registration worked. Thanks!

  • Avatar
    rotblitz

    As I said.  Enjoy!

Please sign in to leave a comment.