Belkins router not updating to openDNS DNS address

Comments

9 comments

  • Avatar
    rotblitz

    If you configure OpenDNS on the WAN facing side of the router, then the OpenDNS resolver addresses are not propagated to the end user devices.  This is totally normal.  They are only propagated when configuring on the LAN/DHCP side of the router which is sub-optimal, because external resolver addresses on the LAN side impact or break local name resolution.

    So, what is your problem?  What does http://welcome.opendns.com/ return?

    Also, if you still have problems, copy & paste the complete plain text outputs of the following diagnostic commands to here when connected to the router where OpenDNS does not work:

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

     

  • Avatar
    flaunt

    Thanks for the reply. Yes I changed the DNS address on WAN side of router. But I cannot see DNS tab on LAN side of Belkins router. That must be the reason .


    It has just LAN settings and DHCP client list under LAN setup. Why is that ? Is there any other way to get client devices receive OpenDNS nameservers ? 

  • Avatar
    rotblitz (Edited )

    Why in the world would you want to get OpenDNS resolver addresses propagated to the end user devices?  This is not how it is to work, as I explained above already.  And it's ok if your router "has just LAN settings and DHCP client list under LAN setup", whatever it may look like.  I do not know Belkin routers, so I cannot really comment.

    It's fine that you configured the OpenDNS resolver addresses on the WAN side.  It should work as expected then.  If you still have problems with using OpenDNS, provide the information I asked for above.

    At least the OpenDNS resolver addresses "not distributed to computer connected to that router" is clearly a non-issue but how it is supposed to work.

  • Avatar
    flaunt

    Hi,

    The filtering of web-content I have done on openDNS is not working and neither the OpenDNS updater is showing ip.address . Therefore, as a troubleshoot, when I did ipconfig /all, I can see the end user computer is not taking openDNS nameserver. But as soon as I manually enter openDNS nameserver on wireless adapter on client computer, the settings of openDNS starts working. That is the reason why I thought openDNS nameserver was supposed to be propogated to end users. 

    Please find below the screenshots of information you asked for : 

  • Avatar
    rotblitz (Edited )

    Your router behind 192.168.5.1 sends the DNS traffic only randomly to OpenDNS at best.  This is either a firmware glitch, or you didn't configure your router right.  As I cannot see anything from your Thursday's screen shot, can you post again screen shots from the router page(s) where you have configured OpenDNS, probably under WAN/DNS and also under IPv6/Connection Settings in case you have IPv6 connectivity.

    General advices:
    Fill all DNS server fields with OpenDNS resolver addresses, and only with OpenDNS resolver addresses:
    For IPv4:  208.67.222.222;  208.67.220.220;  208.67.222.220;  208.67.220.222
    If you have IPv6 connectivity, fill also all DNSv6 fields with OpenDNS resolver addresses:
    ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde
    If this is not possible, disable IPv6 connectivity on the router altogether.

    The Updater and your OpenDNS dashboard are irrelevant as long as your DNS queries do not reliably go to OpenDNS.  You can test it at http://welcome.opendns.com/

  • Avatar
    flaunt

  • Avatar
    rotblitz

    This looks fine.  Does it work now?

  • Avatar
    flaunt

    NO it doesn't work. This is the configuration I did in the beginning and I haven't changed anything after that. And it hasn't worked until now. That is the reason why I wrote in this forum. 

    The issue I guess is end user computer isn't getting the nameserver from the router because as soon as I enter opendns nameserver manually on my computer, it works.

    When I connect my computer to my another router(Asus) and do ipconfig /all, i can see Opendns nameserver address next to DNS address. And opendns settings works . This makes me think that Belkins router isn't propogating opendns address and as a result opendns isn't working on my computer. But I couldn't figure out why ? 

  • Avatar
    rotblitz (Edited )

    "The issue I guess is end user computer isn't getting the nameserver"

    I say it again a 3rd time: no, the end user devices do not have to get the OpenDNS resolver addresses.  This happens only if you would be able to configure them on the LAN/DHCP side which is suboptimal.

    "When I connect my computer to my another router(Asus) and do ipconfig /all, i can see Opendns nameserver address next to DNS address."

    Yes, because you may have configured the OpenDNS resolver addresses on the LAN/DHCP side.

    "But I couldn't figure out why ?"

    It turns out that this problem is a router firmware glitch.  You would have to refer to Belkin support.  We cannot help you with device problems in the OpenDNS forum.  But check if you have the latest firmware version loaded.

    "as soon as I enter opendns nameserver manually on my computer, it works."

    Yes, sure, it works then.  And this is the workaround as long as the router firmware bug is not fixed.

Please sign in to leave a comment.