Cannot configure OpenDNS servers on Huawei HG8245 router, ISP MyRepublic Indonesia

Comments

2 comments

  • Avatar
    rotblitz (Edited )

    Not sure what help you're looking for.  What I can see from your command outputs is the following:

    Fact is that your ISP prevents you from using 3rd party DNS services, not your router.  You can circumvent this restriction by using DNSCrypt, as you successfully did, because DNSCrypt can use alternative ports and protocols, not being recognized as DNS traffic by your ISP.

    You could use your PC where DNSCrypt runs on as DNS server for your whole network, then all devices will be using OpenDNS.  Instead of listening on 127.0.0.1, you get DNSCrypt to listen on your PC's private external IP address, and you configure your other devices to use the PC's private external IP address as DNS server.

    0
    Comment actions Permalink
  • Avatar
    bayazidbh

    Ah, bummer. It's exactly as I feared. Still, thanks for the solution though. I know there is a global resolver option in DNSCrypt but didn't know how to use it before. And it works with my phone, too. Thanks.

    0
    Comment actions Permalink

Please sign in to leave a comment.