HP Deskjet 3520 Wont Connect to WIFI Airport Extreme with OpenDNS enabled

Comments

10 comments

  • Avatar
    rotblitz

    You must configure external DNS resolver addresses (like the OpenDNS ones) on the WAN side, not on the DHCP/LAN side of the router.  With the latter you will break or impact local name resolution.

  • Avatar
    amityweb

    Ok thanks, but any instructions anywhere how to do this? Would be quite a common issue I can imaging!
    Thanks

  • Avatar
    rotblitz

    Aren't these your instructions?  https://support.opendns.com/hc/en-us/articles/228006427

    I'm not so sure about this being a common issue, else it would be reported more often here.  Even more, if the printer doesn't connect via WLAN to the router, then this does not appear to have to do with OpenDNS.  You have to troubleshoot with your printer and your router then.  DNS is not needed to establish a WLAN connection.

  • Avatar
    amityweb (Edited )

    But thats what I have done, those instructions are just setting the router to use OpenDNS nameservers. When I do that, the printer wont connect to to the router via wifi. The nameservers I use are not the ones in those instructions, I use the family shield ones 208.67.222.123 and 208.67.220.123. 

    If you google it (link below) you can see lots of people having printer connecting issues with OpenDNS. Its just the solutions I found about getting the printer hostname and IP and using the hosts file to connect to the printer, does not work as the printer is not even connected to the router. 

    https://www.google.co.uk/search?num=50&biw=1211&bih=680&ei=7U4AWt6OFoaBmQHujZHwAw&q=printer+not+working+opendns&oq=printer+not+working+opendns&gs_l=psy-ab.3..0i8i30k1.13382.14227.0.14396.11.9.0.0.0.0.138.738.7j2.9.0....0...1.1.64.psy-ab..6.5.395...0i8i7i30k1.0.HXQ3qm5GGEM

  • Avatar
    rotblitz

    Yes, these problems are that people could not connect to their network printer from their computers, and not that the printer could not connect to the router via WLAN.  This is a big difference.  You must get the printer to establish a connection to the router before you can access and use it from another end user device.  And this is unrelated to DNS.

    If you still think it is OpenDNS, then simply try with configuring another DNS service, e.g. Google DNS (8.8.8.8 and 8.8.4.4) or Level-3 DNS (4.2.2.1 to 4.2.2.6), to see if it works then.  It it is OpenDNS' FamilyShield, then the problem must disappear when using Google DNS or Level-3 DNS, because these do not use any content filtering.  It the problem remains with Google and Level-3, then your problem has nothing to do with OpenDNS.

  • Avatar
    amityweb (Edited )

    Well, the reason I think its OpenDNS is because it works when I use my ISP DNS, then when I use OpenDNS it doesn't. I've repeated this test about 3 times!

    So in answer to your question, I have done all that. 

    It could be a big coincidence of course, but the only factor in my tests causing the issue is OpenDNS servers, so thought I would post here to see if anyone knows. If you say this is something new to you, it really should not be OpenDNS, I can keep investigating. 

    I have used this printer for years no problem. I am sure I have used OpenDNS for years too. I am sure it worked fine before, it has just been something like the last several months, 6 months or so. Cant be very accurate but it stopped this year, and I haven't changed anything. 

    I may have added other settings to the Airport Extreme router. I use a dynamic DNS service by duiadns.net and I have to enter their domain into the Domain Name box in the internet tab, and then in Internet Options "Use dynamic global hostname" so duiadns can update my hostname from my router as opposed to running software on a computer (as I do not have an always on computer that can run it). This is the only thing i can think of that was introduced earlier this year. 

     

  • Avatar
    amityweb

    Further info is when disabling OpenDNS I can do a WPS setup and I can go into the printer control panel and setup WIfi direct and it works. Then when I switch to OpenDNS on the router, the wifi no longer works. I can connect to the printer using its built in web server for the control panel, and then doing the wifi setup and test fails then! and the WPS wont work anymore either.

    The interesting thing is when using WPS, the Airport Extreme software says its successfully connected to the printer, and it names the printer, so you know its connected somehow, but the printer never finishes the setup and either says Timeout or there was an error. 

     

  • Avatar
    rotblitz

    "it works when I use my ISP DNS"

    Did you configure their DNS resolver addresses manually, same as the OpenDNS resolver addresses?  If not, then you cannot compare!  Try also with the other two DNS services and again with your ISP's, and don't simply say "I have done all that".

    And also your WPS issues could be exactly because of this.  Only if you manually configure different DNS services (one at a time), you can prove that it is really OpenDNS causing this problem, and not the manual configuration itself.

    "I haven't changed anything"

    Yes, this is indeed very often the root cause for issues, not keeping up with these many changes around.  It is not a warranty that anything still should work.

  • Avatar
    falsesfdsfdsf (Edited )

    "Did you configure their DNS resolver addresses manually, same as the OpenDNS resolver "

    If the OpenDNS nameservers are just deleted, the ISP DNS are then entered automatically, so I did not enter them in myself, they are added automatically if left blank. 

    "and don't simply say "I have done all that"."

    That was meaning that I followed the OpenDNS instructions on the link you sent. So I did do all that, what the instructions say. But using the family shield DNS.  

    "Only if you manually configure different DNS services (one at a time), you can prove that it is really OpenDNS causing this problem, and not the manual configuration itself."

    Ok will manually enter some. I can try entering Google's too, 8.8.8.8 and 8.8.4.4. I sometimes set my phone to that so I can bypass the YouTube block we put in place in OpenDNS so the kids cant watch it!

    Thanks

  • Avatar
    rotblitz (Edited )

    It seems your response went into "Pending approval".

    "If the OpenDNS nameservers are just deleted, the ISP DNS are then entered automatically, so I did not paste them in myself, they are added automatically if left blank."

    Correct, this is what happens.  But you must for sure test with other DNS services using the same method as for OpenDNS: you manually configure DNS server addresses.  Just removing the OpenDNS addresses to catch your ISP's DNS server addresses automatically via DHCP is not the same method and therefore does prove nothing.  My suspicion is that exactly this manual configuration causes your printer not being able to connect, regardless of what DNS server addresses you configure.

Please sign in to leave a comment.