DNS conflicts with home hub and video on demand etc.

Comments

4 comments

  • Avatar
    rotblitz (Edited )

    Could it be that your ISP uses private domain names for IPTV, not resolvable via public DNS services like OpenDNS, but only resolvable when using your ISP's DNS service?

    If it is this, then you have to contact your ISP to find out what you have to do to use public 3rd party DNS services like OpenDNS.  They probably will tell you that they expect you not using 3rd party DNS services...

    Your other option may be to connect another router to the Home Hub where you configure OpenDNS and connect all end user devices.  Just the IPTV remains connected to the Home Hub.

  • Avatar
    robtg

    Thanks.  I was able to get it working properly again and with Netflix/VOD working correctly too.  Seems like it may have just needed a restart of the modem after setting the manual DNS addresses.  Seemed to do the trick anyhow. 

  • Avatar
    thepylon

    Also make sure you add bell.ca to never block even if you set to not block. There were 3 bell domains being blocked on OpenDNS which seemed to be messing with stuff like Netflix, On Demand and even the space remaining function on the PVR. This is with a Segemcom 3000

  • Avatar
    otc_al (Edited )

    Had this problem going on for the last couple of weeks and finally figured it out.

    I set my Bell Home Hub 3000 (HH3K) to use OpenDNS instead of Bell's DNS. Our Netflix stopped working, but I didn't put much thought in to it and figured it was an internet hiccup. After 2 weeks of the Mrs' complaining, I figured I should look in to it. Upon packet inspection, it turns out that the HH3K is connecting to something on Bell's internal network.

    For example, I was seeing requests for:

    beapp001.iptv.bell.ca

    Which was then hitting: hit-block.opendns.com

    Hence when trying to access Netflix, I'd see a 403 (Forbidden) error.

    When you do a nslookup on beapp001.iptv.bell.ca, you should receive IP: 10.2.120.17, which is an Class A Network private IP. The problem here is that OpenDNS has a security setting "Suspicious Responses":

    Block internal IP addresses

    When enabled, DNS responses containing IP addresses listed in RFC1918 will be filtered out. This helps to preventDNS Rebinding attacks. For example, ifbadstuff.attacker.com points to 192.168.1.1, this option would filter out that response.

    The three blocks of IP addresses filtered in responses are:

    10.0.0.0     - 10.255.255.255  (10/8)
    172.16.0.0   - 172.31.255.255  (172.16/12)
    192.168.0.0  - 192.168.255.255 (192.168/16)
     
    --
    That setting was conflicting with my Netflix/VOD. Once disabled, the HH3K restarted, and then each IP TV box restarted, Netflix/VOD works like a champ.
     
    Hope that helps someone else and saves a marriage.
     
    - Al

Please sign in to leave a comment.