Help OpenDNS not working

Comments

21 comments

  • Avatar
    rotblitz

    Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config (for Windows only)

     

    0
    Comment actions Permalink
  • Avatar
    saveusall
    @roblitz, Below is my copy and paste running from the command line. I've followed the procedures to the 't' and still I get the "Oops not connected to OpenDNS" error.
     
    1) I logged into my DLINK (DIR-842 router) - given both correct .222.222 & .220.220 DNS to primary and secondary. removed the Host Name to now be blank (it was DIR-842 but all examples in the help files here on support.opendns show the Host Name blank).
    2) I've flushed the dns's via command line w/ success prompts following
    3) I've cleared by Browse history
    4) I've reset the computer
    5) Logged into router and re-confirmed the 220 & 222 DNS numbers
    6) Installed the OpenDNS Updater (v2.2.1) and it shows in red that I am not using OpenDNS
    7) Confirmed by router is using Dynamic IP and my IP listed on the router config matches the IP when I log into OpenDNS.com via my account (jrobe064)
     
    I don't know if its because of the 'dlinkrouter' being listed as the server (below) or if xfinity/Comcast won't allow the proper dns entry as shown below when I ran the "netsh interface ipv4 show config" command because I see both Comcast DNS and some concatenated OpenDNS dns....
     
    Looking for some assistance here - thanks!
     
    ----------------------------------------------------------------------------
    nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server:  resolver2.opendns.com
    Address:  208.67.220.220
    Non-authoritative answer:
    debug.opendns.com       text =        "server m25.ash"
    debug.opendns.com       text =        "flags 20 0 50 39500007E00400014C3"
    debug.opendns.com       text =        "originid 125004172"
    debug.opendns.com       text =        "actype 2"
    debug.opendns.com       text =        "bundle 10769042"
    debug.opendns.com       text =        "source 73.213.154.112:50207"
    ----------------------------------------------------------------------------------------------------
    nslookup -type=txt which.opendns.com.
    Server:  dlinkrouter
    Address:  192.168.0.1
    Non-authoritative answer:
    which.opendns.com       text =        "I am not an OpenDNS resolver."
    ----------------------------------------------------------------------------------------------------
    >nslookup whoami.akamai.net.
    Server:  dlinkrouter
    Address:  192.168.0.1
    Non-authoritative answer:
    Name:    whoami.akamai.net
    Address:  69.252.33.9
    ----------------------------------------------------------------------------------------------------
    netsh interface ipv4 show config
    Configuration for interface "Ethernet"
        DHCP enabled:                         Yes
        InterfaceMetric:                      5
        DNS servers configured through DHCP:
    68.87.74.162
    68.87.68.162
    208.67.222.220
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None
    Configuration for interface "Wi-Fi"
        DHCP enabled:                         Yes
        IP Address:                           192.168.0.102
        Subnet Prefix:                        192.168.0.0/24 (mask 255.255.255.0)
        Default Gateway:                      192.168.0.1
        Gateway Metric:                       0
        InterfaceMetric:                      55
        DNS servers configured through DHCP:  192.168.0.1
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None
    Configuration for interface "Loopback Pseudo-Interface 1"
        DHCP enabled:                         No
        IP Address:                           127.0.0.1
        Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
        InterfaceMetric:                      75
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None
    ----------------------------------------------------------------------------------------------------
    0
    Comment actions Permalink
  • Avatar
    zugwangz

    hi thanks for the reply rotblitz 

    C:\Users\user only>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com internet address = 36.86.63.182

    opendns.com
    primary name server = auth1.opendns.com
    responsible mail addr = noc.opendns.com
    serial = 1515872809
    refresh = 16384 (4 hours 33 mins 4 secs)
    retry = 2048 (34 mins 8 secs)
    expire = 1048576 (12 days 3 hours 16 mins 16 secs)
    default TTL = 2560 (42 mins 40 secs)

    C:\Users\user only>nslookup -type=txt which.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    opendns.com nameserver = auth1.opendns.com
    opendns.com nameserver = auth2.opendns.com
    opendns.com nameserver = auth3.opendns.com
    auth1.opendns.com AAAA IPv6 address = 2620:119:30::53
    auth1.opendns.com internet address = 208.69.39.2
    auth2.opendns.com AAAA IPv6 address = 2a04:e4c0:53::53
    auth2.opendns.com internet address = 146.112.60.53
    auth3.opendns.com internet address = 208.69.39.2

    C:\Users\user only>nslookup whoami.akamai.net.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    DNS request timed out.
    timeout was 2 seconds.
    Name: whoami.akamai.net
    Address: 180.241.108.241


    C:\Users\user only>netsh interface ipv4 show config

    Configuration for interface "Ethernet 2"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: 192.168.100.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 14"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi 3"
    DHCP enabled: Yes
    IP Address: 192.168.100.14
    Subnet Prefix: 192.168.100.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.100.1
    Gateway Metric: 0
    InterfaceMetric: 55
    Statically Configured DNS Servers: 208.67.222.222
    208.67.220.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Bluetooth Network Connection 3"
    DHCP enabled: Yes
    InterfaceMetric: 65
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    @zugwangz 

    I see that you have the OpenDNS resolver addresses configured on your computer, and that it is connected to the router via WiFi.  It looks like your ISP redirects your DNS queries to another DNS service.  You may want to call them opting out from this redirection, or you can try to circumvent it with https://dnscrypt.info/

     

    @saveusall 

    You could use OpenDNS via WiFi if your router at 192.168.0.1 would forward your DNS queries to OpenDNS, but it doesn't.  Are you sure that you have the router correctly configured?  If so, then your router ignores this configuration, and you had to refer to your router's supplier.

    In case you also want to use the "Ethernet" interface, you should correct the DNS configuration for this on the computer or on the router.

    0
    Comment actions Permalink
  • Avatar
    zugwangz

    THANK YOU SO MUCH ITS WORKING NOW !!!!!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @zugwangz

    How did you solve the problem?  Calling the ISP, or using DNSCrypt?

    0
    Comment actions Permalink
  • Avatar
    zugwangz

    using DNSCrypt

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Great, thanks for the information.

    0
    Comment actions Permalink
  • Avatar
    jems1304

    Could you help me with the same issue here, or do i need to start a new post? This is what I get when I run the command:

    C:\Users\ander.ANDERSONDESKTOP>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m17.pao"
    debug.opendns.com text =

    "flags 20 0 8050 180000000000000000003B504027F4070909ED3"
    debug.opendns.com text =

    "originid 30439859"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 7290755"
    debug.opendns.com text =

    "source 73.235.162.27:56969"

    C:\Users\ander.ANDERSONDESKTOP>nslookup -type=txt which.opendns.com.
    Server: cdns01.comcast.net
    Address: 2001:558:feed::1

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    C:\Users\ander.ANDERSONDESKTOP>nslookup whoami.akamai.net.
    Server: cdns01.comcast.net
    Address: 2001:558:feed::1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 96.114.18.141


    C:\Users\ander.ANDERSONDESKTOP>netsh interface ipv4 show config

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, you better would have opened your own thread.  Almost all messages here are about "OpenDNS not working", and it does not make sense to cumulate all in one thead.

    Also, you forgot to post the output of the last command.  I just see the command, not its output.

    And last but not least, your problem has been responded to in other threads.  There was no need to post here at all.

    Again, this is the DNS service you're using:

    Server: cdns01.comcast.net
    Address: 2001:558:feed::1

    Clearly not OpenDNS, but Comcast's DNSv6 service.  Configure also the IPv6 side with addresses from the following list:
    ::ffff:d043:dedc   ::ffff:d043:dcde   ::ffff:d043:dede   ::ffff:d043:dcdc

    0
    Comment actions Permalink
  • Avatar
    agokce

    Hi rotblitz,

    My router shows the following DNS servers. But OpenDNS is not blocking anything.

    DNS Server  
    208.67.222.222
    208.67.220.220

    Below is the output of the commands above. It seems DNS servers  are not used at all. What do I do? Thanks.

    C:\Users\algok>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    debug.opendns.com       text =

            "server m53.ash"
    debug.opendns.com       text =

            "flags 20 0 8050 180000000000000000003950000000000000000"
    debug.opendns.com       text =

            "originid 102448881"
    debug.opendns.com       text =

            "actype 2"
    debug.opendns.com       text =

            "bundle 10299739"
    debug.opendns.com       text =

            "source 96.231.151.86:59411"
    ====================================================================
    C:\Users\algok>nslookup -type=txt which.opendns.com.
    Server:  FIOS_Quantum_Gateway.fios-router.home
    Address:  192.168.1.1

    Non-authoritative answer:
    which.opendns.com       text =

            "m37.ash"
    ========================================================================
    C:\Users\algok>nslookup whoami.akamai.net.
    Server:  FIOS_Quantum_Gateway.fios-router.home
    Address:  192.168.1.1

    Name:    whoami.akamai.net
    Address:  2620:0:ccb::69

    ===============================================================
    C:\Users\algok>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
        DHCP enabled:                         Yes
        IP Address:                           192.168.1.153
        Subnet Prefix:                        192.168.1.0/24 (mask 255.255.255.0)
        Default Gateway:                      192.168.1.1
        Gateway Metric:                       0
        InterfaceMetric:                      25
        DNS servers configured through DHCP:  192.168.1.1
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 4"
        DHCP enabled:                         Yes
        InterfaceMetric:                      25
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 5"
        DHCP enabled:                         Yes
        InterfaceMetric:                      25
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Ethernet 2"
        DHCP enabled:                         Yes
        InterfaceMetric:                      35
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Bluetooth Network Connection"
        DHCP enabled:                         Yes
        InterfaceMetric:                      65
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
        DHCP enabled:                         Yes
        Default Gateway:                      192.168.1.1
        Gateway Metric:                       0
        InterfaceMetric:                      70
        Statically Configured DNS Servers:    8.8.8.8
                                              8.8.8.4
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
        DHCP enabled:                         No
        IP Address:                           127.0.0.1
        Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
        InterfaceMetric:                      75
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Not sure what you mean by "It seems DNS servers are not used at all".

    I do not see any problem as long as you use an Ethernet (wired) connection to the router.  But if you use Wi-Fi (wireless), you will be using Google Public DNS which you manually (and wrongly, 8.8.8.4 should be 8.8.4.4) configured on the computer:

    Statically Configured DNS Servers:    8.8.8.8
                                                         8.8.8.4

    You would have to change this settings to obtain the DNS server addresses automatically via DHCP from the router, or to change it to 192.168.1.1 (your router) as the only DNS server address.

    0
    Comment actions Permalink
  • Avatar
    agokce

    Rotblitz,

    Thank you for the response. I am using a wired connection at my desktop but it doesn't block anything.

    I wasn't able to find the statically configured DNS server setting at my router, could you point me to where I should look. My router is FIOS-G1100.

    Thanks!

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    I wasn't talking about your router, but I clearly said: But if you use Wi-Fi (wireless), you will be using Google Public DNS which you manually (and wrongly, 8.8.8.4 should be 8.8.4.4) configured on the computer.

    According to your command outputs, you are using OpenDNS when using the Ethernet connection.  You can check it also by visiting http://welcome.opendns.com/
    If nothing is being blocked, then there are chances that your IP address is not properly registered at https://dashboard.opendns.com/settings/ or you didn't configure your dashboard to block domains you want to have blocked, or you use a browser plugin which circumvents your DNS configuration.

    I do not know your router FIOS-G1100, but if you want, you can post a screen shot of the page where you configured OpenDNS.
    See also https://support.opendns.com/hc/en-us/articles/228008607

    You may also post the output of the following commands:

    nslookup -type=txt debug.opendns.com.
    nslookup www.internetbadguys.com.
    nslookup www.exampleadultsite.com.

     

    0
    Comment actions Permalink
  • Avatar
    agokce

    This is embarrassing but the filtering was set to none at the dashboard. Fixed it and it is working now.

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Sometimes it is so easy to do things right...  ;-)

    0
    Comment actions Permalink
  • Avatar
    rafaeduard.luque

    Hi rotblitz

    This is my case, please give me your diagnostic:

    C:\Users\Uusuario>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Servidor: resolver2.opendns.com
    Address: 208.67.220.220

    Respuesta no autoritativa:
    debug.opendns.com text =

    "server m53.ash"
    debug.opendns.com text =

    "flags 20 0 8050 180000000000000000003950000000000000000"
    debug.opendns.com text =

    "originid 228168748"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 11827150"
    debug.opendns.com text =

    "source 186.91.106.1:52917"

    C:\Users\Uusuario>nslookup -type=txt which.opendns.com.
    Servidor: dns-ace-01.datacenter.cha.cantv.net
    Address: 200.44.32.12

    Respuesta no autoritativa:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    C:\Users\Uusuario>nslookup -type=txt whoami.akamai.net.
    Servidor: dns-ace-01.datacenter.cha.cantv.net
    Address: 200.44.32.12

    *** No hay registros text (TXT) disponibles para whoami.akamai.net.

    C:\Users\Uusuario>netsh interface ipv4 show config

    Configuración para la interfaz "Conexión de área local"
    DHCP habilitado: Sí
    Dirección IP: 192.168.1.2
    Prefijo de subred: 192.168.1.0/24 (máscara 255.255.25
    5.0)
    Puerta de enlace predeterminada: 192.168.1.1
    Métrica de puerta de enlace: 0
    Métrica de interfaz: 20
    Servidores DNS configurados estáticamente: 200.44.32.12
    200.44.32.13
    Registrar con el sufijo: Solo el principal
    Servidores WINS configurados a través de DHCP: ninguno

    Configuración para la interfaz "Loopback Pseudo-Interface 1"
    DHCP habilitado: No
    Dirección IP: 127.0.0.1
    Prefijo de subred: 127.0.0.0/8 (máscara 255.0.0.0)
    Métrica de interfaz: 50
    Servidores DNS configurados estáticamente: ninguno
    Registrar con el sufijo: Solo el principal
    Servidores WINS configurados estáticamente: ninguno

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    I'm not really sure what you're asking for.  This is the DNS service you're actually using and which you have manually configured on your computer:

    Servidores DNS configurados estáticamente: 200.44.32.12  (dns-ace-01.datacenter.cha.cantv.net)
                                                                         200.44.32.13  (dns-ace-02.datacenter.cha.cantv.net)

    If you don't want to use this, simply configure another, for example OpenDNS.
    https://support.opendns.com/hc/en-us/articles/228006887

    If you have configured OpenDNS on your router, then you can also obtain the network settings (including DNS) automatically via DHCP from the router.

    0
    Comment actions Permalink
  • Avatar
    ashutosh.a

    @rotblitz : first thanks for helping people like us. 

    opendns doesn't seem to be working as the sites that I am trying to block are still going through. Here are the outputs. Will appreciate your guidance please:

     

    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.

    C:\Users\Admin>nslookup -type=txt debug.opendns.com 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server r1.mum1"
    debug.opendns.com text =

    "flags 40020 0 50 180000000000000000003950600FF4055121CD3"
    debug.opendns.com text =

    "originid 156438890"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 11210606"
    debug.opendns.com text =

    "source 117.99.90.148:61795"

    C:\Users\Admin>nslookup -type=txt which.opendns.com
    Server: UnKnown
    Address: 192.168.1.1

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    opendns.com nameserver = auth1.opendns.com
    opendns.com nameserver = auth2.opendns.com
    opendns.com nameserver = auth3.opendns.com
    auth1.opendns.com AAAA IPv6 address = 2620:119:30::53
    auth1.opendns.com internet address = 208.69.39.2
    auth2.opendns.com AAAA IPv6 address = 2a04:e4c0:53::53
    auth2.opendns.com internet address = 146.112.60.53
    auth3.opendns.com internet address = 208.69.39.2

    C:\Users\Admin>nslookup whoami.akamai.net
    Server: UnKnown
    Address: 192.168.1.1

    Non-authoritative answer:
    Name: net.domain.name
    Address: 185.82.212.199
    Aliases: whoami.akamai.net.domain.name


    C:\Users\Admin>netsh interface ipv4 show config

    Configuration for interface "Local Area Connection* 12"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Bluetooth Network Connection"
    DHCP enabled: Yes
    InterfaceMetric: 40
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.1.8
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 20
    DNS servers configured through DHCP: 192.168.1.1
    208.67.222.222
    208.67.220.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 50
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None


    C:\Users\Admin>

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Your router doesn’t work as you expect it to work. It doesn’t forward your DNS queries to OpenDNS. Can you post a screenshot of the router page where you have configured OpenDNS?

    Also, you forgot the trailing dot after the domains, so that the nslookup commands may have returned useless results. You better repeat:
    nslookup whoami.akamai.net.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    I have seen from a notification e-mail that you responded, but I do not see the response here, so I believe your comment is still in status "pending approval".  You must raise a support ticket, link "Submit a request" above, to get your comment released.

    Unfortunately your screenshot is not retained in the e-mail, so I just see the command outputs which do not really reveal any additional information.

    As I said, the problem seems to be with your router.  Its DHCP server propagates the following DNS addresses to the end user devices: 192.168.1.1, 208.67.222.222 and 208.67.220.220.  It should be propagating either only its own address or the OpenDNS addresses, never mixed stuff.

    Now the problem is that DNS queries via 192.168.1.1 are not being forwarded to OpenDNS by the router, but to another DNS service, probably your ISP's (Bharti Airtel Ltd., India).

    After all, this is clearly a router firmware bug where the community here cannot help with.  You may want to contact support for your router.

    0
    Comment actions Permalink

Please sign in to leave a comment.