xhamster.com has found a way past block

Comments

12 comments

  • Avatar
    rotblitz (Edited )

    We cannot try out your settings.  Our settings are certainly different.  And no, I don't believe you.  But I can have a look to see why your settings and configuration allows to access xhamster.com.

    Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com.
    nslookup xhamster.com.

     

  • Avatar
    bunibrat07

    I dunno either our business network needs to be secure. So, thank you for the help. 

    Where do i insert this command line?
    nslookup -type=txt debug.opendns.com.
    nslookup xhamster.com.


  • Avatar
    rotblitz (Edited )

    You open a command prompt / terminal window on a Windows, Mac OS X or Linux computer where you enter and execute the commands.  There is no other place on any computer where you can enter system commands...
    The syntax is everywhere the same for the nslookup command.

    "our business network needs to be secure"

    So you're using Cisco Umbrella?  Because Cisco OpenDNS Home is licensed for home/household use only.  No worries, the diagnostics are good also for Umbrella.

  • Avatar
    bunibrat07

    Last login: Thu Oct 26 06:51:49 on console

    homes-Macintosh:~ home$ nslookup -type=txt debug.opendns.com.

    Server: 10.0.0.1

    Address: 10.0.0.1#53

     

    Non-authoritative answer:

    debug.opendns.com text = "server m45.chi"

    debug.opendns.com text = "device 00000C61B1007223"

    debug.opendns.com text = "flags 422 0 8010 3840000100000000000"

    debug.opendns.com text = "originid 63235841"

    debug.opendns.com text = "actype 1"

    debug.opendns.com text = "bundle 63235841"

    debug.opendns.com text = "source 172.79.241.22:38112"

     

    Authoritative answers can be found from:

     

    homes-Macintosh:~ home$ nslookup xhamster.com.

    Server: 10.0.0.1

    Address: 10.0.0.1#53

     

    Non-authoritative answer:

    Name: xhamster.com

    Address: 146.112.61.104

     

     

  • Avatar
    rotblitz (Edited )

    Brilliant, DNS lookups for xhamser.com are being blocked for you on this Mac computer.

    The returned IPv4 address is 146.112.61.104 (hit-block.opendns.com) which means it is blocked for you via your "always block" policy list.  The real addresses needed to connect to the site would be:

    Name:    xhamster.com
    Addresses:  2a02:b48:4000:d::1
              2a02:b49:4:8::1
              88.208.29.24
              88.208.18.30

    It was good to not believe you.  How could you say "xhamster.com has found a way past block"?  Or could it be that your web browser ignores your system settings, but uses it's own DNS service?

    What does a visit of http://welcome.opendns.com/ return with on this browser?  And what about a visit of http://www.exampleadultsite.com/ ?

    Also, you have Live Parental Controls enabled on the router, and the LPC dashboard is only at http://netgear.opendns.com/ 

    If you want to use OpenDNS Home or Umbrella, you should disable LPC, because LPC is incompatible with the other services.

  • Avatar
    dave031387

    I just tried entering the same two commands that bunibrat07 did, and it is returning the correct IP for xhamster.com. It is not being blocked. I have just enabled this feature on my laptop a few minutes ago. Do I need to reboot for the changes to take effect? I have tried this in Microsoft Edge (both normal and "in private" modes) and Google Chrome. Same results in all three. Here are the responses from the two commands -

    C:\>nslookup -type=txt debug.opendns.com
    Server:  UnKnown
    Address:  2601:405:8402:ee54:eafc:afff:fefd:c5c9
    Non-authoritative answer:
    debug.opendns.com       text =
            "server m33.chi"
    debug.opendns.com       text =
            "device EF0A0AA0000EFE73"
    debug.opendns.com       text =
            "flags 422 0 70 7950800000000000000"
    debug.opendns.com       text =
            "originid 0"
    debug.opendns.com       text =
            "actype 0"
    debug.opendns.com       text =
            "source 68.34.32.108:35663"
    C:\>nslookup xhamster.com
    Server:  UnKnown
    Address:  2601:405:8402:ee54:eafc:afff:fefd:c5c9
    Non-authoritative answer:
    Name:    xhamster.com
    Addresses:  2a02:b48:4000:d::1
              2a02:b49:4:8::1
              88.208.29.24
              88.208.18.30
  • Avatar
    dave031387

    Okay, I think I figured out what was wrong. I had to add a network on the OpenDNS site for my home network. After doing that, the two nslookup commands now return the correct results, and the xhamster.com domain is getting blocked. Thanks!

  • Avatar
    rotblitz

    "I have just enabled this feature on my laptop a few minutes ago."

    Hardly.  You have Live Parental Controls enabled on the router, and the LPC dashboard is only at http://netgear.opendns.com/ 

    If you now want to use OpenDNS Home, you should disable LPC, because these two services are incompatible.  Also, it seems you have IPv6 connectivity.  I'm not sure if this has influence and also IPv6 resolver addresses need to be configured, ::ffff:d043:dedc and ::ffff:d043:dcde.

  • Avatar
    dave031387
    Okay, I didn't realize I needed to disable LPC. I have done that and I have also followed the instructions on your website for configuring OpenDNS filtering. I entered the first two of three IP addresses you give into the two DNS server slots in the router configuration of my NETGEAR Nighthawk X6. I then clicked the test link on your webpage and it indicated that I had things configured correctly and was now protected by OpenDNS. I tried a few domains as well to verify, and they were blocked with the exception of xhamster. That domain is still getting through. In your reply you mentioned that "IPv6 resolver addresses need to be configured." But you don't mention where or how. Is that the piece I'm missing? I get slightly different results now when I enter the two nslookup commands mentioned earlier in this thread:
     
    C:\>nslookup -type=txt debug.opendns.com
    9.c.5.c.d.f.e.f.f.f.f.a.c.f.a.e.0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa
            primary name server = localhost
            responsible mail addr = nobody.invalid
            serial  = 1
            refresh = 600 (10 mins)
            retry   = 1200 (20 mins)
            expire  = 604800 (7 days)
            default TTL = 10800 (3 hours)
    Server:  UnKnown
    Address:  fe80::eafc:afff:fefd:c5c9
    Non-authoritative answer:
    debug.opendns.com       text =
            "server m25.chi"
    debug.opendns.com       text =
            "flags 20 0 50 39500007C0000000000"
    debug.opendns.com       text =
            "originid 111598250"
    debug.opendns.com       text =
            "actype 2"
    debug.opendns.com       text =
            "bundle 10523170"
    debug.opendns.com       text =
            "source 68.34.32.108:50549"
     
    C:\>nslookup xhamster.com
    9.c.5.c.d.f.e.f.f.f.f.a.c.f.a.e.0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa
            primary name server = localhost
            responsible mail addr = nobody.invalid
            serial  = 1
            refresh = 600 (10 mins)
            retry   = 1200 (20 mins)
            expire  = 604800 (7 days)
            default TTL = 10800 (3 hours)
    Server:  UnKnown
    Address:  fe80::eafc:afff:fefd:c5c9
    Non-authoritative answer:
    Name:    xhamster.com
    Addresses:  2a02:b48:4000:d::1
              2a02:b49:4:8::1
              146.112.61.106
     
    Thanks for your help!
    Dave
  • Avatar
    rotblitz (Edited )

    "I have also followed the instructions on your website for configuring OpenDNS filtering."

    Hardly.  I do not have such instructions on my websites.  I'm just a user, not OpenDNS staff member.

    And yes, you still can reach xhamster.com over IPv6, but not over IPv4.  Try with configuring the IPv6 resolver addresses I listed above in the IPv6 settings of your computer or your router.  (No idea where you configured OpenDNS for IPv4.  You said on your laptop, so configure on the same device for IPv6 too.)  According to your router's user manual this could be doable also on the router, depending on the type of IPv6 connection you have.  If you don't need to access the IPv6 internet, you also may be able to disable IPv6 connectivity altogether.

    Alternatively, get rid of OpenDNS Home, but use LPC instead.  You can perform the same filtering there, but you do not have stats and logs with LPC.

  • Avatar
    dave031387

    I fixed my issue by configuring my router to do IPv6 pass through. According to the user guide, "In pass-through mode, the router works as a Layer 2 Ethernet switch with two ports (LAN and WAN Ethernet ports) for IPv6 packets. The router does not process any IPv6 header packets." That seemed to do the trick. Now when I enter the two nslookup commands you mentioned earlier, I get the following. Thanks for your help!

    C:\>nslookup -type=txt debug.opendns.com
    1.1.168.192.in-addr.arpa
            primary name server = localhost
            responsible mail addr = nobody.invalid
            serial  = 1
            refresh = 600 (10 mins)
            retry   = 1200 (20 mins)
            expire  = 604800 (7 days)
            default TTL = 10800 (3 hours)
    Server:  UnKnown
    Address:  192.168.1.1
    Non-authoritative answer:
    debug.opendns.com       text =
            "server m33.chi"
    debug.opendns.com       text =
            "flags 20 0 50 39500007C0000000000"
    debug.opendns.com       text =
            "originid 111598250"
    debug.opendns.com       text =
            "actype 2"
    debug.opendns.com       text =
            "bundle 10523170"
    debug.opendns.com       text =
            "source 68.34.32.108:58623"
     
    C:\>nslookup xhamster.com
    1.1.168.192.in-addr.arpa
            primary name server = localhost
            responsible mail addr = nobody.invalid
            serial  = 1
            refresh = 600 (10 mins)
            retry   = 1200 (20 mins)
            expire  = 604800 (7 days)
            default TTL = 10800 (3 hours)
    Server:  UnKnown
    Address:  192.168.1.1
    Non-authoritative answer:
    Name:    xhamster.com
    Addresses:  146.112.61.106
              146.112.61.106
  • Avatar
    rotblitz

    Well done!

Please sign in to leave a comment.