DNS incorrect result

Comments

7 comments

  • Avatar
    dcfraser

    Here is an example of the problem:

    Using my current set-up.

    nslookup facebook.com
    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    Name:    facebook.com
    Addresses:  146.112.61.106
              146.112.61.106

    Forced Goolge DNS lookup

    nslookup facebook.com 8.8.8.8
    Server:  google-public-dns-a.google.com
    Address:  8.8.8.8

    Non-authoritative answer:
    Name:    facebook.com
    Addresses:  2a03:2880:f11b:83:face:b00c:0:25de
              31.13.91.36

    0
    Comment actions Permalink
  • Avatar
    dcfraser

    Update:
    It would seem that these errors are a result of DynDNS failure:

    2017-11-11 14:26:57.5 >>>>>  DDNS is updating.  <<<<<
    2017-11-11 14:26:57.5 A= xxx@xxx.com, H= myip, U= 1
    2017-11-11 14:26:57.3 Connecting to the DDNS server (0x43d75cd2)...
    2017-11-11 14:26:58.5 Return Code= yours
    2017-11-11 14:26:58.5 Account updating error.

    I will open a new forum message.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    It seems your current IP address is registered with another OpenDNS user's dashboard, so you are using his settings, not yours.  Obtain another IP address from your ISP, or open a support ticket with OpenDNS to get your IP address released.  You may also be able to contact the other user via block page.

    No, do not open another forum message.  You already posted in too many threads.

    0
    Comment actions Permalink
  • Avatar
    dcfraser

    Yes you are right, I have investigated it further and there is a reason why somebody else has that IP address.
    Ultimately this has come down to the fact that my Internet connection is a 4G connection and the Internet IP address is actually shared between multiple 4G users.

    In short there is no fix because whoever grabs the service first is the winner.

    As an alternative I could switch to use the FamilyShield service, which is better than nothing.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    No, you got it wrong.  Even if you use the FamilyShield addresses, you still are bound to this other user's settings.  Also FamilyShield uses the dashboard if the IP address is registered.

    And there is a fix too: nobody should be able to register shared IP addresses with OpenDNS.  You simply open a support ticket with OpenDNS, and they release the IP addresses and put them on a list which prevents from being able registering them going further.  From this point on you can use also FamilyShield.

    "whoever grabs the service first is the winner."

    But only until your ticket is actioned.

    0
    Comment actions Permalink
  • Avatar
    dcfraser

    Thanks for the clarification.
    >"No, you got it wrong.  Even if you use the FamilyShield addresses, you still are bound to this other user's settings"
    I found that out by trial and error and thought that it was probably designed that way but raised the question in a support ticket. However, and no disrespect, the person who answered was clueless and never actually answered my question. If I didn't know better I would have thought they were an AI BOT as the answers were in the right topic but disconnected to the question.

    Anyway you have answered and clarified my question here,
    thanks.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "the person who answered was clueless and never actually answered my question."

    Although this is a typical attitude I've often experienced with several front-line support teams, even in the company where I work, it is rather untypical for OpenDNS.  This may be a new inexperienced employee still needing a lot of training and knowledge transfer...

    If you open a ticket with clear and detailed information, i.e with this shared IP address and what the problem is with it, I'm sure this will land in the right hands, and the issue will be rectified soon.

    0
    Comment actions Permalink

Please sign in to leave a comment.