OpenDNS stops working regularly

Comments

16 comments

  • Avatar
    jaquiring

    If anyone is wondering, I have Spectrum internet, and my router is Sagemcom F@st 5260

  • Avatar
    jaquiring (Edited )



    Here's a screenshot of my router settings. OpenDNS doesn't have anything for this router, so could someone help me out? 

  • Avatar
    rotblitz

    "Is there a problem with my OpenDNS software? "

    No, the Updater is just to keep your IP address information registered at OpenDNS, so that your dashboard settings can take effect.  This is unrelated to testing at http://welcome.opendns.com/ to see if your DNS traffic goes to OpenDNS.

    In your screen shot you show only IPv4 settings.  What is with the IPv6 settings?

    When the problem occurs again, copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config (Windows only)
    ifconfig -a (Mac OSX and Linux)

    I may see then what your problem is.

  • Avatar
    jaquiring

    I've tried with ipv6 both enabled and disabled on my router. Here's the settings:

    I'll try to post those diagnostics later. It stopped working last night before I went to bed, and I was intending to run these this morning, but it's working again. I'll update later. 

  • Avatar
    rotblitz (Edited )

    If you enable IPv6 and want your dashboard settings taking effect, you must use from the following OpenDNS resolver addresses:  ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    The listed addresses in your screen shot do not use your dashboard settings at all, but are pure DNSv6 resolvers, as documented.

  • Avatar
    jaquiring

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m29.dfw"
    debug.opendns.com text =

    "flags 20 0 50 39504007D0000001000"
    debug.opendns.com text =

    "originid 104758727"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 10358765"
    debug.opendns.com text =

    "source 66.169.110.244:63219"

    ----

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    ----

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 68.114.44.107

    ----

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.1.15
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 25
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 2"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

  • Avatar
    rotblitz

    As I thought, you're not using OpenDNS, but this DNSv6 service:

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Follow my instructions above for configuring IPv6 to use OpenDNS.

  • Avatar
    jaquiring

    I did follow your instructions, but it still didn't seem to be working. I think the router is deciding when to use the assigned DNS servers and when to use the default servers.

    Even after a fresh restart, OpenDNS seems to be working properly from my desktop (hardwired to the router), but does not work on either my tablet or phone, connected via wifi. 

    I included the screenshot showing ipv6 settings.

  • Avatar
    jaquiring

    Here are the results of those commands after restarting the router: 

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m25.dfw"
    debug.opendns.com text =

    "flags 20 0 50 39504007D0000001000"
    debug.opendns.com text =

    "originid 104758727"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 10358765"
    debug.opendns.com text =

    "source 66.169.110.244:61236"

    ----

    Server: HG6Box
    Address: 192.168.1.1

    Non-authoritative answer:
    which.opendns.com text =

    "m49.dfw"

    ----

    Server: HG6Box
    Address: 192.168.1.1

    Non-authoritative answer:
    which.opendns.com text =

    "m49.dfw"

    C:\Users\Josh>nslookup whoami.akamai.net
    Server: HG6Box
    Address: 192.168.1.1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Addresses: 2620:0:cc6::167
    204.194.238.169

    ----

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.1.15
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 25
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 2"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

  • Avatar
    jaquiring

    If I unplug my desktop and use the wifi, OpenDNS doesn't work. I ran those commands again and got the following results:

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m33.dfw"
    debug.opendns.com text =

    "flags 20 0 50 39504007D0000001000"
    debug.opendns.com text =

    "originid 104758727"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 10358765"
    debug.opendns.com text =

    "source 66.169.110.244:56919"

    ----

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    ----

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 68.114.44.103

    ----

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.1.15
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 5
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 2"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
    DHCP enabled: Yes
    IP Address: 192.168.1.10
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 35
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

    ----

    So, it would seem that my router is not using OpenDNS for wireless connections but is using it for wired connections. To add further confusion, it seems to stop using OpenDNS for wired connections at random, only to be resolved by resetting the router. 

  • Avatar
    jaquiring

    What's even weirder is that everything worked perfectly when I set it up, both wired and wireless connections. 

  • Avatar
    rotblitz (Edited )

    Well, the main reason for issues seems to be your dual-stack (IPv4 + IPv6) internet connection.  Sometimes your components use IPv4, sometimes IPv6, the latter randomly(?) to OpenDNS and to Charter, to send out your DNS traffic.  This can be your computer (or other end devices) or your router or both participating in this inconsistency.  It seems you need to concentrate on your IPv6.

    Everytime it does not work your computer uses Charter's DNSv6 service, not OpenDNS:

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    See here what is being configured manually or via DHCP:

    netsh interface ipv6 show addresses
    netsh interface ipv6 show dnsservers
    nslookup whoami.akamai.net.

    With the first command you should see public IPv6 addresses for the interface to the router (wired or wireless) to confirm that you have IPv6 connectivity at this time.  And with the second command you should see only IPv6 DNS addresses you have configured on the router and/or maybe your router's link-local IPv6 address, having been obtained via DHCP, not Charter's and not any other.  The third command shows what DNS service your computer is using and what recursive DNS service (e.g. OpenDNS or Charter, DNSv4 or DNSv6) is seen by Akamai.

    At the end you may be forced to disable IPv6 connectivity on the router, but you will lose the ability to reach IPv6-only domains then.

  • Avatar
    jaquiring

    Running the commands while connected to the ethernet port, I get the following:

    Interface 9: Ethernet

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Preferred infinite infinite fe80::fd2d:a74b:f0a1:3d6b%9

    Interface 4: Wi-Fi

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Dhcp Deprecated infinite infinite 2600:6c56:417f:ebf3:0:ac92:42b1:27be
    Other Deprecated infinite infinite fe80::b5ba:3869:3f33:9755%4

    Interface 1: Loopback Pseudo-Interface 1

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Preferred infinite infinite ::1

    Interface 6: Local Area Connection* 2

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Deprecated infinite infinite fe80::3d91:cd0:3ded:ad65%6

    Interface 7: Teredo Tunneling Pseudo-Interface

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Public Preferred infinite infinite 2001:0:4137:9e76:c99:2922:bd56:910b
    Other Preferred infinite infinite fe80::c99:2922:bd56:910b%7

    ----

    Configuration for interface "Ethernet"
    DNS servers configured through DHCP: 2607:f428:ffff:ffff::1
    2607:f428:ffff:ffff::2
    Register with which suffix: Primary only

    Configuration for interface "Local Area Connection* 2"
    DNS servers configured through DHCP: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Wi-Fi"
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
    Statically Configured DNS Servers: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Teredo Tunneling Pseudo-Interface"
    Statically Configured DNS Servers: None
    Register with which suffix: None

    ----

    DNS request timed out.
    timeout was 2 seconds.
    Server: UnKnown
    Address: 2607:f428:ffff:ffff::1

    DNS request timed out.
    timeout was 2 seconds.
    DNS request timed out.
    timeout was 2 seconds.
    DNS request timed out.
    timeout was 2 seconds.
    DNS request timed out.
    timeout was 2 seconds.
    *** Request to UnKnown timed-out

  • Avatar
    jaquiring

    Running these commands over wifi (which is where it's not working), I get the following:

    Interface 9: Ethernet

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Deprecated infinite infinite fe80::fd2d:a74b:f0a1:3d6b%9

    Interface 4: Wi-Fi

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Dhcp Preferred 7h58m58s 7h58m58s 2600:6c56:417f:ebf3:0:7415:ff2f:22d1
    Dhcp Preferred infinite infinite 2600:6c56:417f:ebf3:0:ac92:42b1:27be
    Other Preferred infinite infinite fe80::b5ba:3869:3f33:9755%4

    Interface 1: Loopback Pseudo-Interface 1

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Preferred infinite infinite ::1

    Interface 6: Local Area Connection* 2

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Other Deprecated infinite infinite fe80::3d91:cd0:3ded:ad65%6

    Interface 7: Teredo Tunneling Pseudo-Interface

    Addr Type DAD State Valid Life Pref. Life Address
    --------- ----------- ---------- ---------- ------------------------
    Public Preferred infinite infinite 2001:0:5ef5:79fb:3491:30f9:bd56:910b
    Other Preferred infinite infinite fe80::3491:30f9:bd56:910b%7

    ----

    Configuration for interface "Ethernet"
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only

    Configuration for interface "Local Area Connection* 2"
    DNS servers configured through DHCP: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Wi-Fi"
    DNS servers configured through DHCP: 2607:f428:ffff:ffff::1
    2607:f428:ffff:ffff::2
    Register with which suffix: Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
    Statically Configured DNS Servers: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Teredo Tunneling Pseudo-Interface"
    Statically Configured DNS Servers: None
    Register with which suffix: None

    ----

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 68.114.44.103

     

    So, obviously it's not using the correct DNS servers for wifi, but why? 

  • Avatar
    jaquiring

    I don't know if OpenDNS has a dynamic DNS client that could help, but the router has other settings (normally this is not enabled).

  • Avatar
    rotblitz (Edited )

    It seems you don't have IPv6 at all when connected via ethernet.  But you get DNSv6 server addresses via DHCP from the router nevertheless:

    Configuration for interface "Ethernet"
    DNS servers configured through DHCP: 2607:f428:ffff:ffff::1
                                                                2607:f428:ffff:ffff::2

    Because you do not have IPv6 connectivity, you also cannot send DNS queries to these DNS server addresses.  They time out.

    Whereas when connected to WiFi, you do have IPv6 connectivity, but you get DNS server address propagated via DHCP from the router which you did not configure, i.e. not the OpenDNS ones, but the same as via ethernet:

    Configuration for interface "Wi-Fi"
    DNS servers configured through DHCP: 2607:f428:ffff:ffff::1
                                                                2607:f428:ffff:ffff::2

    It looks like that your router does not handle these scenarios correctly.  It may be a bundle of firmware bugs.  I suggest you check the computer settings for IPv6 at the ethernet and the WiFi interfaces.  If this is fine, contact your router supplier.  As a workaround, it may help to disable IPv6 altogether, but you cannot reach IPv6-only sites anymore.

    "I don't know if OpenDNS has a dynamic DNS client that could help, but the router has other settings (normally this is not enabled)."

    This is a different topic, unrelated to using OpenDNS.  It is just to keep your IPv4 address information updated at OpenDNS.  In order to be able using your router, it must have at least one of OpenDNS, DNS-O-Matic or "custom / user defined" from the "Provider" drop-down list.  And sure, OpenDNS also provides update clients for Windows and Mac OS X.

Please sign in to leave a comment.