Sky Router not accepting OpenDNS

Comments

6 comments

  • Avatar
    rotblitz

    I understand that you configured OpenDNS on your PC?  In this case your Sky router is out of scope.  Why do you think it has to do with your router?  And as long as you do not use OpenDNS, your dashboard and the Updater are irrelevant.

    Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

     

    0
    Comment actions Permalink
  • Avatar
    garypburton

     

    Rotblitz

    Thank you for you reply. I obviously don't fully understand what I am doing, and therefore where I am going wrong. Just managed to get my Ubuntu laptop working fine with OpenDNS, on same router. So will try again tomorrow with PC.

    This is one of the problem when you start searching, you tend to find the answers you want, sooner than the correct answer.

    Thanks 

    0
    Comment actions Permalink
  • Avatar
    garypburton

    Problem appears resolved.

    On the Network Connections > Properties - interface, the 'Internet Protocol Version 6 (TCP/IPv6)' was box ticked. Once I unticked it this the OpenDNS now works fine.

    This is not obvious in the set up instructions. However if there is a problem with me un-ticking this item, please let me know.

    Appreciate your contact.

    Gary

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    So, you don't want access to the IPv6 internet?  This may not be a problem now, but can become one as websites are rolled out with IPv6-only.  If your ISP provides you with IPv6 connectivity, you better enable IPv6 again and fill its DNS server fields with OpenDNS addresses from this list:
    ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    "This is not obvious in the set up instructions."

    Not only not obvious - it is not there!  OpenDNS seem to ignore IPv6 in some way. :(

    Btw, we could have abbreviated these actions if you had posted the command outputs.  I would have seen if you have IPv6 connectivity, what DNS service you use if not OpenDNS, and what else may be wrong with your configuration and settings.  But if you like the trial and error experiments, then follow those.

    0
    Comment actions Permalink
  • Avatar
    garypburton

    Microsoft Windows [Version 10.0.16299.125]
    (c) 2017 Microsoft Corporation. All rights reserved.

    C:\Users\Admin>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m29.lon"
    debug.opendns.com text =

    "flags 20 0 50 39500027F00F1189EF3"
    debug.opendns.com text =

    "originid 118957056"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 10661416"
    debug.opendns.com text =

    "source 90.214.37.71:64447"

    C:\Users\Admin>nslookup -type=txt which.opendns.com.
    Server: UnKnown
    Address: 208.67.222.222

    *** UnKnown can't find which.opendns.com.: No response from server

    C:\Users\Admin>nslookup whoami.akamai.net.
    Server: UnKnown
    Address: 208.67.222.222

    *** UnKnown can't find whoami.akamai.net.: No response from server

    C:\Users\Admin>netsh interface ipv4 show config

    Configuration for interface "Local Area Connection"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 3"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wireless Network Connection 2"
    DHCP enabled: Yes
    IP Address: 192.168.0.9
    Subnet Prefix: 192.168.0.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.0.1
    Gateway Metric: 0
    InterfaceMetric: 50
    Statically Configured DNS Servers: 208.67.222.222
    208.67.220.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None


    C:\Users\Admin>

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "No response from server"

    This doesn't look good.  It seems your PC doesn't find a way to send DNS queries to 208.67.222.222 unless you explicitly specify the destination as with the first command.  Did you have IPv6 enabled at this time?  What happens if you visit http://welcome.opendns.com/ ?  In case you still have problems, post the output of 'ipconfig /all'.

    0
    Comment actions Permalink

Please sign in to leave a comment.