Can't get OpenDNS to work

Comments

7 comments

  • Avatar
    rotblitz

    This is the DNS service you're currently using:

    Server:  mercury.delhitel.net
    Address:  204.14.56.2

    Clearly not OpenDNS!  You either must configure OpenDNS on the router and optain the network settings on the computer automatically via DHCP from the router, or you must configure the computer with OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    bredwh

    I need it for 2 computers and a phone. I configured it on the router:

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, this looks fine, but your router or your computer is unimpressed about your configuration exercise, and you use

    Server:  mercury.delhitel.net
    Address:  204.14.56.2

    instead of 208.67.222.222 and 208.67.220.220.  What is the complete output of this command?

    netsh interface ipv4 show config

     

    0
    Comment actions Permalink
  • Avatar
    bredwh

    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.

    C:\Users\bredw_000>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
        DHCP enabled:                         No
        IP Address:                           192.168.2.40
        Subnet Prefix:                        192.168.2.0/24 (mask 255.255.255.0)
        Default Gateway:                      192.168.2.1
        Gateway Metric:                       256
        InterfaceMetric:                      20
        Statically Configured DNS Servers:    204.14.56.2
                                              204.14.56.3
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None

    Configuration for interface "VirtualBox Host-Only Network"
        DHCP enabled:                         No
        IP Address:                           192.168.56.1
        Subnet Prefix:                        192.168.56.0/24 (mask 255.255.255.0)
        InterfaceMetric:                      20
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None

    Configuration for interface "VMware Network Adapter VMnet1"
        DHCP enabled:                         No
        IP Address:                           192.168.235.1
        Subnet Prefix:                        192.168.235.0/24 (mask 255.255.255.0)
        InterfaceMetric:                      20
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None

    Configuration for interface "VMware Network Adapter VMnet8"
        DHCP enabled:                         No
        IP Address:                           192.168.20.1
        Subnet Prefix:                        192.168.20.0/24 (mask 255.255.255.0)
        InterfaceMetric:                      20
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None

    Configuration for interface "Loopback Pseudo-Interface 1"
        DHCP enabled:                         No
        IP Address:                           127.0.0.1
        Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
        InterfaceMetric:                      50
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None


    C:\Users\bredw_000>

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Yes, I see.

    Configuration for interface "Ethernet"
        Statically Configured DNS Servers:    204.14.56.2
                                                              204.14.56.3

    As I indicated above already, change this to 192.168.2.1 as the only one DNS server address in the IPv4 network properties of your computer, so that the DNS traffic goes to your router's DNS server where OpenDNS is configured.

    0
    Comment actions Permalink
  • Avatar
    saif6215

    I have the exact same problem. please help.

     

    HERE ARE MY MINE:

    Configuration for interface "Local Area Connection* 1"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 2"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.0.102
    Subnet Prefix: 192.168.0.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.0.1
    Gateway Metric: 0
    InterfaceMetric: 35
    DNS servers configured through DHCP: 192.168.0.1
    0.0.0.0
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
    DHCP enabled: Yes
    IP Address: 192.168.0.110
    Subnet Prefix: 192.168.0.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.0.1
    Gateway Metric: 0
    InterfaceMetric: 50
    DNS servers configured through DHCP: 208.67.222.123
    208.67.220.123
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

     

     

    i have  already changed the dns adresses but it still doestn work

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Same problem? Then you got the solution.

    Else post the outputs of the three other commands.

    0
    Comment actions Permalink

Please sign in to leave a comment.