Comments

20 comments

  • Avatar
    rotblitz

    You should be able to define different services for each different hostname.  If not, then this is a glitch with DNS-O-Matic.  You better open a support ticket then.

    Alternatively, as a workaround, you can create CNAME records at NameCheap to point to the one hostname you're updating.

  • Avatar
    bggarchow

    I'm having the same problem as the OP. At Namecheap.com I have A records set for www.example.com, server1.example.com and server2.example.com. At dns-o-matic I create a service to update the www host (hostname=www, domain=example.com) but when I try to create another service to update server1 (hostname=server1, domain=example.com) I get "You already have a service with that info."

  • Avatar
    rotblitz

    "same problem"  -  same answer.  What else?  I have no new insights yet.

  • Avatar
    alanhinchcliffe

    namecheaps instructions where to create a wildcard entry in your records have dnsomatic update this record and all records will update 

    so set a subdomain as * with ip address 127.0.0.1 as an A address point dnsomatic to this address and all A address's will be updated

    what i did was to install DDClient on my webserver and have it update all my A records with Namecheap directly 

  • Avatar
    sbonar

    The issue is that I want to update the subdomains with different IP addresses not with the same IP address for all.

  • Avatar
    rotblitz

    No, the issue is different.  Nobody raised a support ticket during the last year to get this fixed in DNS-O-Matic...

  • Avatar
    sbonar

    Added one last night - https://support.opendns.com/requests/148128

  • Avatar
    Alexander Harrison

    Hi sbonar, it looks like your request was incidentally flagged as spam. I'll create a new ticket for you there and we can continue on there with DNS-O-Matic specifically to this potential issue

  • Avatar
    sdf

    Hi i am having the same problem and would like to know if there is any update or workaround to this?

    I am wanting to update @ and www but if i add them to the same host section and separate them with a "," i get an error

    Any help much appreciated

     

  • Avatar
    alanhinchcliffe

    heres an example of my ddclient.cfg file this should give you an idea of how it should look

    ## update time in 300 seconds
    daemon=300
    cache=/tmp/ddclient.cache
    pid=/var/run/ddclient.pid
    use=web, web=checkip.dyndns.com/, web-skip='IP Address'
    protocol=namecheap
    server=dynamicdns.park-your-domain.com
    login=hinchcliffephotography.co.uk
    password=***************************************
    @.hinchcliffephotography.co.uk, news.hinchcliffephotography.co.uk, www.hinchcliffephotography.co.uk, chvps.hinchcliffephotography.co.uk, mail.hinchcliffephotography.co.uk
    protocol=namecheap
    server=dynamicdns.park-your-domain.com
    login=hopevalleyphotosociety.co.uk
    password=****************************************
    @.hopevalleyphotosociety.co.uk, www.hopevalleyphotosociety.co.uk

  • Avatar
    rotblitz

    @sdf 
    Is there an instruction for a comma separated hostname list?  I didn't find one.  I believe that the approach is to configure a separate service for each hostname.  Did you try this?  Does the old original issue still exist that this is not possible?

    @alanhinchcliffe 
    You got the wrong thread.  This here is about DNS-O-Matic, not about ddclient.

  • Avatar
    sdf

    thanks rotblitz

    i have tried "," and "-a" and i have also tried to set up another dnsomatic with the same credentials but changing "@" with "www" but dnsomatic said that account already exited

    i am using Namecheap ddns on windows for the time being untill i can get dnsomatic to update subdomains

    cheers

  • Avatar
    sdf

    Sorry i meant to say account already exists

  • Avatar
    bggarchow

    Namecheap supports wildcard subdomains. Create a cname record under your domain using * for the hostname and pointing to a dummy IP. Configure a dnsomatic entry for your domain with * as the hostname and configure your DDNS client using all.dnsomatic.com for the hostname. dnsomatic will update your cname record IP with the IP of your DDNS client and anysubdomain.example.com will be redirected there.

  • Avatar
    rotblitz

    @sdf
    if there's still the message that the Namecheap account already exists and the comma separated list of hostnames doesn't work, then this is still a bug at DNS-O-Matic, and you should raise a support ticket with OpenDNS.  DNS-O-Matic should allow to update multiple Namecheap hostnames, the one way or the other.

  • Avatar
    sdf

    bggarchow thanks for the post i thought it was all good but i have to add  port number to connect to my synology server which would fail when i was using the wildcard

    rotblitz i created a support ticket last night so hopefully i can get it sorted out

    Thanks all

  • Avatar
    bggarchow

    I am using the configuration I described in my previous comment to connect to my Synology Diskstation server. To avoid having to use port numbers, log into your DSM as admin and go to control panel > application portal. Select an application (e.g. file station) > edit. Select 'enable customized alias' and give it a name (e.g. files) and check the box next to 'redirect from xxx'. Now you may access file statiion by the url server.mydomain.com/files without the port number.

  • Avatar
    montag64

    I also have this problem. I can't use a CNAME record as a workaround because I need 2 A records. One is prioritized behind a URL record which hijacks the IP, and I need the second A record to point directly to the IP of my server. I had to do some serious hackery to get around port 80 without having the ports displayed in the web address bar. I opened a bug report. 

  • Avatar
    montag64

    The only other idea I can think of is create two different DNS-O-Matic accounts with two different email addresses and operate the duplicate host through the other account. That seems incredibly silly though, so I'm hoping the bug can be patched. 

  • Avatar
    semicycler

    So I stumbled upon this same error and had started a different thread.  Yes it's an error on OpenDNS's side.  When using NameCheap there is no way to update more than one A-record coming from DNS-o-matic.  DNS-o-matic admits it is unsupported, and further admits there are no plans to fix it.  See my thread here:  https://support.opendns.com/hc/en-us/community/posts/115000587527

     

Please sign in to leave a comment.