ddclient updates over SSL instead of HTTP

Comments

4 comments

  • Avatar
    rotblitz

    You use the "ssl=yes" parameter in ddclient.conf.
    See https://support.opendns.com/entries/23554765

    0
    Comment actions Permalink
  • Avatar
    whohasbandwith

    Yes, I have that line in config

    However when I this debug command

    sudo ddclient -debug -verbose -noquiet

    I noticed a line this

    CONNECT: dynamicdns.park-your-domain.com

    CONNECTED: using SSL

    except that it said 'HTTP'

    which make me start this post.

    If there is not any other of getting the encypted update to work.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Why would you want to connect to dynamicdns.park-your-domain.com at all???

    Fix your ddclient.conf:

    use=web, web=myip.dnsomatic.com
    ssl=yes
    server=updates.dnsomatic.com
    protocol=dyndns2
    login=dnsomatic/opendns_username
    password=dnsomatic/opendns_password
    all.dnsomatic.com

    0
    Comment actions Permalink
  • Avatar
    Eden

    You can check the ddclient settings on this article to configure your clients to use HTTPS / SSL:

    https://support.opendns.com/entries/21774644-Using-DNS-O-Matic-with-HTTPS

     

    You can also submit your ddclient config file to us on your ticket, and we can have a look for you.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.