How to set up my Century Link Router

Comments

22 comments

  • Avatar
    rotblitz

    Here's a kind of manual for your router: https://qwest.centurylink.com/internethelp/modem-c1000a.html

    First go into the WAN settings and try to configure the OpenDNS resolver addresses there. If there's no possibility to do so, go into the LAN DHCP server settings to configure them there.

    0
    Comment actions Permalink
  • Avatar
    tsbeesley

    I can't figure out how to make the C1000A(centurylink) work with openDNS either.  Has anyone had success with it?  I tried changing it at the DCHP settings but it did not work. 

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    It may be that you can't use OpenDNS at all, no matter what your router is.  Check it first:

    nslookup -type=txt which.opendns.com.  208.67.220.220

    0
    Comment actions Permalink
  • Avatar
    odomus

    For the C1000A, Via Actiontek
    Current Firmware Version: CAC001-31.30L.8

    Advance Setup > WAN Settings > Under: 4. Set the DNS type. Click on Static DNS Button/Mark
    Add the 2 IP's
    208.67.222.222
    208.67.220.220

    Then Hit "Apply"
    Wait till it is done...
    It doesnt Apply from what I can tell, SO...
    Restart/Reboot Your Router....

    Click on "Utilities" First selection is "Reboot Modem" Click on "Reboot" button.
    Then Wait till it Reboots.
    Then click on the welcome link...
    http://welcome.opendns.com

    It should be checked marked....Then there you go!

    I did try and search but google nor anyone else showed this at all. I had to do bits and pieces and paste together what others have said and look for it.
    This is way diff than the pk5000 I had before.

    1
    Comment actions Permalink
  • Avatar
    lemonbar

    I just tried odomus' suggestion, but was declined with the message:

    "WAN Settings set the protocol and addressing type required by your ISP for Internet access."

     

    0
    Comment actions Permalink
  • Avatar
    odomus

    Did you follow the exact way.... and didnt deviate?  Are you sure this is for the Actiontec C1000A via Century Link?  I am now figuring if it isnt Century Link, that may be the problem. 

    I only know to not deviate, due to I deviated with my neighbors, and it didnt work at all. I skipped the reboot, and it reset itself...but as soon as i did it properly, then it worked fine.

    0
    Comment actions Permalink
  • Avatar
    lemonbar

    I just figured it out. I went to  advanced settings -> DCHP settings -> 5. Set DNS servers allocated with DHCP requests. Then chose custom servers.  Took a while to figure it out. Maybe different firmware?

    It is explained in this thread:

    https://support.opendns.com/entries/22472079-Actiontec-C1000A-won-t-let-me-change-primary-or-secondary-static-DNS?page=1#post_21956515

    0
    Comment actions Permalink
  • Avatar
    odomus

    Well the Firmware itself is at the top where I stated it as such, if it is different, then I have no clue, even the slightest change from a       CAC001-31.30L.8 to a CAC001-31.30L.9 (just an example)  can mean a lot in graphic changes and such, so it can happen, especially if you are using the modem for a non century link or even qwest ISP, different firmware totally.  But the firm ware i had is uptodate with CAC001-31.30L.8 for century link ISP, though now that i think about it... if CL decided to be jerks, and make different firmwares for different states though same FW ID's , that can pose a problem.  I have seen that before at work... so it can happen but that is one of the 1% that happens 99% that doesnt happen without a FW ID change over all even from state to state an city to city. 

    As well I didnt touch anything else at all, so that thread... means nothing really, when nothing else was touched at all and it works.  DHCP settings oddly dont need to be even touched... but then again, FW comes into play and if it is an old FW or a NEW FW version again this is all dependent on all  of that.

    0
    Comment actions Permalink
  • Avatar
    anogee

    For me, and I have the latest FW I believe, under DHCP Settings, for me, that selection does nothing. If I set it under WAN Settings, it does in fact work. But here is a strange question?  There is a screen for DNS Host Mapping, which I assume won't work is the router ISN'T in the DNS path, but it doesn't warn you of this.  Go figure.

    0
    Comment actions Permalink
  • Avatar
    smithseo

    I also have faced the same issue & i want its solution. Will anybody fix my issue? 

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    Just saying "will anybody fix my issue" doesn't provide enough troubleshooting information to resolve whatever your issue is.

    Exactly which issue are you referring to and on which hardware model and with which firmware? Several issues were described in this thread, on different possible types of hardware and firmware.

    Have you followed any of the troubleshooting/repair tips or ideas in this thread?

    What error messages or problems are you seeing?

    0
    Comment actions Permalink
  • Avatar
    jttag

    I get to the screens, but I can't do anything with them.  When I click on a button, nothing happens.  Any thoughts?

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    Aside from updating the firmware or calling CenturyLink you might not be able to do anything.

    Is your model of router or the firmware version on it the same as has already been discussed in this thread already?

    Generally I recommend that no one rely on the "modem/router" that is provided by their ISP. For as little as $50-$75 you can buy your own fully featured WiFi router that allows you to configure your own settings however you want them, with no interference or restrictions from your ISP. That would also be where you configure OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    rainecorp

    jttag Try a different browser. I had the same issue with not being able to click on buttons and it was because of the browser. So, try a different one.

    0
    Comment actions Permalink
  • Avatar
    fritzkfan

    I have not been able to configure my CenturyLink Actiontec C1000a to work with openDNS.  I've tried following the instructions here and on related openDNS support pages.  My firmware is the latest, CAC002-31.30L.76.  I tried Chrome first, and everything seemed to work OK in terms of the browser, but still the test page failed (internet access has remained fine throughout, minus the period of time when the router is configuring itself).  I then saw the suggestion to use a different browser, so I used IE, but with the same apparent results.  I then saw the recommendation to reboot, and tried this as well, but to no avail.  Any ideas?  The changes I've attempted have been changing either/both of [Advance Setup > WAN Settings > Under: 4. Set the DNS type] and [advanced settings -> DCHP settings -> 5. Set DNS servers allocated with DHCP requests].

    Any ideas?  Thanks in advance.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Did you see what I wrote above?  Copying to here:
     

    It may be that you can't use OpenDNS at all, no matter what your router is.  Check it first:

       nslookup -type=txt which.opendns.com.  208.67.220.220

    0
    Comment actions Permalink
  • Avatar
    fritzkfan

    Yes, I saw that, but not sure what the results indicate:

     

    C:\Windows\system32>nslookup -type=txt which.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    which.opendns.com text =

    "1.sea"

    The time before I ran it I got "3.sea".

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This means that your DNS queries are not being redirected by your ISP and that you can use OpenDNS.  "sea" indicates that you would be using the OpenDNS Seattle data center.

    It seems the configuration on your router didn't take effect for whatever reason.  You had to refer to Century support.

    0
    Comment actions Permalink
  • Avatar
    westrarun

    Thanks so much Odomus!!!  Worked for me.

    0
    Comment actions Permalink
  • Avatar
    bkeel1

    Odomus.. this worked for me as well.. thanks

    0
    Comment actions Permalink
  • Avatar
    zenrook (Edited )

    Kudos to Odomus,

    It also works on the ActionTec C1900A modem as well (Centurylink Modem)

     

    >>>>

    Advanced Setup

    Wan Settings

    Set the DNS Type

    Select Static DNS

    Primary DNS: 208.67.222.222

    Secondary DNS: 208.67.220.220

    0
    Comment actions Permalink

Please sign in to leave a comment.