Actiontec C1000A won't let me change primary or secondary static DNS

Comments

17 comments

  • Avatar
    rotblitz

    "The Actiontec serviceman told me that it is not possible to use OpenDNS with CenturyLink."

    He is most likely right: https://startpage.com/do/search?q=actiontec+host%3Asupport.opendns.com

    "I really want the OpenDNS service at the router level."

    Then you must use a different router, behind the Actiontec one in addition, or instead of it.

    0
    Comment actions Permalink
  • Avatar
    Chris Frost

    If we do not currently have your router instructions at <https://store.opendns.com/setup/router/> or you are unable to change DNS settings in your router, then we suggest you configure your computer instead (see <https://store.opendns.com/setup/computer/>). You will get the same benefits, and if you have a small number of computers on your network, it's relatively easy.

     

    0
    Comment actions Permalink
  • Avatar
    matterpalm

    Thanks guys. I ended up putting the OpenDNS name servers into the section of my router settings called 5. Set DNS servers allocated with DHCP requests. This seems to have worked!

    0
    Comment actions Permalink
  • Avatar
    Chris Frost

    Glad to hear everything is now working for you!

    0
    Comment actions Permalink
  • Avatar
    halac

    I just bought and installed a C1000A router this weekend for my CenturyLink DSL.  I know it sounds weird, but I was only able to set the DNS when using Internet Explorer (running IE11).  I could not even get many of the web page links to be active with Chrome (v32), and Firefox (v26) gave me page access errors.  Maybe I have some strange setting with the other browsers, but all 3 are "close to default".  Good luck.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I would think you have to report this back to the supplier of this device.  It seems it's web interface doesn't support all common browsers...

    0
    Comment actions Permalink
  • Avatar
    halac

    Agreed it's a Centurylink/Actiontec issue ... just wanted to offer a possible work-around to anyone with this issue

    0
    Comment actions Permalink
  • Avatar
    lemonbar

    I think I finally got it to work. Go into advanced settings -> DCHP settings -> 5. Set DNS servers allocated with DHCP requests. Then choose custom servers.  Took a while to figure it out. Maybe different firmware?

    0
    Comment actions Permalink
  • Avatar
    elycia

    Hello,

    I am having the same issue and having read through the comments I still have no idea how to set my modem with the correct settings to make the DNS active.  Could someone please give me a step by step set of instructions to get into the right place in my modem settings and what exactly to change and where those places to change are located? Thanks for the help!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Is it this Actiontec C1000A ?

    0
    Comment actions Permalink
  • Avatar
    matterpalm

    I'm able to change the DNS servers as described by lemonbar in Advanced settings -> DHCP Settings -> Set DNS servers allocated with DHCP requests but it only works until my ISP changes my routers ip address (I have a dynamic ip address). I'm looking into the post here:

    https://support.opendns.com/entries/26272175-Introduction-to-Configuring-OpenDNS

    to see what options I have to get around the dynamic ip address issue at the router level. If web filtering or content filtering is your main purpose in using opendns setting up squid and dansguardian together can be very effective (even with dynamic ip) and can even provide you with some nice caching capabilities.

    0
    Comment actions Permalink
  • Avatar
    elycia

    Rotblitz, yes this is an Actiontec C1000A modem.  I had the previous version Q1000 and upgraded not knowing this modem would not be the same configuration as the last for this program.  I followed the steps listed above and in the primary listed 205.171.3.25 and the 2nd 205.171.2.25 - this was how it was for the last modem but it's still not working.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, this is a device specific problem, not an OpenDNS problem.  Here are the OpenDNS experts, the Actiontec experts are somewhere else.

    0
    Comment actions Permalink
  • Avatar
    elycia

    I have a DSL router but it's not wireless like the modem.  I'm not sure how to install the router as my "filtering" device along with my modem and still have everything as wireless.  Are there instructions for this some where on the site here? Thanks

    0
    Comment actions Permalink
  • Avatar
    halac

    My C1000A web interface matched (closely) the one shown for the Q1000, so I followed the instructions for that:

    https://store.opendns.com/setup/device/actiontec-q1000

    As listed in my previous post, Chrome does not work (for me) with the built-in Actiontec page ... the links don't work (or are terribly misaligned).  If I try it in Firefox, I get a bunch of errors.  Internet Explorer (IE11), though, works fine.  As the Q1000 directions state, go to Advanced Setup / WAN settings and make the changes there.

    0
    Comment actions Permalink
  • Avatar
    bflying

    I had the same issue, this solved it for me.  Change the DNS under the WAN settings first (ADVANCED>WAN SETTINGS) to the OPEN DNS servers (i.e. 208.67.222.222, etc.)   Then go to DHCP SETTINGS item #4 and change the radio button to Custom Servers and then input the DNS servers for OPEN DNS.  

     

    Here is a link to help too.

     

    http://setuprouter.com/router/actiontec/c1000a-centurylink/dns.htm

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.