Working around the UVerse/2Wire restriction

Comments

24 comments

  • Avatar
    rotblitz

    Theoretically and in principle it is possible to use another router behind the ISP device where OpenDNS is to be configured then.  Just try it out.

  • Avatar
    wbuford

    Rotblitz.  Can you be a bit more specific?  How, specifically, does one go about doing that?

     

  • Avatar
    oakwoodfamily

    Rotblitz, I have the same issue but can not get OpenDNS to block anything.

    I have Uverse, and added a second Modem (Netgear WNDR4500) behind the Uverse modem, wired.

    Netgear genie helped set up the LPC, I logged into my OpenDNS account, set security on high, but nothing gets blocked.

    I was wondering if I still need to add the two DNS somewhere?

  • Avatar
    rotblitz

    It could be that LPC doesn't take effect behind another device.  Post the complete plain text output of the following command:

    nslookup -type=txt debug.opendns.com.

  • Avatar
    oakwoodfamily

    > nslookup
    Server: 192.168.1.254

    > nslookup
    Server: 192.168.1.254
    Address: 192.168.1.254#53

    ** server can't find nslookup: NXDOMAIN
    > nslookup -type=txt debug.opendns.com.
    Server: 192.168.1.254
    Address: 192.168.1.254#53

    ** server can't find nslookup: NXDOMAIN

     

    tks for your fast reply. would really like to work it out with OpenDNS somehow. I tried to switch the modems (first Netgear, than Uverse, but nothing worked anymore).

     

     

     

  • Avatar
    rotblitz

    It seems you have problems entering the command.  You just entered "nslookup", but you have to enter (after you opened a Command Prompt window:

    nslookup -type=txt debug.opendns.com.

    Please try again.  This shouldn't be too difficult.

  • Avatar
    rotblitz

    Also, let me know if you currently have LPC enabled on the Netgear router.

  • Avatar
    oakwoodfamily

    Yes, I do. Netgear LPC supports OpenDNS, so I  am logged in. Both security levels (Netgear Genie has one and then OpenDNS homepage also) are on high, and nothing gets filters. I did NOT change any DNS so far, since it is my understanding that the Netgear Genie does that in the background?)

  • Avatar
    oakwoodfamily

    > nslookup -type=txt debug.opendns.com.
    Server: 192.168.1.254
    Address: 192.168.1.254#53

    ** server can't find nslookup: NXDOMAIN
    >

  • Avatar
    rotblitz

    No, again wrong:

    Start > Run > cmd               (opens the command prompt window), and then

    nslookup -type=txt debug.opendns.com.

    It should look like the attached.




    cmd_nslookup.JPG
  • Avatar
    oakwoodfamily

    sorry, I have a mac, OS X 10.8.5

  • Avatar
    rotblitz

    Fine, then open a terminal window and enter the command there.

  • Avatar
    oakwoodfamily

    > nslookup -type=txt debug.opendns.com.
    Server: 192.168.1.254
    Address: 192.168.1.254#53

    ** server can't find nslookup: NXDOMAIN
    >

     

  • Avatar
    rotblitz

    I give up...

  • Avatar
    oakwoodfamily

    what did I do wrong? I entered your command in the terminal window...

  • Avatar
    rotblitz

    You're landing in the nslookup prompt.  Not sure how you get there. 
    You must enter the complete command (inc parameters) in a plain terminal window. 
    I don't have a Mac, else I would have posted a screen shot.

    Whatever, you  can also execute this in the nslookup prompt:

    > set type=txt 
    > debug.opendns.com.

  • Avatar
    eagleii

    I ditched ATT... and that RG that SUCKED! by 2Wire and so glad I did.  It was B/G wireless to start with (No N and the ports were 10/100 .. not good when all is moving into the gigabit realm... ( wish these speeds were available in the 80's.. any one else here work with 150bd modems..before the 300 came out?  When the 1200bd came into play you felt like you were flying .. nuff, else  this old man will dejavu you to death )  The only way I could run a router (D-Link) off that 2Wire was to make the "frustration" call to support .. and find:::::: There is no true bridge mode on the 2Wire routers.

    1. Set your router's WAN interface to get an IP address via DHCP.  This is required at first so that the 2Wire recognizes your router.

    2. Plug your router's WAN interface to one of the 2Wire's LAN interfaces.

    3. Restart your router, let it get an IP address via DHCP.

    4. Log into the 2Wire router's interface.  Go to Settings -> Firewall -> Applications, Pinholes, and DMZ

    5. Select your router under section (1).

    6. Click the DMZPlus button under section (2).

    7. Click the Save button.

    8. Restart your router, when it gets an address via DHCP again, it will be the public outside IP address.  At this point, you can leave your router in DHCP mode (make sure the firewall on your router allows the DHCP renewal packets, which will occur every 10 minutes), or you can change your router's IP address assignment on the WAN interface to static, and use the same settings it received via DHCP.

    9. On the 2Wire router, go to Settings -> Firewall -> Advanced Configuration

    10. Uncheck the following: Stealth Mode, Block Ping, Strict UDP Session Control.

    11. Check everything under Outbound Protocol Control except NetBIOS.

    12. Uncheck NetBIOS under Inbound Protocol Control.

    13. Uncheck all the Attack Detection checkboxes (7 of them).

    14. Click Save.

     Your router should now be able to route as if the 2Wire was a straight bridge, for the most part.

    Inbound port 22 might be blocked, and inbound ports 8000-8015 might also be blocked, and there's nothing that can be done about it.

    ------------------------------------------------------------------ or -------------------------------------------------------------

    Only want to use "wireless"  from the router you are trying to blend in with the 2 Wire RG?

    Do the following:

     1. Turn off DHCP on your router.

    2. Change the link between the 2Wire router and your router to use the LAN ports on both ends.  (In other words, plug the cable from one of the LAN ports of the 2Wire to one of the LAN ports of your router.  Leave your router's WAN port empty).

    3. Change the LAN IP address of your router to a static IP on the same subnet as the 2Wire router.  For example, if the 2Wire router is using 192.168.1.x, and the DHCP range is 192.168.1.64 - 192.168.1.253, set your router to 192.168.1.10.

    4. If necessary, configure the wireless parameters on your router, such as SSID, encryption, pre-shared key, and MAC filtering.

     Your wireless computers connected to your router will now be able to communicate with wired computers on the 2wire router since everything will be on the same subnet.


    (( I swear before God and man I will NEVER go back to ATT.  They have a new RG (Finally) That supports wireless N .. but the corporate retards left the lan ports at 10/100 .. GO FIGURE! ))

    SomeJoe sends..

  • Avatar
    eagleii

    ps:  when stating "router" - router refers to your add on.   If any thing applies to 2Wire it will state 2Wire. 

  • Avatar
    eagleii

    Meant to say, if you use option #1 you could probably add OpenDNS to the "router".   No longer on ATT - and senility mode in medium .. you'll have to try it on the "trial and error" basis.

  • Avatar
    eagleii

    command prompt window:  Run in Admin mode ...
    Start
    All Programs / Accessories

    Right click on :  Command Prompt icon
    Choose Run as Admin.
    May help.

  • Avatar
    iphelp

    Does this mean there is a way for opendns to get around the uverse debacle? If so I would like to hear a yes vote, or should I switch carriers and try something other than ATT.

     

  • Avatar
    Kristy Patullo

    Unfortunately the Uverse routers leased by AT&T do not allow you to change their DNS settings.

    Alternatively, you can always change the DNS settings on your computers and devices instead (see https://support.opendns.com/categories/20080020-OpenDNS-Device-Configuration). You will get the same benefits, and if you have a small number of computers on your network, it's relatively easy.

    Another option would be to install a third-party router, such as one you would buy at a store, in between the ISP's router and the rest of the devices on your network. You can then configure OpenDNS on that device and it will distribute the DNS settings to the devices on your network.

  • Avatar
    eagleii

    We left uverse ( nightmare-verse ) and went with comcast and a DOCSIS3  setup.    We got the "blast" package ( 50mbps)  -- and always was in the 80mbps arena.  They have doubled our setup to 100mbps and no price change and we now get in the 129 mbps realm.   I added on TV  ( came out to about 3.00 per month more and it includes streampix.. more and our total monthly bill is 87.00 and some change.  Our frustration call time with ATT support is now "0" as there has been no need to call comcast support on a regular basis.    PS:  We never even came close to the connection we paid for with ATT-UVerse.

    Good gateway to use with comcast ( or the like ) Motorola Surfboard eXtreme wireless Cable Modem sbg6580.  gigabit ethernet.  Most computers are now equipped with N and gigabit ethernet.  OpenDNS Friendly.

Please sign in to leave a comment.