I am not able to get OpenDNS configured with D-Link DSL-2750U

Comments

12 comments

  • Avatar
    rotblitz

    It seems you did everything right, although the DNS proxy may be irrelevant here.  It most likely takes its values from the other two fields.  However, if the command

           nslookup -type=txt which.opendns.com. 208.67.220.220

    returns "I am not an OpenDNS resolver", then your ISP redirects your DNS queries to their own DNS service and you're out of luck with using 3rd party DNS.  You had to call your ISP to ask if it is possible to opt out from this DNS redirection.

  • Avatar
    nithin.tp

    Hi 

    I have the same problem , the command 

    nslookup -type=txt which.opendns.com208.67.220.220

    Returns values as below

    Server: 208.67.220.220
    Address: 208.67.220.220#53

    Non-authoritative answer:
    which.opendns.com text = "3.lon"

    Authoritative answers can be found from:

     nithin@Inspiron-620$

     

    Can u please suggest a solution ?

    Thank you

  • Avatar
    wsadaqa

    Hi,

    I have ran the command  nslookup -type=txt which.opendns.com. 208.67.220.220

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    which.opendns.com text =

    "5.fra"

     

    Please help.

    Thanks.

     

  • Avatar
    rotblitz

    @nithin.tp and @wsadaqa:

    Your DNS queries are not redirected by your ISPs.

    Same problem - so you're using a D-Link DSL-2750U, else it would not be the same problem.

    Well, try without the DNS proxy enabled to see if it works then.

  • Avatar
    wsadaqa

    If I untick this option the network fails and I would not be able to browse any website.

    I ran the command again (without the DNS proxy being enabled) and I still get the same error.

     

  • Avatar
    rotblitz

    "If I untick this option the network fails and I would not be able to browse any website."

    I had checked the user manual earlier, and the description for this function is lousy anyway.  :(

    "I ran the command again (without the DNS proxy being enabled) and I still get the same error."

    Same error?  Oops, you didn't get an error at all.  You confirmed that your DNS queries are not being redirected, and that you would be using the OpenDNS Frankfurt location if you used OpenDNS at all.  This is not an error, but good!

    And you know that this is an OpenDNS forum here, and OpenDNS do not supply routers.  Therefore you had to refer to D-Link support.  It isn't an OpenDNS problem, but a general D-Link problem.

  • Avatar
    wsadaqa

    I have figured it out.  I kept the DNS Proxy but this time I added 208.67.222.222 in the Host name of the Broadband Router.

    Thanks for your great support; your pointed me where to check. 

     

  • Avatar
    prashanth.ambekar

    Hi wsadaqa, could you please share a screenshot of your router settings now. I did what you suggested, but it doesn't seem to be working for me. I'd appreciate your help. Thanks!

  • Avatar
    rotblitz

    @prashanth.ambekar 
    With "Host name" wsadaqa meant the field in the second screen shot he originally posted. 
    https://support.opendns.com/attachments/token/c3NS2IZa5eog6TlbzfPagnHmv/?name=DLink2.jpg

    But you're right, the described measure cannot be the solution, it must have been something else which solved his problem.  Whatever, you may try it too nevertheless.  It can't harm anything.

    Did you ensure that your ISP does not redirect your DNS lookups to their own DNS service, as described above?

  • Avatar
    prashanth.ambekar

    Hi rotblitz,I did try what wsadaqa suggested, but it didn't work for me. And I did run the nslookup, and this is what I found - I assume it means that my ISP is not redirecting DNS requests.

    Server:        208.67.220.220
    Address:    208.67.220.220#53

    Non-authoritative answer:
    which.opendns.com    text = "3.lon"

    Authoritative answers can be found from:

  • Avatar
    prashanth.ambekar

    @rotblitz, I finally got OpenDNS set up on my computer. I changed the DNS settings on my router and flushed the DNS cache on my Mac as suggested, but I still wasn't able to use OpenDNS. Finally, I went to System Preferences > Network > Advanced > DNS, and noticed that my computer was using the old DNS addresses. Those addresses were grayed out, and I couldn't delete them. So I added the OpenDNS addresses using the + sign at the bottom, and flushed my DNS cache, and voila!

    Hope this is helpful to others who're on a Mac.

  • Avatar
    sjohansen

    I have had the same problem since august 14. I gave up at the end, but today I found that there was a problem with the firmware on the router.

    After update the firmware all woorks fine again.

    Seems like the error in the log at the router telling something about no entry in the resolv file have to do with it. The dns setting did infact not save correctly on the router.

    For DIR860L the firmware 1.08 works

Please sign in to leave a comment.