Comments

20 comments

  • Avatar
    Alexander Harrison

    Hello,

    You may find this guide available at setuprouter.com useful for configuring your device to OpenDNS (208.67.220.220 and 208.67.222.222): http://setuprouter.com/router/alcatel-lucent/i-240w-q/dns.htm.

    Best regards,

    0
    Comment actions Permalink
  • Avatar
    josesitojuniorsaso

    This is not working, it asks domain name.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "it asks domain name."

    Interesting.  Post a screen shot of it.

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    http://imgur.com/3lfISSz

     

    note : it's the same if leave it blank

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    note : i put the ip in the name and ip place for test , but it dosen't seem to work

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Why don't you enter the related domain names?

    resolver1.opendns.com    208.67.222.222 
    resolver2.opendns.com    208.67.220.220 
    resolver3.opendns.com    208.67.222.220 
    resolver4.opendns.com    208.67.220.222 

    If it keeps the device happy.....  ;-)

    1
    Comment actions Permalink
  • Avatar
    yazeed44

    i did add the first two dns

     

    but the router dosen't seem to use those two dns

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Post the complete plain text output of the following diagnostic command here:

    nslookup -type=txt which.opendns.com.

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    i run that on the terminal on my pc , and here's the output :

     

    nslookup -type=txt which.opendns.com
    Server:        127.0.1.1
    Address:    127.0.1.1#53

    Non-authoritative answer:
    which.opendns.com    text = "I am not an OpenDNS resolver."

    Authoritative answers can be found from:

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Why are your DNS queries routed to 127.0.1.1?  What DNS server/forwarder is behind 127.0.1.1?  This isn't your router...

    "but the router dosen't seem to use those two dns"

    Yep!  It cannot.

    Unless this 127.0.1.1 is a DNS proxy, you must change your computer's DNS configuration to point to your router's IP address.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    ...and if 127.0.1.1 is a DNS proxy, you must ensure that this sends DNS queries to the IP address of your router.

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    when i said  "but the router dosen't seem to use those two dns"

     

    i meant the router itself , not in my computer

     

    [url=http://www.zimagez.com/zimage/screenshot-262014-114736.php][img]http://www.zimagez.com/miniature/screenshot-262014-114736.php[/img][/url]

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    ^^

    this picture from router status

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    The picture shows that the router isn't configured to use OpenDNS.  These are not OpenDNS resolver addresses, but your ISP's.

    "when i said  "but the router dosen't seem to use those two dns"  i meant the router itself , not in my computer"

    Yes, I know.  But also the computer must be correctly configured to use the router's configuration.  And this 127.0.1.1 suspects me that something is wrong with your computer configuration too.  You may post the output of the following commands here:

    ipconfig /all

    netstat -nabov

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    i use linux , so i don't have ipconfig/all

    but i used ifconfig -a :

     

    eth0      Link encap:Ethernet  HWaddr 00:30:18:a7:bb:2b  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:30229 errors:0 dropped:0 overruns:0 frame:0
              TX packets:30229 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:32182199 (32.1 MB)  TX bytes:32182199 (32.1 MB)

    wlan0     Link encap:Ethernet  HWaddr f8:d1:11:0c:17:1f  
              inet addr:192.168.1.53  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::fad1:11ff:fe0c:171f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1028320 errors:0 dropped:0 overruns:0 frame:0
              TX packets:840185 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:848777146 (848.7 MB)  TX bytes:169998452 (169.9 MB)

     

     

     

     

    netstat -nabov :

     

    netstat: invalid option -- 'b'

     

     

    a picture for dns settings : [url=http://www.zimagez.com/zimage/screenshot-262014-155304.php][img]http://www.zimagez.com/miniature/screenshot-262014-155304.php[/img][/url]

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    The last picture shows your configuration page, not what's actually used as the earlier picture does.  And this indicates that you're using 84.235.x.x addresses, not 208.67.x.x resolvers.  Look again into your router's manual to see what the purpose of this configuration page is.

    Regarding your computer configuration, your DNS currently points to 127.0.1.1, but should normally point to 192.168.1.1 unless you run a DNS proxy (like DNSmasq) on this computer.  But then this proxy must go out via 192.168.1.1.  Else your computer will not be using your router's DNS settings.

    And the right equivalent for above syntax of the netstat command for Linux is:

    netstat -napv

    0
    Comment actions Permalink
  • Avatar
    yazeed44

    it did print alot of lines so i pasted it into website :

     

    http://justpaste.it/f8t8

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    That's hard to read, so I uploaded a better readible version here.

    It proves that you have 127.0.1.1. configured as DNS server address on this computer, but with no evidence of a DNS proxy.  Not sure how this can work at all, but may be one of the reasons why it doesn't work.  Try with reconfiguring this to 192.168.1.1, your router's address, to see if this gives better results.

    If you don't know how to  configure DNS on the computer, take a look here: https://store.opendns.com/setup/computer/ - under Unix/Linux
    You may need to edit your /etc/resolv.conf file for this purpose.




    netstat.txt
    0
    Comment actions Permalink
  • Avatar
    jsarachaga

    The real problem here is that this modem does not allow for you to change DNS servers, nor set the DHCP server to provide different DNS servers. It's a shame.

    The instructions provided here are to create personalized DNS entries so that the modem can resolve locally when asked. It's like a hosts file for the modem, just that.

    I can't find a way to really tell the modem to resolve DNS names to OpenDNS servers. Any news on this?

    0
    Comment actions Permalink

Please sign in to leave a comment.