OpenDns blocks wifi calling on t-mobile cellspot router

Comments

7 comments

  • Avatar
    rotblitz

    Then find out the related domains you have blocked to whitelist them.

    https://dashboard.opendns.com/stats/all/blockeddomains

    0
    Comment actions Permalink
  • Avatar
    Brad

    I have none blocked.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Then it may not be OpenDNS related at all.  Switch back to your previous DNS service to see if it works then.  What DNS service would this be?  One of T-Mobile?  Some ISPs resolve some ISP-specific (private) domains using their general DNS service.  You had to find out the domains in question to introduce a different resolution method when OpenDNS is to be used.

    0
    Comment actions Permalink
  • Avatar
    mwalker1

    I have the same issue ...I think it is because the EE Calling  service is only set to work inside the UK and the Opendns servers and based outside the UK ....I would love a fix for this....

    It works fine if i take Opendns off...

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "the EE Calling  service is only set to work inside the UK and the Opendns servers and based outside the UK"

    This is not right in two ways. 

    • DNS is never ever country specific but worldwide.  But it can be ISP specific.  I.e. the ISP may perform name resolution for private domains with their DNS service which cannot be resolved by any other DNS service, no matter if in the same country or on the same continent or not.
    • OpenDNS servers are not "based outside the UK".  OpenDNS use Anycast technology, and you are routed to their nearest location, in your case most likely London/UK.
      https://www.opendns.com/data-center-locations/

    "I would love a fix for this...."

    No problem, there is a fix.  You must not resolve these private domains with OpenDNS, but locally.  To achieve this, I can think of the following options:

    • In case you have an internal DNS server, configure this to handle the ISP's private domains and send the rest to OpenDNS.
    • Else you may add the private domains and their IP addresses to the local hosts files of the devices where these private domains are being used.
      Then you can continue to use OpenDNS as normal.
    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    To confirm which datacenter the internet route through your ISP is sending requests through, run the following test:

    nslookup -type=txt debug.opendns.com

    and you can confirm which datacenter this is by comparing the source: line with the codes at http://system.opendns.com/

    Some UK ISPs route data on the other side of the North Sea and therefore may have DNS answered by a server other than our London server location (lon). 

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @Alexander
    ...but no matter what data center (s)he uses, this will not solve the issue with resolving private domain names.

    0
    Comment actions Permalink

Please sign in to leave a comment.