Belkin ac1200 won't let me type in DNS fields...

Comments

6 comments

  • Avatar
    us

    I figured this same problem out.  Go to the website filter in the router and turn off the website filter.  Save the setting then you can edit the DNS page.

    It appears Belkin's website filter is setup like opendns, although very VERY limited, so when you enable the website filter in the router it locks your DNS to their DNS to provide the filtering.

    2
    Comment actions Permalink
  • Avatar
    eyemeansit

    No solution yet...

    1
    Comment actions Permalink
  • Avatar
    mattwilson9090

    It's possible that this might not be possible on this router. As a first step make sure that you using the latest firmware available for the router.

    Even if you aren't able to change the DNS settings for the router itself you might be able to change them in the DHCP section where you configure how DHCP functions on your network.

    0
    Comment actions Permalink
  • Avatar
    stephanieb

    I'm having the exact same problem with the same router.  Did you ever find a solution?  I tried going through Belkin's support to fix it, but they were no help.  

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Why do you post it here and don't refer to Belkin?  OpenDNS don't supply routers...

    -1
    Comment actions Permalink
  • Avatar
    rotblitz

    If you cannot enter DNS resolver addresses on the router, then there is no solution.  How could be it?

    Instead of configuring on the router, configure on the end user devices.
    https://support.opendns.com/categories/20080020

    -1
    Comment actions Permalink

Please sign in to leave a comment.