Can't change IP address for new Modem/Router

Comments

7 comments

  • Avatar
    rotblitz

    "I have followed all the steps given to change the IP address"

    Why and where do you want to change what IP address?  Where are "all the steps given" listed?

    "I get the following message: "You cannot add a network in private IP space"."

    Yes, you cannot add a private IP address at https://dashboard.opendns.com/settings/ 
    Using a private IP address does not make sense.  You must use your public IP address, because this is the one visible on the internet, so visible by OpenDNS.

    To see where your problems may be, post the complete plain text output of the following diagnostic commands:

       nslookup -type=txt debug.opendns.com.

       nslookup whoami.akamai.net.

    0
    Comment actions Permalink
  • Avatar
    jpapin

    Thank you for helping.  I don't know the difference between a public and private IP address.  How do I find the public IP address?  The address already in Open DNS (the one I was using for my old modem/router), is not working since I changed the modem/router.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Frustrating that you didn't provide the requested information and answered the questions, but raised even more questions.  How can one help then???

    "I don't know the difference between a public and private IP address."

    Why don't you know?  Search engines are your friend!  http://lmgtfy.com/?q=private+public+ip+address

    "How do I find the public IP address?"

    The public IP address where your DNS traffic is coming from would have been seen from the command outputs which you didn't post.
    It's the "source" field from the first command and maybe the IP address returned from the second command.

    0
    Comment actions Permalink
  • Avatar
    jpapin

    Thank you for responding again.  I wasn't clear on what I was trying to say on the last post, but it is not important to go into that much.  I did not understand what you were asking for in your first response.  My fault, not yours.  I'm sure it's basic to you, but to me, it's a different "language".  I understood the concept of Public and Private IP.  I found my Public IP, it is the same one that Open DNS is using, however, It's still not working in filtering anything.

    I think I may have figure out what you were talking about.  I have never gone into the computer command line on my Mac.  From Google, I found that Mac uses "dig" instead of "nslookup"

    dig -type=txt debug.opendns.com.

    ; <<>> DiG 9.8.3-P1 <<>> -type=txt debug.opendns.com

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30228

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

     

    ;; QUESTION SECTION:

    ;debug.opendns.com. IN A

     

    ;; ANSWER SECTION:

    debug.opendns.com. 15 IN A 92.242.140.2

     

    ;; Query time: 12 msec

    ;; SERVER: 68.105.28.11#53(68.105.28.11)

    ;; WHEN: Mon Mar  7 05:37:04 2016

    ;; MSG SIZE  rcvd: 51

     

    dig whoami.akamai.net.

    ; <<>> DiG 9.8.3-P1 <<>> whoami.akamai.net.

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50997

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

     

    ;; QUESTION SECTION:

    ;whoami.akamai.net. IN A

     

    ;; ANSWER SECTION:

    whoami.akamai.net. 26 IN A 68.105.28.43

     

    ;; Query time: 10 msec

    ;; SERVER: 68.105.28.11#53(68.105.28.11)

    ;; WHEN: Mon Mar  7 05:45:15 2016

    ;; MSG SIZE  rcvd: 51

     

    I don't understand anything that came up on in the Command lines.   I do not know what I am looking for.  I see different IP addresses, but I don't know what to do with each one.

    Thank you for any help on this again.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "From Google, I found that Mac uses "dig" instead of "nslookup""

    Well, OS X has almost also nslookup implemented, not just dig.  However, the syntax for dig is different from nslookup, so your first command output doesn't do what it should.  The correct syntax would be

       dig txt debug.opendns.com.

    You don't need to post the correct output right now, because...

    ; SERVER: 68.105.28.11#53(68.105.28.11) whoami.akamai.net. 26 IN A 68.105.28.43

    From both command outputs I'm seeing that you are not using OpenDNS, but 68.105.28.11 and 68.105.28.43 which are clearly Cox's DNS resolver addresses.  You either did not configure the OpenDNS resolver addresses at all, or you configured them at the wrong place.  So, as the first step, configure the OpenDNS resolver addresses on your router or on your computer, before anything else can work.
    https://support.opendns.com/categories/20080020

    Then test by visiting http://welcome.opendns.com/ to see if you're now using OpenDNS.  Everything else, like your IP address or your dashboard, is totally irrelevant as long as you don't use OpenDNS, i.e. don't send your DNS queries to OpenDNS, but still to Cox.

    Now, as a second step, if you're using OpenDNS or even not, copy & paste the complete plain text output of the corrected dig command.

    0
    Comment actions Permalink
  • Avatar
    jpapin

    Thank you again for your help.  You are right on.  Cox Communications came out and installed the router/modem.  So I'm sure they set it up with their address as you thought.  From spending a lot of time on this last night,  it looks like I need to reset it to factory settings to try to make it all work.  I am not sure and need to look into even more then I have been.  I am not sure what I will get if I do reset it.  I don't want to lose the internet completely and then not know how to get it going with the right addresses.  I have to look into even more first.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Seing your level of skills, I strictly recommend to not reset the device to it's factory defaults.  You likely risk to lose your internet connection.

    0
    Comment actions Permalink

Please sign in to leave a comment.