dns setting is overwritten in ppp

Comments

11 comments

  • Avatar
    rotblitz

    ddclient is totally irrelevant with your problem. This is the update client only and has nothing to do with your DNS settings.

    Regarding your configuration of the OpenDNS resolver addresses, did you strictly follow https://store.opendns.com/setup/operatingsystem/ubuntu ?

    You should get rid of  "nameserver 127.0.0.1"  in your resolv.conf using the related maintenance tool. And the OpenDNS resolver addresses should not be listed more than once.

  • Avatar
    tabebqena

    I follow the instructions , it work for the current session only ,

    I apply the note(number 8 ) to make the changes globally ...

    the commands is :

    sudo cp /etc/resolv.conf /etc/resolv.conf.auto
    sudo find /etc -name dhclient.conf
    gksudo gedit /etc/dhcp3/dhclient.conf
    # add the following line to the document before the 'require subnet-mask' command
    supersede domain-name-servers 208.67.222.222,208.67.220.220;
    # save and exit
    $ sudo ifdown eth0 && sudo ifup eth0    # the output is (ifdown: interface eth0 not configured
    )

     

  • Avatar
    rotblitz

    "the output is (ifdown: interface eth0 not configured"

    This indicates that you don't have eth0 configured, but another network device name. So use this instead..

  • Avatar
    tabebqena

    dr@dr-Satellite-C660:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr b8:88:e3:11:27:30 
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    lo        Link encap:Local Loopback 
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:8 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:440 (440.0 B)  TX bytes:440 (440.0 B)

    ppp0      Link encap:Point-to-Point Protocol 
              inet addr:10.104.95.92  P-t-P:10.64.64.64  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
              RX packets:2470 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2662 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1974993 (1.9 MB)  TX bytes:356761 (356.7 KB)

    dr@dr-Satellite-C660:~$ sudo ifdown eth0
    ifdown: interface eth0 not configured
    dr@dr-Satellite-C660:~$ sudo ifdown lo
    dr@dr-Satellite-C660:~$ sudo ifdown ppp0
    ifdown: interface ppp0 not configured
    dr@dr-Satellite-C660:~$ sudo ifup lo

  • Avatar
    tabebqena

    I had google the error "interface eth0 not configured"

    & fix it by
     root@dr-Satellite-C660:/home/dr/ddclient# sudo ifconfig eth0 down
    root@dr-Satellite-C660:/home/dr/ddclient# sudo ifconfig ppp0 down
    root@dr-Satellite-C660:/home/dr/ddclient# sudo ifconfig lo down
    root@dr-Satellite-C660:/home/dr/ddclient# sudo ifconfig lo up
    root@dr-Satellite-C660:/home/dr/ddclient# sudo ifconfig eth0 up
    root@dr-Satellite-C660:/home/dr/ddclient# sudo ifconfig ppp0 up

    is it valid ...

  • Avatar
    rotblitz

    Well done! As you said in the subject already: "dns setting is overwritten in ppp", yes, ppp0 seems to be the network device name being in use for your internet connetion. You may be able to exempt the loopback interface (lo) from this procedure.

  • Avatar
    tabebqena

    ok , thanks , the settings are fixed now especially after adding # to the line :  dns = dnsmasq in the file  /etc/NetworkManager/NetworkManager.conf ...


    another question please ,
    I had this massage :

     root@dr-Satellite-C660:/home/dr# /etc/init.d/ddclient start
    Starting ddclient: WARNING:  skipping host: : 'login=' is an invalid login.
    WARNING:  skipping host: web=myip.dnsomatic.com: 'login=' is an invalid login.

    hint : in my conf. file , what of the following is valid :
    login = tabebqena

    login = tabebqena@gmail.com

    login = "tabebqena"

    login = "tabebqena@gmail.com"

    almost I used all of them with the same result .

    Note : when I login from the browser using the username (tabebqena), the login fail . successful login ocurrs only when I use  the mail (tabebqena@gmail.com)

  • Avatar
    rotblitz

    Only grandfathered accounts have a username as login credentials (like mine). Newer accounts use the e-mail address. Not sure if spaces around the equal sign are valid, better don't use spaces. That said, try with:

    login=tabebqena@gmail.com

  • Avatar
    tabebqena

    the same result :

     
    dr@dr-Satellite-C660:~$ sudo /etc/init.d/ddclient start
    Starting ddclient: WARNING:  skipping host: : 'login=' is an invalid login.
    WARNING:  skipping host: web=myip.dnsomatic.com: 'login=' is an invalid login.

  • Avatar
    rotblitz

    Best is to open a support ticket now. We users may not be able to help here.

  • Avatar
    tabebqena

    many thanks .....

     

Please sign in to leave a comment.