OpenDNS Not Working Again - Help!

Comments

32 comments

  • Avatar
    cervezafria

    Login to your Dashboard when this is happening. Does the IP address that OpenDNS sees from you ("Your current IP is...") match the IP address on you account?

  • Avatar
    rotblitz

    "I confirmed that my router's  DNS  server settings are:

    • 208.67.222.222
    • 208.67.220.220"

    And how many DNS server entry fields are there? If more than two, fill them with 208.67.222.220 and 208.67.220.222.

    "My WAN connection is Dynamic IP.   OpenDNS automatic updates have been turned on for years. "

    Fine. And do you run also an Updater within your network? What Updater is this? Else your IP address information will not be updated, and your settings do not take effect.

    "I flushed cache as prescribed via:  ipconfig /flushdns  .    I also flushed browser cache."

    Fine. But this should not be needed as "I haven't changed anything on my PC or route?? ". Or the latter is exactly the problem. Not to change anything can often be the culprit for everything.

    If you still can't solve your problem after having followed our advices, post the complete plain text output of the following commands here:

    nslookup -type=txt debug.opendns.com.

    nslookup www.exampleadultsite.com.

  • Avatar
    nickva

    Reply to cervezafria:  I don't see/understand what you're asking me to compare.  Are you asking me to compare (2) IP addresses located somewhere on my  Dashboard?    Precisely,  where do I locate each of these (2) IP addresses?  Could you give me precise navigation (links/buttons)  that will bring me to each of the (2) IP addresses you wish me to compare?

    Reply to rotblitz:   OpenDNSUpdater.exe  is running on my PC as a Task Manager process.  It was installed on my PC  by running  (OpenDNS-Updater-2.2.1.exe).  Does this count as "running an Updater within my network"?   If not,  would you kindly explain how to "run an Updater within my network"?

    Reply to rotblitz:  Nslookup results that you requested:

    C:\>nslookup -type=txt debug.opendns.com.

    Server:  resolver1.opendns.com

    Address:  208.67.222.222

     

    Non-authoritative answer:

    debug.opendns.com       text =

     

            "server 11.ash"

    debug.opendns.com       text =

     

            "flags 20 0 2f4 0"

    debug.opendns.com       text =

     

            "id 0"

    debug.opendns.com       text =

     

            "source 70.15.136.124:60823"

     

    C:\>nslookup www.exampleadultsite.com.

    Server:  resolver1.opendns.com

    Address:  208.67.222.222

     

    Non-authoritative answer:

    Name:    www.exampleadultsite.com

    Address:  67.215.92.210

     

     

    C:\>

     

     

     

  • Avatar
    rotblitz

    "Precisely,  where do I locate each of these (2) IP addresses?"

    Visit https://dashboard.opendns.com/settings/ and compare the IP addresses:

    • At the top after "Your current IP is ..."
    • The one registered with your network under "Your networks"

    "Does this count as "running an Updater within my network"?"

    Yes, it does.

    Regarding your output, your IP address 70.15.136.124 is not registered with any OpenDNS network, especially not with yours, so your settings cannot take effect. That's normal under these circumstances. Your check at https://dashboard.opendns.com/settings/ from above will confirm this.

  • Avatar
    rotblitz

    Back to your Updater, you don't have "Send Dns-O-Matic Updates" enabled, do you? You must not!

  • Avatar
    nickva

    Re: Multi-page attachment.   

    My "Enable Dynamic IP Update"  check-box setting has been checked (on) for years.  Does that setting equate "Send Dns-O-Matic Updates" enabled"?  If not,  how do I enable "Send Dns-O-Matic Updates"?

     

    You said, "Regarding your output, your IP address 70.15.136.124 is not registered with any OpenDNS network, especially not with yours, so your settings cannot take effect."      

    Re:  attachment.   My OpenDNS network, "HomeNF",  lists (2) IP addresses.  They are:  70.15.139.186  and   70.15.136.124 .   You will see that  70.15.136.124 is greyed /dimmed.   70.15.139.186 is NOT  greyed /dimmed. 

     

    My problem persists.   Based on the info provided,  what action(s)  do I need to take?  Do you need additional info?

     

    Thanks for your reply.




    Miscl Info Settings.doc
  • Avatar
    rotblitz

    "Does that setting equate "Send Dns-O-Matic Updates" enabled"?"

    No, this setting is not at your dashboard, but in your OpenDNS Updater.

    "If not,  how do I enable "Send Dns-O-Matic Updates"?"

    No, not enable, but disable if enabled. If you have it enabled, it most likely will not do its update job. :(

    "My OpenDNS network, "HomeNF",  lists (2) IP addresses.  They are:  70.15.139.186  and   70.15.136.124"

    Yes, 70.15.139.186 is the registered one, but 70.15.136.124 is your actual one. You must click the green arrows icon between them to register your current IP address with your network. Then everything should work after you also flushed your local resolver cache and your browser cache.

    And if you fix also the problem with the Updater (i.e. disable "Send Dns-O-Matic Updates"), it should work further on if your IP address changes again.

  • Avatar
    nickva

    rotblitz -  As you suggested, I "clicked the green arrows icon between them to register your current IP address with your network."   THAT DID IT.   My OpenDNS is now working/blocking as it should.   Thank you very much!

    Could you answer just a few more questions?   You said I should disable  "Send Dns-O-Matic Updates".    Doesn't that feature keep DNS IP addresses in sync?  Isn't that something I would want to keep enabled?   What you're suggesting (disable it) is counter intuitive to me.  Could you further  explain why  I should disable the "Send Dns-O-Matic Updates"  feature?    

    To disable "Send Dns-O-Matic Updates",  do I remove "OpenDNS Updater 2.2.1"  (re: attachment)  from my PCs   (XP)   (Add or Remove Programs) list? 

    If not, precisely how do  I disable the "Send Dns-O-Matic Updates" feature?

     

    Thanks again for your reply.




    MoreInfo_OpenDNS.doc
  • Avatar
    rotblitz

    "You said I should disable  "Send Dns-O-Matic Updates".    Doesn't that feature keep DNS IP addresses in sync?  Isn't that something I would want to keep enabled?"

    If you have the option disabled, your updates go directly to OpenDNS. If you enable this option, the Updater tries to send your IP address information updates to DNS-O-Matic (http://www.dnsomatic.com), not to OpenDNS. Do you know DNS-O-Matic? If not, you should disable this option in the Updater. If yes, ensure that you have your services correctly configured at DNS-O-Matic.

    "To disable "Send Dns-O-Matic Updates",  do I remove "OpenDNS Updater 2.2.1""

    Oh no, not at all, else your IP address information updates do no longer take effect, and you run into the same troubles again and again.

    To disable the option. double-click the OpenDNS Updater icon in the systray, then click "Settings", and then uncheck "Send Dns-O-Matic Updates" and confirm with clicking the "OK" button.

  • Avatar
    nickva

    rotblitz -   Dns-O-Matic Updates is now UNCHECKED.  Thanks again for taking the time to explain how these features work!  Many thanks!

  • Avatar
    nickva

    Correction:  "Send Dns-O-Matic Updates"  is UNCHECKED......

  • Avatar
    khenimvu

    Hello,
    i have a problem. after i read all forum about OpenDNS not working i cant find solution..
    this is the result :
    1.
    ============================================
    C:\Users\Khen>nslookup -type=txt debug.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    *** resolver1.opendns.com can't find debug.opendns.com.: Non-existent domain
    ===============================================================
    2.
    ==========================================================
    C:\Users\Khen>nslookup -type=txt which.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."
    ==============================
    3.
    ==========================================================
    C:\Users\Khen>nslookup -type=txt which.opendns.com. 208.67.222.222
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."
    ==============================
    im really confused why it say "not an OpenDNS resolver"
    thanks and sorry if my English is bad

  • Avatar
    rotblitz

    Your ISP redirects your DNS queries to their own DNS service, so you cannot use OpenDNS by simply configuring the resolver addresses.

    You may give it a try with using the dnscrypt-proxy from http://dnscrypt.org/
    See also: https://support.opendns.com/entries/25418695-I-tried-everthing-but-OpenDNS-still-not-working

  • Avatar
    khenimvu

    I have been follow this

    https://support.opendns.com/entries/25418695-I-tried-everthing-but-OpenDNS-still-not-working

    its working now.. but i setting DNS on computer..
    how i can setting DNS in router ?
    this, when i insert 127.0.0.1
    it says Invalid IP Address

    Thank you so much




    Image.jpg
  • Avatar
    rotblitz

    Sure, because you run the dnscrypt-proxy on the computer, it cannot take effect on the router.  It is normal that the router rejects 127.0.0.1 which is the localhost address.

    What you can try:

    Start the dnscrypt-proxy with the following parameters:

    dnscrypt-proxy.exe  --local-address=192.168.2.11    (replace 192.168.2.11 by the IP address of your computer where dnscrypt-proxy is running!)

    For starting the Windows service this way, you need to change the registry for this,
    see https://github.com/jedisct1/dnscrypt-proxy/blob/master/README-WINDOWS.markdown
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\dnscrypt-proxy\Parameters\LocalAddress     (REG_SZ)

    Then change the DNS server settings on the computer and on the router to this IP address.  Maybe this works.

  • Avatar
    rotblitz

    Ah no, better try with changing the DNS server address on the computer from 127.0.0.1 to the router's IP address 192.168.1.1, and on the router to the computer's IP address.

  • Avatar
    khenimvu

    Sorry im not understand what do you mean sir..
    I have to change DNS server address on router to which number ??

    here i want to set DNS server on computer to set automatically..
    sorry i want to ask, if i set DNS server on router with DNS from dnscrypt-proxy it will work every computer which using connection from my router, right ?
    thank for reply and sorry for my bad English

  • Avatar
    khenimvu

    Ah i know..
    i have been try this :

    =============================================================================================

    Start the dnscrypt-proxy with the following parameters:

    dnscrypt-proxy.exe  --local-address=192.168.2.11    (replace 192.168.2.11 by the IP address of your computer where dnscrypt-proxy is running!)

    For starting the Windows service this way, you need to change the registry for this,
    see https://github.com/jedisct1/dnscrypt-proxy/blob/master/README-WINDO...
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\dnscrypt-proxy\Parameters\LocalAddress     (REG_SZ)

    Then change the DNS server settings on the computer and on the router to this IP address.  Maybe this works.

    =============================================================================================

    when i only set on DNS router its not working.. but after i set on DNS router and Computer. its working..
    My ISP always redirect my DNS..
    conclusion :
    if i set DNS on computer to automatically my ISP will always redirect my DNS, even i set DNS on router ? right ?
    thank you so much

  • Avatar
    rotblitz

    "when i only set on DNS router its not working."

    Not if you use an external resolver address on the router.  If you use your computer's then I would think it works.  The router then sends the DNS queries to the computer, and the dnscrypt-proxy on the computer sends them to OpenDNS.

    "but after i set on DNS router and Computer. its working.."

    Fine.

    "if i set DNS on computer to automatically my ISP will always redirect my DNS, even i set DNS on router ? right ?"

    Your ISP will always redirect your DNS queries if they are sent over port 53.  The dnscrypt-proxy however sends them over port 443 and encrypts them, so that your ISP is no longer able to recognize them.

  • Avatar
    khenimvu

    "Not if you use an external resolver address on the router.  If you use your computer's then I would think it works.  The router then sends the DNS queries to the computer, and the dnscrypt-proxy on the computer sends them to OpenDNS."

    Can make it works on every computer which use connection from my router without changing DNS on every computer ( i mean DNS on computer set to automatically ). Im newbie about DNS. :(

    Do you know sir how to use an external resolver address on router ?
    BTW thanks for your reply.

  • Avatar
    rotblitz

    "Can make it works on every computer which use connection from my router without changing DNS on every computer ( i mean DNS on computer set to automatically )."

    Yes.  If you configured your computer's IP address (where the dnscrypt-proxy runs) as the only DNS server address on the router, all DNS queries from all devices are sent to your computer where the dnscrypt-proxy forwards them to OpenDNS.  You must leave the computer switched on, of course.

    "Do you know sir how to use an external resolver address on router ?"

    External resolver addresses are e.g. 208.67.222.222 and 208.67.220.220 for OpenDNS.  You cannot configure them on the router or the computer, because your ISP would redirect them to their DNS service.  Only a DNS proxy (like dnscrypt-proxy) can circumvent this restriction.

  • Avatar
    khenimvu

    If i set IP address manually..  automatically DNS must be sat manual too sir.. :(

    "Can make it works on every computer which use connection from my router without changing DNS on every computer ( i mean DNS on computer set to automatically )."

    Yes.  If you configured your computer's IP address (where the dnscrypt-proxy runs) as the only DNS server address on the router, all DNS queries from all devices are sent to your computer where the dnscrypt-proxy forwards them to OpenDNS.  You must leave the computer switched on, of course."


    this is my last question sir..im confused how to set only from router.. could you please give me example setting on router sir ?
    thanks in advance..

  • Avatar
    khenimvu

    I mean example setting to make its work without changing DNS server on every computer (set automatically).

    thanks again

  • Avatar
    rotblitz

    You set "Primary DNS Server" at https://support.opendns.com/attachments/token/sljfsaz05qurdgz/?name=Image.jpg to your computer's IP address, the computer where the dnscrypt-proxy runs.

  • Avatar
    khenimvu

    Okay sir its work..
    thanks for your help.

  • Avatar
    rotblitz

    Excellent!  You're welcome.

  • Avatar
    abedahmed

    Hi why OpenDNs not working whit me

    It works the first time but when i install Ubutnu Not working

    HElp me

  • Avatar
    rotblitz

    @abedahmed, what about opening your own thread instead of appending to this long and old thread?

    And it would help if you posted the complete plain text output of the following command in your new thread:

    nslookup -type=txt debug.opendns.com.

  • Avatar
    adeytrash

    I have run the updater then logged onto the website only to find that my home network IP is not showing on the website, and this always occurs after a router reboot, hence the update has been run but does not update the IP address the only way to do this is to log on to the OPENDNS website delete the existing network and then add a new one and it picks up the correct IP and it starts working again. Test it your self reboot your router, run the updater program, check online to see if the IP address has been updated.

     

    Hence the OPEN DNS updater v 2.2.1 is clearly not working. Typical! free products never seem to work correctly.

  • Avatar
    mattwilson9090

    Just because the updater is not working perfectly for you does not mean it is not working for anyone. I replaced my Dad's computer this past Sunday, installed the Updater and it's working fine, just like it has for the last several years.

    On your dashboard settings are these networks that you keep deleting and recreating set as a dynamic network, or is it set as a static network? My suspicion is that they aren't configured as dynamic updates.

Please sign in to leave a comment.