Comments

15 comments

  • Avatar
    cindelicato

    First off, if anything at all is happening, OpenDNS would 'reject' (or rather: filter and block) Gmail, not the other way around.

    I use OpenDNS with GMail on my iPhone (Umbrella) , no issues.

     

    Please describe what you mean by 'rejecting', or adjust your policy settings.  Without details, I cannot be more specific.

     

     

    -1
    Comment actions Permalink
  • Avatar
    mkinder80122

    actual the previous description is correct. If OpenDNS is in user Gmail give the error:

    Cannot connect to the real gmail.com

     

    Something is currently interfering with your secure connection to gmail.com.

    Try to reload this page in a few minutes or after switching to a new network. If you have recently connected to a new Wi-Fi network, finish logging in before reloading.

    If you were to visit gmail.com right now, you might share private information with an attacker. To protect your privacy, Chrome will not load the page until it can establish a secure connection to the real gmail.com.

     I would call this gmail rejecting access with OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    Dominic Bannister

    Hi,

    What browser are you using? 

    Are you receiving the same error message cross all browsers? 

    Are you only unable to load gmail.com? 

    Can you get to other HTTPS sites? 

    I would recommend that you clear your browser's cache (https://support.google.com/chrome/answer/95582) and try loading the site again. 

     

    0
    Comment actions Permalink
  • Avatar
    97itr217

    Has this issue been resolved? I tried both Chrome and IE11 but no matter what I did, I couldn't get gmail to work completely.

    In my case, gmail will load but most buttons do not work. Images from google.com also were not loading. I have already unchecked the checkbox for "web mail" and  added "google.com" and "google.ca" to the whitelist.

    Other https links seem to work fine, already tried.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This isn't a general issue but how you configured your settings.  Find out the related domains still being blocked to unblock them: 
    https://dashboard.opendns.com/stats/all/blockeddomains

    Another tool to see DNS lookups in real-time: http://www.nirsoft.net/utils/dns_query_sniffer.html

    0
    Comment actions Permalink
  • Avatar
    97itr217

    Thank you for your response rofblitz.

    I looked at the list of blocked domains. Although google/gmail wasn't showing on the list, my gmail page was also half-loaded.

    Attached is what I visually see after gmail has been logged on and loaded. Those orange boxes are cut-out but you get the idea: the background picture wasn't loaded, the logout button wasn't working (though picture was loaded), labels for a number of buttons are not loaded.

    How likely is this problem gonna be fixed?




    gmail.png
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "How likely is this problem gonna be fixed?"

    Didn't I say that this isn't a general problem?  Therefore nobody else can fix it for you except yourself.  And the likelyness that you can fix it is 105%.  You must fix your settings to not block domains you don't want to be blocked.  I don't use Gmail, so can't advise what domains these would be.

    A way to find out the blocked domains would be to right click the place with the orange boxes to see the properties, i.e. the exact URL with the domain name contained.  Or you can look into the HTML source of the impacted page.

    Else you may have to use the tool to find out the domain names in question.  You may post a screen shot from the tool and/or from https://dashboard.opendns.com/stats/all/blockeddomains so that I may be able to identify the domain names.

    0
    Comment actions Permalink
  • Avatar
    97itr217

    Please excuse my ignorance but I can't really tell what I can fix.

    As I said, I have verified that "google.ca" and "google.com" are not in the list of blocked domains (as shown). I unchecked the "WebMail" in my settings and added "google.ca" and "google.com" in my never block list (as shown). Please educate me what else I can fix, I'd love to learn.

     




    block-domains.png
    settings.png
    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    The issue that you're seeing is that all or parts of Gmail are being blocked by your filtering settings. Specifically, you have gstatic.com blocked on your network which would prevent Google's images from appearing in GMail because these images are loaded from gstatic.com. 

    For more information regarding the privacy certificate error, refer to https://support.opendns.com/entries/42404534-Chrome-with-Facebook-the-block-page-Your-connection-is-not-private-or-Cannot-connect-to-the-real-www

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    In your blocked domains list from today (Sep 17) there are almost Microsoft related domains, not Google's.  You may select another day (e.g. yesterday) to see more Google relevant stuff.  Btw, not a good idea to block the related category Software/Technology, because this can prevent from installing important Windows hotfixes...

    From your settings I see that you block gstatic.com. :shocked:  This and its subdomains are very hard used by Google for their static content (gstatic = Google static), and blocking this is most likely the root cause of your problems with Gmail.

    Therefore remove gstatic.com from your "always block" list, flush both, your local resolver cache and your browser cache, and your issue will be past.

    0
    Comment actions Permalink
  • Avatar
    97itr217

    Thank you very much, Alexander and rotbilz. Your answer is right on. Blocking gstatic is the culprit.

    When I first set things up, I saw gstatic quite a bit and hitting up gstatic.com returned nothing. So I decided this may be one of the spam web sites or sites that people make money on, as a result I blocked it. At first, gmail was still working properly. But after a few days (or about a week), gmail started acting erratically. Finally gmail.com is only half-loading on my computer. Too bad that I didn't clue it on blocking gstatic.

    At the end, few lessons learned on me. I love forums like OpenDNS where people would give informative suggestions rather than shouting, cursing and calling people stupid. Keep good info flowing please.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Interesting the comments at https://domain.opendns.com/gstatic.com

    Since the icons for Google Apps and specifically GMail are located at this domain, it is impossible to block this and keep Google Apps functionality for our teachers. It is unfortunate that this is also the domain where image search thumbnails are kept,

    It is Very unfortunate that the Mail icons are located at this same domain.

    But the domain gstatic.com isn't used at all, but subdomains of it only: https://community.opendns.com/domaintagging/search/?q=gstatic.com

    That said, if one wants to be more granular with blocking and whitelisting, there's a chance to do so...

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    A good chunk of Google Images' images are loaded from the following domains, so it's popular to try and block them with gstatic.com. Note that the first few Google Image  search results display from a data: URI (in short - can't be blocked without blocking google.com).

    encrypted-tbn0.gstatic.com

    encrypted-tbn1.gstatic.com

    encrypted-tbn2.gstatic.com

    encrypted-tbn3.gstatic.com

    encrypted-tbn.l.gstatic.com

    Most gmail images come from csi.gstatic.com and ssl.gstatic.com so these could also be whitelisted over gstatic.com's block. 

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Good points!  However, there is no encrypted-tbn.l.gstatic.com.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    That's right - Google changed things around a bit so encrypted-tbn.l.google.com is now tbn.l.google.com and that list has been updated. Each of the encrypted-tbn*.gstatic domains used to be encrypted-tbn*.google.com as well.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.