OpenDNS not working

Comments

34 comments

  • Avatar
    rotblitz

    Copy and paste the complete plain text output of the following command, and post it here:

    nslookup -type=txt debug.opendns.com.

    0
    Comment actions Permalink
  • Avatar
    toweyik

    Hi, folks. Sorry to pile on, but I was about to ask the same question. My router has the correct dns settings, my Updater ran successfully, I flushed cache, and still no blocking. This was working great until recently. We had a power outage that restarted everything. Maybe that did it, but I can't see how it would keep the OPENDNS settings and not use them.

    C:\>nslookup -type=txt debug.opendns.com.
    Server:  resolver1.opendns.com
    Address:  208.67.222.222
    Non-authoritative answer:
    debug.opendns.com       text =
            "server 7.ash"
    debug.opendns.com       text =
            "flags 20 0 2f4 800000000000000"
    debug.opendns.com       text =
            "id 0"
    debug.opendns.com       text =
            "source 65.188.188.112:64989"

    0
    Comment actions Permalink
  • Avatar
    toweyik

    Never mind. I deleted and re-added my network. Whatever it was, it's fixed now.

    1
    Comment actions Permalink
  • Avatar
    rotblitz

    The problem was that your IP address 65.188.188.112 was not registered with any OpenDNS network, especially not with yours ("id 0"), therefore your settings could not take effect. You had to update your network with your IP address information, e.g. by running an Updater.

    Deleting and adding your network does not help by itself. This is a solution for nothing. However, when you added the network again, you certainly have also registered your IP address with your network, so it seemed only you solved it this way.

    0
    Comment actions Permalink
  • Avatar
    gretiro

    I have a network with a wireless router, despite having configured the OpenDNS some machines, notebooks access blocked sites, set up a wired PC and found that the windows in IE 7 or 8 to access the majority of social networks that had blocked. How can I configure dns for all machines that use the router not access these sites?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    We cannot know, as you didn't tell us other users what router you have and didn't point us to an online manual of your router.

    What message does show up if you visit http://welcome.opendns.com/ from these computers where social networks should be blocked?

    Only if it says "You're using OpenDNS", then post the complete plain text output of the following command here:

    nslookup -type=txt debug.opendns.com.

    0
    Comment actions Permalink
  • Avatar
    gretiro

    Model router d-link DSL 2730B, set to HI operator in Brazil. Inserted both primary as secondary DNS of OpenDNS. only the pc with windows xp OpenDNS blocked the requested sites in windows 7, windows 8 and notebook that uses wi-fi, access is still allowed by the Internet Explorer browser!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    And further? Read my message again, and respond to everything, not just to the first part of the first sentence.

    Also, I couldn't find an online manual for this model in one of the languages I speak.

    "set to HI operator in Brazil"

    What could this mean?...

    0
    Comment actions Permalink
  • Avatar
    dealguy

    I'm having the same issue.  I've done the same things as the original poster. I'm using a Linksys WRTU54G-TM router.  I'm probably just missing something simple.

    c:\>nslookup -type=txt debug.opendns.com.
    Server:  resolver1.opendns.com
    Address:  208.67.222.222

    Non-authoritative answer:
    debug.opendns.com       text =

            "server 5.ash"
    debug.opendns.com       text =

            "flags 20 0 2fe 7e00400014c3"
    debug.opendns.com       text =

            "id 16007159"
    debug.opendns.com       text =

            "source 50.160.199.51:60506"

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    Same problem here. I have done everything in this open ticket. I setup the IP address in my DNS settings, cleaned the cache of browser and ipconfig /flushdns.

    I deleted and re-added my network in the Open DNS website. I can't make it to work. All websites are accessible.  I would really appreciate some help. Thanks in advanvce.

    0
    Comment actions Permalink
  • Avatar
    Phil

    Same problem.  I registered 98.100.84.54 with OpenDNS to my WiFi policy with Moderate settings and can still access playboy.com.  I seem to be able to access everything.

    Server: dns-cac-lb-01.rr.com
    Address: 209.18.47.61

    *** dns-cac-lb-01.rr.com can't find debug.opendns.com.: Non-existent domain

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @dealguy
    Linksys? You must fill DNS 3 with one of 208.67.222.220 or 208.67.220.222. Then flush both, your local resolver cache and your browser cache, and you should be good to go ahead.

     

    @zukkaus
    "I deleted and re-added my network in the Open DNS website." - This was nonsense. You can save such efforts. This activity is not part of any instructions for troubleshooting. As you didn't provide the information asked for, we can't help you further.

     

    @Phil
    Whatever you did, you didn't configure the OpenDNS resolver addresses at the right place. This 209.18.47.61 is definitely not an OpenDNS resolver address, but a Road Runner address (dns-cac-lb-01.rr.com). Content filtering works only if you use OpenDNS, not if you use Road Runner...
    The OpenDNS resolver addresses are 208.67.222.222, 208.67.220.220, 208.67.222.220, 208.67.220.222.

    0
    Comment actions Permalink
  • Avatar
    dealguy

    @rotblitz  Thanks!  I had DNS3 filled in already, but suspect I hadn't properly flushed either the local resolver or browser cache as it seems to be working fine now.

    0
    Comment actions Permalink
  • Avatar
    Phil

    rotblitz,

    That's what it was.  The router didn't save the DNS settings.  I thought it did.

    Thank,

    Phil

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @dealguy and @Phil, glad to hear that it works for you now. :)

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    Thanks for the fast response Rotblitz, this is the output when running nslookup -type=txt debug.opendns.com

    Server:   resolver1.opendns.com

    Address:   208.67.222.222

     

    Non-authoritative answer:

    debug.opendns.com         text=

                      "server 9.dfw"

    debug.opendns.com

                      "flags 20 0 2f6 0"

    debug.opendns.com           text=

                       "id 16011037"

    debug.opendns.com

                        "source 184.155.56.214:50402"

     

    I cleared the browser cash and flushed DNS. Still not working. And I cannot think on anything else to do. Thanks for the support. 

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    According to this output everything should work. What does not work? Can you provide us with examples please, i.e. domain names which do not deliver the expected reaction?

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    Rotblitz, thanks for your reply. I am able to go to playboy.com., penthouse.com, facebook.com, twitter.com.  All of them are accessible. 

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Ok, then post the output of the following commands:

    nslookup www.playboy.com.
    nslookup www.penthouse.com.
    nslookuop www.facebook.com.
    nslookup www.twitter.com.

    Also, let us know what browser you're using.

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    nslookup www.playboy.com

    Server:  resolver1.opendns.com

    Address: 208.67.222

    Non-authoritative answer:

    Name: Playboy.com

    Address:  66.254.102.216

     

    Nslookup www.penthouse.com

    Server:  resolver1.opendns.com

    Address: 208.67.222

    Non-authoritative answer:

    Name: penthouse.com

    Address:  208.88.180.54

     

    Nslookup www.facebook.com

    Server:  resolver1.opendns.com

    Address: 208.67.222

    Non-authoritative answer:

    Name: star.c10r.facebook.com

    Address:  69.171.242.27

     

    nslookup www.twitter.com

    Server:  resolver1.opendns.com

    Address: 208.67.222

    Non-authoritative answer:

    Name: twitter.com

    Addresses:  199.59.148.10

                            199.59.148.82

                             199.59.148.230

    Aliases: www.twitter.com

     

    I normally use Internet Explorer, but also use Chrome. Same result on both. Thanks for all the help

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    The address is: 208.67.222.222. I copied the result from command prompt, don't know why didn't copy the last .222, it only copied in the first one.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You generally forget the trailing dot after the domain to make it an FQDN, but no worries, it works because you don't seem to have DNS suffixes configured.

    Now post the output of this:

    nslookup  -type=txt  which.opendns.com.  208.67.220.220

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    This is the output of running the command:

    Server:    resolver2.opendns.com

    Address:    208.67.220.220

    Name:    Which.opendns.com

     

    I have made a discovery today. I have 2 laptops which I want to setup Open DNS here in my house, and so far as you know it doesn't filter anything. However, I took both laptops to my office, and it works as desired. Came back home, and nothing is filtered. Something to think about.

     

    As always, thank you for the support.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    No, this isn't the output of the command I listed, but most likely the output of "nslookup which.opendns.com.".

    Please try again...

    0
    Comment actions Permalink
  • Avatar
    shawn.hobbs

    Hi,

    Just finished setting up OpenDNS on linksys wrt54g with dd-wrt. This is a second router in my home. The primary is a belkin n750db. I want to keep this one as the primary as my wife and I use that one and being that our children are cyber-schooled, we have a lot of desktops and laptops that we would like to use opendns with; thereby the second router.

    Here's the problem:

    flushed all cache and dns on all machines, waited a day or so, still the sites I have listed on the opendns account are not being blocked. Also on the opendns page I see an ip address of 208.65.149.242, but on the opendns updater (which I have on one pc on the second router/network), it shows ip address as 24.229.173.2, which is my providers' ip. 

    I'm a newb at this...did I miss something?

    Thanks

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @shawn.hobbs
    You're a newb at especially how to raise issues in a forum...
    Didn't see that this thread is in the middle of handling another problem? Why do you ignore this to break the thread? What prevents you from opening your own thread?

    0
    Comment actions Permalink
  • Avatar
    shawn.hobbs

    Please don't criminalize me. I believed this was a general opendns not working thread. No harm was intented. Apologies

    0
    Comment actions Permalink
  • Avatar
    cervezafria

    @Shawn... Generally speaking It is best to start your won thread, after searching the forum for an answer to your issue. If you find an active thread about your issue, "subscribe" to it and follow along.

    But I see your confusion on this since others (toweyik, gretiro, dealguy, zukkaus, Phil) all jumped in as well, so you're no more "criminalized" than those before you who received help here..

    BTW... Do you use McAfee internet protection on your systems, because it seems you are proxying through their network, which would in effect bypass your OpenDNS filter settings.

    0
    Comment actions Permalink
  • Avatar
    zukkaus

    Rotblitz, sorry about the delay, and yes, you are correct, that was not the output of the command, the output is as follows:

     

    Server:     resolver2.opendns.com

    Address:   208.67.220.220

    Non-authoritative answer:

    which.opendns.com        text  =

    "5.dfw"

     

    I wonder, why it works in my office and it doesn't work at home.

     

    Thank you for the help Rotblitz

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    After your diagnostic outputs everything should work, but according to your sample domain outputs it doesn't.

    The reasons I could think of:

    • Your IP address is not registered with your network, but with somebody else's.
    • You have additional resolver addresses configured, beside the OpenDNS ones.
    • Your browser circumvents OpenDNS in some way, e.g. if you have a proxy configured or turbo mode enabled with Opera or "“show suggestions for navigation errors" enabled with Chrome.
    • "The address is: 208.67.222.222. I copied the result from command prompt, don't know why didn't copy the last .222, it only copied in the first one."
      This can be a reason either. This .222 should not disappear just when copying.
    0
    Comment actions Permalink

Post is closed for comments.