OpenDNS doesn't log anything

Comments

17 comments

  • Avatar
    mrmike1976

    Let me add this:

     

    Microsoft Windows [versie 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Alle rechten voorbehouden.

    C:\Users\Mike>nslookup -type=txt debug.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Niet-bindend antwoord:
    debug.opendns.com text =

    "server 1.ams"
    debug.opendns.com text =

    "flags 20 0 2f6 0"
    debug.opendns.com text =

    "id 16104941"
    debug.opendns.com text =

    "source 84.27.126.214:49413"

     

     

    0
    Comment actions Permalink
  • Avatar
    cervezafria

    For new accts, check back in 24 hours... 

    0
    Comment actions Permalink
  • Avatar
    mrmike1976

    After some hours it seemed to start working.

     

    Then i reset the data. But now i get noting again. How fast does the log update?

     

    0
    Comment actions Permalink
  • Avatar
    mrmike1976

    Addition: 

     

    Last night i set this up, at first it didn't seem to do anything but after a couple of hours it seemed to work ok.  Then i reset all the data in stats and went to bed.

    This morning  i was on the notebook for some time, my kids on tablets, etc. 

     

    Now when i go to stats, i can see activity in the requests between 7am and 10am i have several hundreds. 

    However any other log i requests says it has no data? 

     

    Only the total requests show acivity, all the other ones are empty. 

    What am i doing wrong? How fast does it update the other stats?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "Then i reset the data. But now i get noting again. How fast does the log update?"

    LOL. If you want to see stats, don't purge them. Your purge job will be queued and executes at any time later, when you least expect it to happen. This purge is for other purposes. (Data protection and stuff, after you have disabled logging at all.)

    Again, for new accounts it can take up to 24 hours before stats appear at all. And further on, stats are not real-time, but usually appear 2-3 hours later, sometimes more, depending on system use and performance.

    0
    Comment actions Permalink
  • Avatar
    mrmike1976

    Well i'm glad i got you to chuckle, although i dont think my questions are that strange.  I did the purge last night (my time) after i got it to work i wanted to start with a clean slate.

    Like your website states:  "This button simply deletes all the DNS data we have for this network up to this point in time. Think of it as a way of resetting your stats to zero."

    What you tell me and what the website does, is a bit diffrent. I setup everything as i wanted , did some tests. and then i purged to get clean data. "reseting stats to zero"

     

    This morning and this is a good 10 hours later, i dont get any new data showing up. 

    Is it so weird i ask if anything is wrong, and how often it updates? I dont think it tells me anywere on the website.

     

    I read that you said it can take up to 24 hours for a new account, But when i started working a couple hours after i set it up. I didn't think i would encounter more problems. 

     

    I am now roughly 24 hours later, and still have the same thing. I see the total requests but no other stats have any data.

    Is this because of the purge? 

     

    Regards,

    Mike

     

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "Like your website states"

    LOL again. Although I have some websites, I'm not aware that something like that is quoted there. Just for the sake of clarity, I'm a user like you. That said, all of this is my pure personal subjective experience with the OpenDNS functionality since 2007, not more, not less

    After all, I think you must be much more patient with your stats. Don't purge them, but return to them 2-3 hours after the new calendar day, then all stats for the previous day should have been collected and may be ready for presentation. If this is not the right time for you, return to your stats in the morning to review yesterday.

    And be ensured, there will be surprises, big surprises, as for everybody else seeing the DNS stats the first time...
    Your real questions may start at this point...

    0
    Comment actions Permalink
  • Avatar
    mrmike1976

    Well i seem to make your day :P 

    But yes, i have many good and fine qualities, patience is not one of them :P

    I will wait some more, it worked yesterday so i think it should still work.

     

    I am not new to IT, i'm working in it for 20 years, so the DNS logs probably won't surprise me, i know how much junk and stuff gets in there because of advertisments and stuff. But this is my first time using this DNS service.

     

    Anyways , kudo's for your help to the community, it's nice to have persons like you. 

     

    Regards,

    Mike

    0
    Comment actions Permalink
  • Avatar
    y10k

    Hello, and thank you for these posts. I found them helpful, since I just encountered the same events and had the same questions Mr. Mike had.

    mrmatt

    0
    Comment actions Permalink
  • Avatar
    joshuarenae
    Is that diagnostic real? It looks like a phishing scam.
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    What?  What diagnostic?  Can you be more descriptive?

    0
    Comment actions Permalink
  • Avatar
    Eden

    Hi y10k, 

    There are usually 2 reasons why OpenDNS is not logging traffic - 1) your devices is not pointing to OpenDNS, and 2) your IP address is not current. Can you check your router/device settings to see if you are pointed to us? Also, you can check on your Dashboard to see if your IP address is up-to-date as most home users have dynamic IP addresses. If both of these are correct, then please send us a ticket with your diagnostic test results. Instructions on how to run the test can be found here: https://support.opendns.com/entries/21841580-Diagnostic-Tool-Link-and-Instructions

    0
    Comment actions Permalink
  • Avatar
    palmyrapark
    If I might suggest something to help prevent the frustration.... Can the screen which shown lo logs available have a message added to say there is a time lag between using a domain and seeing it in the logs Pat.
    0
    Comment actions Permalink
  • Avatar
    bragao

    ... and some clarification of the effects of the Purge in not showing new domain data after almost 12h of the Purge?!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    If you want to see stats, do not use the Purge function, because this schedules a purge job, running any time later when you least may expect it to run.

    Purge your stats only if you want to finally purge them, e.g. for privacy reasons.

    0
    Comment actions Permalink
  • Avatar
    bragao

    Hi ! thnx for the reply.

    But that was not what happened - the data was cleared immediatly and not "any time later when you least may expect it to run". The issue is that no new data is appearing and almost 24h have passed. If this is a "feature" it needs to be explicitly said besides the Purge button.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "the data was cleared immediatly and not "any time later when you least may expect it to run""

    Well, no matter, "immediately" includes "any time later", even if it was within a second only.  And no, the Purge function should not stop collecting stats.

    Ensure that you still have stats and logs enabled on the same page where this Purge option is, that you're using OpenDNS at all (http://welcome.opendns.com/), and that your IP address is correctly registered at https://dashboard.opendns.com/settings/
    If all three prerequisites are given, your DNS queries should be collected and logged.

    If you're still having problems, copy & paste the complete plain text output of the following command:

       nslookup -type=txt debug.opendns.com.

    0
    Comment actions Permalink

Please sign in to leave a comment.