Why can't I access mail.google.com?

Comments

5 comments

  • Avatar
    rotblitz

    Do you have one of the categories Webmail or Search Engines blocked?
    http://domain.opendns.com/mail.google.com

    As I understand, you added mail.google.com to your "never block" list, did you? Well if you visit this domain, this is not the only one needed. The foloowing is a minimum on domains needed and used to access Google Mail:

    mail.google.com
    accounts.google.com
    ssl.gstatic.com
    accounts.youtube.com

    And mail.google.com use HTTPS (SSL), therefore this certificate warning comes up, and this is because one of the needed domains are still blocked with your settings. Uncheck the related category, or add those domains to your "never block" list too. You may want to check your domain stats to find out what domains are still being blocked but needed to access mail.google.com.

  • Avatar
    reaperwrecking

    I'm also having trouble with Gmail with regard to forwarding my Gmail to another email account.  In Gmail, after you've added the address you want to forward the Gmail to, a confirmation box pops-up asking you to confirm you want gmail to be forwarded to the account you've just entered.  However, in place of the normal confirmation, the text shown below appears, and I'm blocked from confirming the Gmail fowarding--there is, in fact, no option to confirm I still want to forward my Gmail or to override the security warning message.  This was in Linux Mint 15, and I'm encountering this Gmail fowarding hiccup in both Firefox and Chrome.  Earlier today on the WinXP side of my machine with OpenDNS active, I was able to forward a different Gmail account without a hitch.  I don't have any OpenDNS security settings that would be causing this problem on either side of my machine.  Given that it worked on WinXP earlier today, this could be a LInux Mint quirk, but I'm not sure what the underlying explanation would be.  Anyway, here's the error message I received:

    ===BEGIN====

    This Connection is Untrusted

    You have asked Firefox to connect securely to isolated.mail.google.com, but we can't confirm that your connection is secure.

    Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.


    What Should I Do?

    If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

    isolated.mail.google.com uses an invalid security certificate. The certificate is only valid for the following names: *.opendns.com , opendns.com (Error code: ssl_error_bad_cert_domain) ====END====

    I'll try again when I reboot back into WinXP in the morning, but if you have any suggestions (other than adding the multiple Gmail domains to the "never block" list), I'd appreciate hearing them.  Thanks.

  • Avatar
    rotblitz

    Read my answer and your error message again.

    "isolated.mail.google.com uses an invalid security certificate. The certificate is only valid for the following names: *.opendns.com , opendns.com"

    You either have some domain name or an alias blocked, needed to access an SSL site of Google mail, or the domain of an SSL link referenced on a web page simply does not exist in DNS (OpenDNS NXDOMAIN redirection). The latter is not the case:

    nslookup isolated.mail.google.com.
    Server: dns1.local.prv
    Address: 10.164.118.84

    Non-authoritative answer:
    Name: b.googlemail.l.google.com
    Addresses:  2a00:1450:4001:c02::bd
                          173.194.70.189
    Aliases:   isolated.mail.google.com

    So look for the domain name or alias you have blocked, e.g. by raising this DNS lookup too or by checking your OpenDNS domain stats.  This could be the real domain name or a parent domain name of it or also the alias.

  • Avatar
    reaperwrecking

    @rotblitz: many thanks for the speedy and detailed reply.  I'll do as you suggest.  Thank you.

  • Avatar
    pngtrade

    Thanks you @rotblitz. I also had the same problem and got it fixed with your solution.

Please sign in to leave a comment.