OpenDNS works, then stops multiple times per day

Comments

34 comments

  • Avatar
    cervezafria

    What do you mean "when I click on update"... There is no manual update for OpenDNS service.

    If you are using OpenDNS Updater to update your external IP address, it should be configured to auto-update, thereby requiring no manual intervention.

  • Avatar
    cervezafria

    Dang it... hit enter too early... Continued...

    Did you enter the OpenDNS server IPs (208.67.222.222, 208.67.220.220) at your router, or local PC. The image suggests that you are not connected to OpenDNS.

  • Avatar
    khaehl

    OpenDNS Updater is configured to "Send Dnd-O-Matic updates" and "Run hidden".  It never required manual intervention before, so maybe this means nothing.

    The OpenDNS server IPs are configured in my router, not any local PC's.




    CropImage3_cr.jpg
    CropImage4_cr.jpg
  • Avatar
    khaehl

    One more thing I just found.  The IP Updates History looks a bit strange.  Is this a clue?




    OpenDNS IP Update History.txt
  • Avatar
    khaehl

    One more thing I just found.  The IP Updates History looks a bit strange.  Is this a clue?

  • Avatar
    cervezafria

    If that is your current log, it appears as though you haven't used OpenDNS since May 12. No major setting issues that I see.

    Just hang here until rotblitz shows up with his command lines. He will be able to dig a little deeper than I.

  • Avatar
    khaehl

    Thanks, I appreciate the help.  I do know I have used it several times the last few days as I've been trying to troubleshoot this problem.  It works fine, but later I'll check it and it will not be connected through OpenDNS.

  • Avatar
    khaehl

    Incidently, I just looked at the OpenDNS Updater window again, and it said I was not using OpenDNS.  When I clicked on Update now, it switched to "Yes".  The IP address has not changed.

  • Avatar
    rotblitz

    "OpenDNS Updater is configured to "Send Dnd-O-Matic updates""

    This is the problem. Disable this option. You do not really want to use DNS-O-Matic, do you?

    [Brian Hartvigsen - Fixed your link]

  • Avatar
    rotblitz

    I meant http://www.dnsomatic.com/

    This forum is lousy for propagating links. :(

  • Avatar
    khaehl

    Thanks rotblitz.  I had assumed that Dns-O-Matic was the setting to automatically update my IP address to OpenDNS.  I have now disabled that setting, and will monitor it through the day to see how it goes.

    Kevin

  • Avatar
    khaehl

    Dns-O-Matic is disabled, but I still keep losing contact with OpenDNS.  The first screenshot was taken just a couple of minutes ago.  This time I did NOT touch the Update now button, but now it say I am using OpenDNS.




    CropImage6_cr.jpg
    CropImage5_cr.jpg
  • Avatar
    rotblitz

    "Dns-O-Matic is disabled, but I still keep losing contact with OpenDNS."

    Contact with OpenDNS? Funny terminology! ;-) There is no such thing. You just send your DNS lookups to OpenDNS, because you adviced your router to do so..

    Ignore the Updater messages for now. What's the output of this command?

    nslookup  -type=txt  debug.opendns.com.

    If you get an error message, post also the complete output of "ipconfig /all".

  • Avatar
    khaehl

    Sorry about the poor terminology.  I'm not exactly an IT expert, but if you want to talk chemistry...

    Seriously, though, here are the details from the nslookup and ipconfig.  I tried the nslookup twice, once by pasting your text exactly, and one by typing it in (since it appeared that it had extra spaces in the pasted version).




    CropImage_cr7.jpg
  • Avatar
    rotblitz

    Ah yes, all clear now.

    You do not really use OpenDNS at all. The main reason is that you have IPv6 connectivity enabled, and your system seems to raise DNS lookups mainly over IPv6. Beside the fact that you don't have an OpenDNS IPv6 resolver address configured, but another one, the enhanced features beyond pure DNS are not supported yet by OpenDNS, like content filtering and stats and stuff.

    If you want to use OpenDNS to its full, you must disable IPv6 for this network connection and to work only via IPv4. Else you almost will be successfully circumventing OpenDNS...

    "I tried the nslookup twice, once by pasting your text exactly, and one by typing it in (since it appeared that it had extra spaces in the pasted version)."

    Don't worry, I did this for a better optical recognition only. ;-)  Spaces don't matter anyway in this context.  There's no difference in the output.

  • Avatar
    khaehl

    So if I understand correctly, I need to disable IPv6 on my router.  I'm glad you are helping me here, because I would never have figured that out.  So here is a screenshot of my Belkin router configuration page.  It's not clear to me which to select to disable IPv6.  Any suggestions?  Thanks.




    CropImage_cr8.jpg
  • Avatar
    cervezafria

    Different router, but mine has a checkbox to disable IPv6. YMMV

    Also you can disable IPv6 from your network adaptor. Right-click adaptor, then Properties/Networking...

    (see attachment)




    IPv6.png
  • Avatar
    rotblitz

    I did not really think about your router, but about your computer. I cannot comment on this router option without having studied the related manual.

    It is probably easier to disable IPv6 on the computer.

    Here for Windows 7: https://store.opendns.com/setup/operatingsystem/windows-7

    You follow the instructions until you hit this: http://shared.opendns.com/img/start_win7_5.gif

    See the two items IPv6 and IPv4? Simply uncheck only IPv6, confirm with "Ok" until all of this is closed again. IPv6 is gone then for this connection. I would expect that you can use OpenDNS with no problems from then on.

    If you ever need IPv6 again for whatever reason, simply enable it again the same way.

  • Avatar
    khaehl

    If I disable IPv6 on one PC (my main desktop), will the other PC's, iPhones, and Kindle's on my home network still have problems with OpenDNS due to the router using IPv6?

  • Avatar
    rotblitz

    This depends on at least two factors:

    • Does a particular device use IPv6 at all? If not, no problems. If IPv6 is used,.....
    • What is the priority on this system? If first IPv4 and then IPv6, then problems are unlikely.
      If IPv6 has priority over IPv4 (like on your computer), then OpenDNS' features and DNS service is rarely used, if at all.

    You may quick-check on any device by visiting http://welcome.opendns.com/ in a browser.

  • Avatar
    Brian Hartvigsen

    You could also try using 0:0:0:0:0:ffff:d043:dede and 0:0:0:0:0:ffff:d043:dcdc in the IPv6 DNS configuration on your router.  These are just the IPv4 addresses (208.67.222.222 & 208.67.220.220) mapped into IPv6.  This doesn't actually use IPv6 and not all IPv6 stacks support mapped addresses (see the Wikipedia article on IPv6 for more info), but it may help you out without having to disable IPv6 completely.

    This should work for most Linux devices, Windows post XP and OS X.  Basically anything that uses a unified IPv4 and IPv6 stack.  If it doesn't work, just disable IPv6 ;-)

    An example of this working:

    linode:~$ dig @::ffff:d043:dede myip.opendns.com +short
    74.207.x.x
  • Avatar
    khaehl

    I'm still working out how to disable IPv6.  Doing it on each device doesn't seem practical, especially since the kids' computer is an XP device.

    Any idea when OpenDNS will become compliant with IPv6?

    Thanks for the help.

  • Avatar
    rotblitz

    Aha, you like to introduce more complexity? You'll get it!

    Why do you think that OpenDNS is not compliant with IPv6? As far as I know, they are fully compliant.

    http://www.opendns.com/technology/ipv6/

    It's just that the features beyond pure DNS are not in effect for DNS lookups via/over IPv6. They are in effect regarding IPv6 (AAAA record) lookups over IPv4.

    That said, if you want to use the enhanced features beyond pure DNS (like content filtering or stats), you must ensure that you send your DNS lookups to their IPv4 resolver addresses only, not to their (or any other) IPv6 resolver addresses.

    This means, you can even continue to use IPv6 connectivity, you just must remove any IPv6 DNS resolver addresses from your configuration.

    Recommending to remove IPv6 as a whole was for simplicity reasons only. In reality it is sufficient to eliminate only DNS lookups via IPv6 (i.e. to IPv6 resolver addresses). You wanted it more complex, you get what you want...

  • Avatar
    rotblitz

    "Doing it on each device doesn't seem practical, especially since the kids' computer is an XP device."

    As I said above, if a device/system doesn't have IPv6, or if IPv4 has priority over IPv6, there will be no issues regarding content filtering and stats and stuff.  Windows XP does not have IPv6 activated by default, and if you activated it earlier, you can easily disable it:

    net stop tcpip6

    netsh interface ipv6 uninstall

    You can even (only) change the priority of IPv4 over IPv6 and much more (instead of removing it): http://support.microsoft.com/kb/929852

    (As you seem to want more options and complexity...)

  • Avatar
    cervezafria

    @Kevin... Did you try Brian's suggestion? Seems like that would alleviate your concern setting each device..

  • Avatar
    khaehl

    I was only just now able to get back at the computer to set it up as Brian suggested.  Thanks.  It is working for now, and I will keep an eye on it to see if I have the same problem as before.

  • Avatar
    khaehl

    Rotblitz, thanks for the details, although I must admit you are speaking over my head on this.  I did find out that this particular router can not disable IPv6, so I have tried Brian's suggestion to input the OpenDNS address for both IPv4 and IPv6 into the setup.

  • Avatar
    khaehl

    Here's the update.  I set up both IPv4 and IPv6 DNS as suggested above.  It worked for a while.  However, my router is still going around OpenDNS sometimes.  Working on the PC this morning, and the OpenDNS updater popped up saying I was no longer using OpenDNS.  To confirm it, I checked the internetbadguys.com site, and sure enough, I am not using it.  A few minutes later, and all is working again.

    Any other suggestions?

  • Avatar
    rotblitz

    While looking through your Router's Manual, do you also use the Norton content filtering options offered for the router? If so, this would interfere with OpenDNS. Better select "no filter". Below this option there's a link to configure your DNS settings. Follow it to check that there are only OpenDNS resolver addresses configured.

  • Avatar
    rotblitz

    @Brian
    "You could also try using 0:0:0:0:0:ffff:d043:dede and 0:0:0:0:0:ffff:d043:dcdc in the IPv6 DNS configuration on your router."

    You should really include this information in your IPv6 sandbox page as an alternative option for those using content filtering and/or stats and such. Although for experts this may be obvious, it's not for the normal user fighting with/against the upcoming IPv6 era.

Please sign in to leave a comment.