How to properly block "youporn.com"

Comments

23 comments

  • Avatar
    rotblitz

    Is this still the case? If yes, copy & paste the plain text output of the following commands here:

    nslookup -type=txt debug.opendns.com.
    nslookup youporn.com.
    nslookup www.youporn.com.

    If the site is blocked, then we cannot reproduce this, but are limited to assumptions.

    0
    Comment actions Permalink
  • Avatar
    prkrnt

    Here are the results:

    Server:  resolver2.opendns.com Address:  208.67.220.220

    debug.opendns.com text =

     "server 11.lax" debug.opendns.com text =

     "flags 20 0 2fe c007e6000201001" debug.opendns.com text =

     "id 15338279" debug.opendns.com text =

     "source 70.176.222.56:55466" Server:  resolver2.opendns.com Address:  208.67.220.220

    Name:    youporn.com Address:  67.215.65.131

    Server:  resolver2.opendns.com Address:  208.67.220.220

    Name:    www.youporn.com Address:  67.215.65.131

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    All fine, you're using the Los Angeles OpenDNS location, and your IP address 70.176.222.56 is registered with your OpenDNS network ID 15338279. You have youporn.com in your "always block" list, because OpenDNS returns the IP address of hit-block.opendns.com for it, not its real IP address. So, this site should be blocked by your settings.

    If you can access the site nevertheless, then you may have visited it before, and it's still in your browser cache. So flush this. Or your browser generally circumvents OpenDNS, because you have something like a "turbo mode" enabled or a proxy or VPN configured. What browser are you using?

    0
    Comment actions Permalink
  • Avatar
    anthony.clarke

    Confirmed, YouPorn.com is not blocked by OpenDNS. When I add it, OpenDNS comments that it is already blocked by one of more of my selected types of site to block, but it most certainly does not.

    Other porn site give the OpenDNS 'blocked' page, but "youporn.com" does not.

    On the command line:

    ipconfig /flushdns          *** (to make sure the dns cache is empty)

    nslookup youporn.com

    Gives the output:
    Server: UnKnown
    Address: 2620:0:ccc::2

    Non-authoritative answer:
    Name: youporn.com
    Address: 31.192.116.24

    This is *not* a browser cache or issue. OpenDNS, you have mucked this one up somewhere - I think one of your staff is in the take from YouPorn ;-)

    0
    Comment actions Permalink
  • Avatar
    anthony.clarke

    OpenDNS: Here is the output using the commands you asked to be run....

    C:\Windows\system32>nslookup -type=txt debug.opendns.com.
    Server: UnKnown
    Address: 2620:0:ccc::2

    Non-authoritative answer:
    debug.opendns.com text =

    "server 9.lon"
    debug.opendns.com text =

    "flags 20 0 0 0"
    debug.opendns.com text =

    "id 0"
    debug.opendns.com text =

    "source [2a01:348:6:872a:856d:d0d1:d6c8:806c]:49368"

    C:\Windows\system32>nslookup youporn.com.
    Server: UnKnown
    Address: 2620:0:ccc::2

    Non-authoritative answer:
    Name: youporn.com
    Address: 31.192.116.24

     

    Come on now - two years and you still fail to replicate the problem. I think this is a case of the "Won't do it's" rather than the "Can't do it's". Is YouPorn an OpenDNS sponsor?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "Server: UnKnown
    Address: 2620:0:ccc::2"

    "source [2a01:348:6:872a:856d:d0d1:d6c8:806c]:49368"

    You're using IPv6 connectivity, and content filtering is not supported with IPv6 yet, because you cannot register your IPv6 address with OpenDNS.  You'll want to disable IPv6 connectivity to use content filtering reliably.

    "Come on now - two years and you still fail to replicate the problem."  -  LOL, please don't be stupid.  (Btw, I'm just a user, so I never fail. ;-))
    Also, your problem is totally unrelated to the original problem reported.

    But, yeah, OpenDNS should now introduce to register also an IPv6 address beside the IPv4 address. It's the right time now.

    0
    Comment actions Permalink
  • Avatar
    anthony.clarke

    @robitz,

     

    0. I know IPv6 addresses are not yet filtered.

    1. The address returned is for IPV4 after - did you not read the trace.,

    2. Content filtering for IPV4 addresses using this configuration *works* perfectly for all other porn sites even when accessing the IPv6 OpenDNS addresses.

    3. Who is the stupid one now.

    Basically, OpenDNS *have* screwed this one up. Although they have youporn.com. in their lists, it is set to pass through the real IP. The ability or non-ability to add IPv6 addresses is irrelevant to this case.

    Apology please - or get of the boards.

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "The address returned is for IPV4 after - did you not read the trace."

    This "address returned" is absolutely irrelevant.

    I say it again, you need to disable IPv6 connectivity, because your DNS queries go out via IPv6, and it is not possible to register your IPv6 address 2a01:348:6:872a:856d:d0d1:d6c8:806c at https://dashboard.opendns.com/settings/ yet.  Therefore OpenDNS is not able to associate your DNS queries with your settings.  At the end, your settings simply don't take effect.

    "Who is the stupid one now."  -  Better no comment.

    0
    Comment actions Permalink
  • Avatar
    anthony.clarke

    @ rotblitz

    Once again you have failed to read all the information. Tell you what, I'll shout it.

    OPENDNS FILTER BLOCKS OTHER PORN SITES USING THIS CONFIGURATION. GET IT. DO YOU. IT BLOCKS PHIMSEX, IT BLOCKS FUCKBUDDY, IT BLOCKS EVERYTHING EXCEPY YOUPORN.

    Now more quietly. Time for you to actually *read* the posts rather than quoting the IPv6 mantra. OpenDNS DOES 'block' DNS requests for other porn sites. Your comment about it not picking up my external IPv6 address is now moot, AS ALL OTHER SITES ARE BLOCKED. 

    Further - on a PURE IPv4 LOOKUP (work network) it also fails to block YouPorn. 

    Do you get it now? Just shut up and leave the experts to figure it out.

    0
    Comment actions Permalink
  • Avatar
    anthony.clarke

    Elevated to OpenDNS - who do think this is worth looking into.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I don't have an explanation why it blocks certain sites.  You would have to post more diagnostics, so that I could see what's going on.  But this is not the question, but the question was why YouPorn is not being blocked.  But...

    Well, I told you twice what to do.  As you stay advice resistent, I give up...
    You simply could have done it to see that it really works then.

    "leave the experts to figure it out."

    I thought I'm one.  No matter, I'm confident that "experts" will tell you the same.

    0
    Comment actions Permalink
  • Avatar
    Chris Frost

    @anthony.clarke I have just responded to your ticket (#100921), please follow up with us via the support ticket. 

    0
    Comment actions Permalink
  • Avatar
    bethyboops

    I am a new user to OpenDNS.  I am also trying to block youporn.com without success.  Has there been any improvement in the blocking of this site?  Please advise.  Thank you!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    There is no improvement needed.  If you configured OpenDNS correctly, it is blocked.

    Do you use OpenDNS at all?  http://welcome.opendns.com/

    Is your IP address registered with OpenDNS?  https://dashboard.opendns.com/settings/

    0
    Comment actions Permalink
  • Avatar
    bethyboops

    Thank you for your response, rotblitz.  

    Actually, improvement still is needed as you can see from the fact that the previous poster had to have his ticket elevated to an actual OpenDNS representative.  

    I'm not sure exactly whey it works for you; however, for some users, myself and the OP included, it does not block that particular address.  Since it is blocking every other site I test with, I can tell that I have the software configured properly. It blocks all of the other sites that are associated with youporn, but not youporn itself.

    Yes, I use OpenDNS - I have a paid VIP account.

    Yes, my IP address is registered.

    In any event, I was able to specifically enter the domain name in the blacklist so that it is effectively blocked. I am mostly concerned that there are other domains with similar issues. I am hoping that OpenDNS will address the matter.  

    Thanks again for your response!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I'm not sure exactly whey it works for you"

    Because I configured everything correctly.

    "however, for some users, myself and the OP included, it does not block that particular address."

    Apparently not so for the rest of some 50 millions of users...
    So, the question is, what are you doing wrong?

    "I can tell that I have the software configured properly."

    This may be the reason.  You can't configure any software in this context.  OpenDNS is not software, but a configurable service.  It may be this unspecified software, unrelated to OpenDNS, causing you troubles?

    "Yes, I use OpenDNS - I have a paid VIP account."

    Just paying doesn't prove that you're using OpenDNS.

    To possibly see why it doesn't work for you, you can post the complete plain text output of the diagnostic commands from my first response above here.

    0
    Comment actions Permalink
  • Avatar
    chrmou

    Just signed up. Blocking with "moderate" works. But: Not for youporn.com. Neither sites like porntube.com

    Has this somethign to do with the location? I live in the Netherlands.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    No, it has to do with the weather, the season, your body temperature and the speed capabilities of your bike.  ;-)  LOL

    As I said above already, post the complete plain text outputs of the following diagnostic commands here, so that I see what's up:
    (Trailing dots are part of the commands!)

       nslookup -type=txt debug.opendns.com.

       nslookup youporn.com.

       nslookup porntube.com.

       nslookup www.exampleadultsite.com.

    0
    Comment actions Permalink
  • Avatar
    chrmou

    nslookup -type=txt debug.opendns.com
    Server: 127.0.1.1
    Address: 127.0.1.1#53

    Non-authoritative answer:
    debug.opendns.com text = "server 1.ams"
    debug.opendns.com text = "flags 20 0 50 19500007E00400014C3"
    debug.opendns.com text = "originid 40989527"
    debug.opendns.com text = "actype 2"
    debug.opendns.com text = "bundle 8313543"
    debug.opendns.com text = "source 82.169.6.106:2779"

    Authoritative answers can be found from:

     

    ---------

    Server: 127.0.1.1
    Address: 127.0.1.1#53

    Name: youporn.com
    Address: 31.192.116.24

    ----------

     

    Server: 127.0.1.1
    Address: 127.0.1.1#53

    Non-authoritative answer:
    Name: porntube.com
    Address: 146.112.61.106

    nslookup www.exampleadultsite.com

    Server: 127.0.1.1
    Address: 127.0.1.1#53

    Non-authoritative answer:
    Name: www.exampleadultsite.com
    Address: 146.112.61.106

     

    -----

    Dear Rotblitz, you have a really funny style. Pay attention Basil Fawlty! LOL

    Seriously: I read the whole forum.  

    Result: Only exampleadultsite is succesfully blocked. 

     

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You're using the OpenDNS data center in Amsterdam, and your IP address 82.169.6.106 is registered with OpenDNS network ID 40989527 which is probably yours.  The domains porntube.com and www.exampleadultsite.com are being blocked by category (146.112.61.106 - hit-adult.opendns.com), but youporn.com is indeed not blocked, but their real IP address 31.192.116.24 is returned.  It should be blocked because of its categorization: https://domain.opendns.com/youporn.com

    I understand that you think that porntube is not being blocked for you.  This must be something outside OpenDNS and is inconsistent with what is returned by OpenDNS.  It seems your browser or anything else disregards your settings and finds a way to circumvent the settings for this zone.  Or you simply visited the site before, but missed to flush both, your local resolver cache and your browser cache, after the settings change.
    https://support.opendns.com/entries/26336865-Clearing-the-DNS-Cache-on-Computers-and-Web-Browsers

    Regarding youporn.com, as this is nothing we users can help with, open a support ticket with a link to this thread.  Only OpenDNS staff can check this.

    If OpenDNS provide a solution for you, it would be great to come back to post it here, for the benefit of others who may have the same issue.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Just seeing, unlike for the other outputs which are "Non-authoritative", the result for youporn.com is authoritative, an indication that your DNS server at 127.0.1.1. handles this differently from the others for whatever reason, maybe because you have root hints configured.  Only such DNS lookups return authoritative results, i.e. obtained directly from the nameservers of youporn.com instead of a recursive DNS service like OpenDNS.

    nslookup -type=any youporn.com.
    Server:  dns1.local.prv
    Address:  10.165.161.13

    Non-authoritative answer:
    youporn.com     internet address = 31.192.116.24
    youporn.com     nameserver = sdns3.ultradns.org
    youporn.com     nameserver = sdns3.ultradns.net
    youporn.com     nameserver = ns1.p44.dynect.net
    youporn.com     nameserver = ns4.p44.dynect.net
    youporn.com     nameserver = sdns3.ultradns.com
    youporn.com     nameserver = ns3.p44.dynect.net
    youporn.com     nameserver = sdns3.ultradns.biz
    youporn.com     nameserver = ns2.p44.dynect.net
    youporn.com     MX preference = 20, mail exchanger = smtp-scan01.mx.reflected.net
    youporn.com     text =
            "v=spf1 include:_ipv4spf.youporn.com ptr:closedrelay.com ptr:emailsrvr.com mx a:smtp.youporn.com mx a:smtp2.youporn.com mx ptr:reflected.net ip4:66.254.119.174 ip4:66.254.113.78 -all"
    ns1.p44.dynect.net      internet address = 208.78.70.44
    ns2.p44.dynect.net      internet address = 204.13.250.44
    ns3.p44.dynect.net      internet address = 208.78.71.44
    ns4.p44.dynect.net      internet address = 204.13.251.44
    sdns3.ultradns.biz      internet address = 156.154.142.3
    sdns3.ultradns.biz      AAAA IPv6 address = 2610:a1:1003::3
    sdns3.ultradns.com      internet address = 156.154.140.3
    smtp-scan01.mx.reflected.net    internet address = 66.254.98.230
    smtp-scan01.mx.reflected.net    internet address = 216.18.179.54
    smtp-scan01.mx.reflected.net    internet address = 66.254.109.210

    0
    Comment actions Permalink
  • Avatar
    mandelicacid

    Hope this tip will help you, or anyone reading this. I also had this problem, youporn and internetbadguys.com kept on showing up.

    I was using a firewall with DNS caching. Turned the DNS caching off and OpenDNS started working.

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Thanks for the hint.  That may well be the reason for not working.

    0
    Comment actions Permalink

Please sign in to leave a comment.