How can I block League of Legends?

Comments

13 comments

  • Avatar
    rotblitz

    To find out what you did wrong, what are these "several ways" you tried to block this?

    • Did you try with blocking the Game category?
    • Did you add leagueoflegends.com to your "always block" list?

    If one of those and it did not help, you have a general configuration error. Then post the complete output of the following command here:

    nslookup -type=txt debug.opendns.com.

  • Avatar
    tanquynh

    On my "always block" list I had:

    na.leagueoflegends.com

    leagueoflegends.com

    I also check the box "proxy/Anonymizer" under the Custom Categories, to make sure he can't sneak out other ways.

    Didn't work.  New school new starts today.  Please help. Thanks

  • Avatar
    rotblitz

    "On my "always block" list I had:

      na.leagueoflegends.com

      leagueoflegends.com"

    The first (na) entry is useless and redundant, because the second already covers itself and any subdomains.

    Well, post the complete plain text outputs of the following commands here, from within the network you want to have it blocked, and with all your OpenDNS stuff enabled, and ideally from the computer where this game is played on, but can be from another computer too:

    nslookup -type=txt debug.opendns.com.
    nslookup leagueoflegends.com.
    nslookup na.leagueoflegends.com.

    Pretty clear that you should uninstall the game from the computer too, in addition to blocking it with OpenDNS.

  • Avatar
    tanquynh

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\nguyen>nslookup leagueoflegends.com
    Server:  qwestmodem.domain.actdsltmp
    Address:  192.168.0.1

    Non-authoritative answer:
    Name:    leagueoflegends.com
    Address:  50.19.235.141

    This is the output. Thanks

  • Avatar
    rotblitz

    This was only one of three outputs. Where are the other two?

  • Avatar
    tanquynh

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\nguyen>nslookup na.leagueoflegends.com
    Server:  qwestmodem.domain.actdsltmp
    Address:  192.168.0.1

    Non-authoritative answer:
    Name:    na.leagueoflegends.com
    Address:  67.215.65.131


    C:\Users\nguyen>nslookup -type=txt debug.opendns.com
    Server:  qwestmodem.domain.actdsltmp
    Address:  192.168.0.1

    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    *** Request to qwestmodem.domain.actdsltmp timed-out

    C:\Users\nguyen>

  • Avatar
    rotblitz

    This 67.215.65.131 indicates that you blacklisted na.leagueoflegends.com individually, and this one is blocked for you. Fine.

    This 50.19.235.141 indicates that leagueoflegends.com is not blocked by your settings. This is their real IP address in your area.

    "*** Request to qwestmodem.domain.actdsltmp timed-out"

    Something is wrong. Try the following instead and do not forget the trailing dot this time!

    nslookup -type=txt -timeout=12 debug.opendns.com.

  • Avatar
    tanquynh

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\nguyen>nslookup -type=txt -timeout=12 debug.opendns.com.
    Server:  qwestmodem.domain.actdsltmp
    Address:  192.168.0.1

    DNS request timed out.
        timeout was 12 seconds.
    *** Request to qwestmodem.domain.actdsltmp timed-out

    C:\Users\nguyen>

    I appreciate your time and efforts

  • Avatar
    rotblitz

    You get a timeout even after 12 seconds? Your DNS server and forwarder at 192.168.0.1 (qwestmodem) is lousy and not reliable. It doesn't do its job. It seems it cannot handle certain DNS lookups. Get it repaired, or get rid of it. An upgrade to the latest firmware may help too.

    For the time being, post the output of the following (circumventing the router's DNS forwarding function):

    nslookup  -type=txt  debug.opendns.com.  208.67.220.220

  • Avatar
    tanquynh

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\nguyen>nslookup -tyoe=txt debug.opendns.com. 208.67.220.220
    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    debug.opendns.com       text =

            "server 7.chi"
    debug.opendns.com       text =

            "flags 20 0 2fe 80000000000"
    debug.opendns.com       text =

            "id 15330825"
    debug.opendns.com       text =

            "source 63.225.150.118:57402"

    Thanks

  • Avatar
    rotblitz

    Great, if you use OpenDNS directly, it looks fine. So it's really your router where the DNS server/forwarder function is lousy. You do yourself a favour if you configure the OpenDNS resolver addresses on the computers, or use another router with better behaviour and performance.

    Just FYI, the ouput tells me that you use the OpenDNS Chicago location, and that your IP address 63.225.150.118 is registered with OpenDNS network ID 15330825 which is probably yours.

    Regarding blocking of the domain in question, you may post the output of

    nslookup leagueoflegends.com. 208.67.220.220

  • Avatar
    tanquynh

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\nguyen>nslookup leagueoflegends.com. 208.67.220.220
    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    Name:    leagueoflegends.com
    Address:  67.215.65.131


    C:\Users\nguyen>

  • Avatar
    rotblitz

    Yes, this 67.215.65.131 indicates that leagueoflegends.com is in your "always block" list, so it would be blocked if you configured the OpenDNS resolver addresses on the computer. After all, the culprit seems to be the router.

Post is closed for comments.