Using OpenDNS stops samba access to fileserver from Linux computers.


1 comment

  • Avatar

    Because OpenDNS by default returns no NXDOMAIN results but always a valid result, also for internal name resolution. You may have configured the OpenDNS resolver addresses on the LAN side, so all your DNS queries go to OpenDNS, including the internal ones.

    You would want to configure the OpenDNS resolver addresses on the WAN side of the router only, or as forwarders in your DNS server only.

    If you cannot do this, you'll want to add your internal names as VPN exceptions under Advanced Settings of your dashboard.

    Comment actions Permalink

Please sign in to leave a comment.