DNS properly configured to router and devices but fails the test.

Comments

20 comments

  • Avatar
    rotblitz

    Copy & paste the complete plain text output of the following commands:

    nslookup -type=txt debug.opendns.com.
    nslookup -type=txt which.opendns.com. 208.67.220.220
    ipconfig /all

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    C:\Users\Vi3tfool>nslookup -type=txt debug.opendns.com.
    Server: cdns01.comcast.net
    Address: 2001:558:feed::1

    *** cdns01.comcast.net can't find debug.opendns.com.: Non-existent domain

    C:\Users\Vi3tfool>nslookup -type=txt which.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    which.opendns.com text =

    "2.pao"

    C:\Users\Vi3tfool>ipconfig/all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Vi3tfool-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Broadcast
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : hsd1.ca.comcast.net.

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : hsd1.ca.comcast.net.
    Description . . . . . . . . . . . : Intel(R) WiFi Link 1000 BGN
    Physical Address. . . . . . . . . : 00-1E-64-76-2D-14
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2601:c:8280:381:2c64:902e:8643:79a4(Prefe
    rred)
    Temporary IPv6 Address. . . . . . : 2601:c:8280:381:bd79:ea29:d099:d6c7(Prefe
    rred)
    Link-local IPv6 Address . . . . . : fe80::2c64:902e:8643:79a4%14(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.103(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Monday, August 19, 2013 9:07:58 PM
    Lease Expires . . . . . . . . . . : Tuesday, August 20, 2013 9:27:39 PM
    Default Gateway . . . . . . . . . : fe80::cad3:a3ff:fe5b:d734%14
    192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DHCPv6 IAID . . . . . . . . . . . : 251666020
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-98-E8-05-00-26-9E-89-64-A5

    DNS Servers . . . . . . . . . . . : 2001:558:feed::1
    2001:558:feed::2
    192.168.0.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:24d3:38bf:9d1f:8a85(Pref
    erred)
    Link-local IPv6 Address . . . . . : fe80::24d3:38bf:9d1f:8a85%18(Preferred)
    Default Gateway . . . . . . . . . :
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter 6TO4 Adapter:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft 6to4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Reusable ISATAP Interface {CA364309-C771-41E9-B91F-746B12CD4B42}:


    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.hsd1.ca.comcast.net.:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : hsd1.ca.comcast.net.
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    All clear. You need to deactivate IPv6 in the properties of your "Wireless LAN adapter Wireless Network Connection", because your DNS lookups are raised over IPv6, and you have non-OpenDNS IPv6 DNS resolver addresses configured.

    If you don't use content filtering, it is sufficient to configure two or more of the following OpenDNS IPv6 DNS resolver addresses for this same connection:

    ::ffff:d043:dede
    ::ffff:d043:dcdc
    ::ffff:d043:dedc
    ::ffff:d043:dcde

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    I deactivated ipv6 and went through to standard procedure of flushing and clearing the dnscache and power cycle my router,restarted my pc but still dont have opendns working. I dont use content filtering on my opendns account nor do I use it on my router but I am confused on where to assign those ipv6 dns to. Using opendns requires the cancellation of ipv6?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "but still dont have opendns working."

    Then I need to see the complete output of this command again:

    nslookup -type=txt debug.opendns.com.

    "I am confused on where to assign those ipv6 dns to."

    Wherever you want and can, on the computer or on the router. On the computer it's under the IPv6 properties (which you disabled), from Windows Vista and higher. Under XP you must do it via command prompt with the netsh or ipv6 command.

    "Using opendns requires the cancellation of ipv6?"

    No, not OpenDNS, but content filtering. You currently cannot register an IPv6 address with your OpenDNS network, just an IPv4 address, and therefore OpenDNS would not be able to associate your DNS lookups raised over IPv6 with you and your settings.

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    C:\Users\Vi3tfool>nslookup -type=txt debug.opendns.com.

    Server: dlinkrouter.hsd1.ca.comcast.net
    Address: 192.168.0.1

    *** dlinkrouter.hsd1.ca.comcast.net can't find debug.opendns.com.: Non-existent
    domain

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    I entered those ipv6 dns to my dlink router  ipv6 dns settings but I keep getting a popup saying that the primary dns is a invalid address and wont let me save the settings. I should enter these ipv6 dns into my computer even though I deactivated the ipv6 on my computers?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "*** dlinkrouter.hsd1.ca.comcast.net can't find debug.opendns.com.: Non-existent domain"

    Your router does not forward your DNS lookups to OpenDNS, for whatever reason. Can you post a screen shot of the router page where you configured the OpenDNS server addresses?

    "I entered those ipv6 dns to my dlink router  ipv6 dns settings but I keep getting a popup saying that the primary dns is a invalid address and wont let me save the settings."

    Weird, if this is on another router page, post a screen shot of this as well.

    "I should enter these ipv6 dns into my computer even though I deactivated the ipv6 on my computers?"

    No, not in this case.

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    Here is the screen for the OpenDNS server addresses and the ipv6 dns settings screen shot as well.

     




    Untitled.png
    Untitled1.png
    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    I am greatly confuse about getting it to work but of course your help has been greatly appreciated rotblitz. I actually thought just setting the opendns manually on the computer would work but I guess it isnt that easy. Hopefully we can sort this out. Keep up the help rotblitz, glad to have someone who knows their stuff.

    0
    Comment actions Permalink
  • Avatar
    maintenance

    Your router WAN IPv6 yet has "obtain IPv6 addresses automatically" checked. If changing this does not solve the problem, you may power off the router for a minute or so, then power back on. You may also wish to check that computers have not been assigned any IPv4 DNS addresses other than the LAN IP of the router. You may also wish to remove these

    Connection-specific DNS Suffix . : hsd1.ca.comcast.net.

    DNS Suffix Search List. . . . . . : hsd1.ca.comcast.net.

    and replace with a single dot.

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    On the WAN screen: Try with enabling Advanced DNS Service to see if this becomes better.

    On the IPv6 screen:
    Check "Use the following DNS address".
    Enter these IPv6 DNS server addresses:
    ::ffff:d043:dede
    ::ffff:d043:dcdc

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    When I enable advance dns service it sets my dns to automatically get dns from ip seen in the screen. The ipv6 screen gives me a colon error.




    Untitled.png
    Untitled1.png
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Then disable the Advanced DNS Service on the WAN page again.

    Then try with this IPv6 presentation: 0000:0000:0000:0000:0000:ffff:d043:dede and 0000:0000:0000:0000:0000:ffff:d043:dcdc

    Btw, I'm nearly running out of ideas. Your best bet is to open a support ticket now, with a URL to this thread.

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    " You may also wish to remove these

    Connection-specific DNS Suffix . : hsd1.ca.comcast.net.

    DNS Suffix Search List. . . . . . : hsd1.ca.comcast.net.

    and replace with a single dot. "   

     

    How do I change those settings at?

    0
    Comment actions Permalink
  • Avatar
    frozynwarlord

    " Then disable the Advanced DNS Service on the WAN page again.

    Then try with this IPv6 presentation: 0000:0000:0000:0000:0000:ffff:d043:dede and 0000:0000:0000:0000:0000:ffff:d043:dcdc "

     

    It works.. I finally got the checkmark and all 3 url test have given me the pass. The new change on my ipv6 dns made all the difference. Thanks for all the help rotblitz, Would be nice if my isp support service was as helpful as you.

    Now hopefully It always works this way but if something wrong does happen I know where to go to find the best help.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Wow, glad to hear.  You're welcome!  Enjoy OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    luvhotchiles

    I have the exact same problem, but I do not have an IPV6 tab on my DIR-655 and the software is up to date. 

    0
    Comment actions Permalink
  • Avatar
    luvhotchiles

    I stand corrected.... I rebooted the computer and it cleared the issue, and I am now on open DNS!  Yippie!  I am pleased.  Now, lets see the benefits.... Peace.

    0
    Comment actions Permalink
  • Avatar
    mvdl

    Thanks for your help also rotblitz. I hadn't noticed that comcast had switched over to IPV6 Anycast DNS servers and was pulling my hair out trying to figure out why it was not using my OpenDNS addresses. Just a note, after the router IPV6 DNS change you have to reboot the computer to update.

    Thanks again.

    0
    Comment actions Permalink

Post is closed for comments.