OpenDNS not working

Comments

8 comments

  • Avatar
    rotblitz

    Did you flush your local resolver cache and your browser cache?  This is mandatory after settings changes to take effect immediately.
    http://www.opendns.com/support/category/10

    If you're still having problems, post the complete plain text output of the following commands:

    nslookup -type=txt debug.opendns.com.

    nslookup www.internetbadguys.com.

  • Avatar
    krismerful

    Yep, I've flushed both already. 

     

    Server: app.singnet.com.sg
    Address: 192.168.1.254

    Non-authoritative answer:
    debug.opendns.com text =

    "server 3.sin"
    debug.opendns.com text =

    "flags 20 0 2f6 700000000000"
    debug.opendns.com text =

    "id 18470559"
    debug.opendns.com text =

    "source 202.166.41.106:54251"

     

    And

     

    Server: app.singnet.com.sg

    Address: 192.168.1.254

    Non-authoritative answer:
    Name: www.internetbadguys.com.singnet.com.sg
    Address: 67.215.65.132

     

    Thanks!

  • Avatar
    rotblitz

    You forgot to enter the trailing dot, therefore the second lookup is for nothing, because your DNS suffix was appended. :(
    There is no domain www.internetbadguys.com.singnet.com.sg...

    According to the TXT query for debug.opendns.com, you're using the OpenDNS Singapore location and your IP address 202.166.41.106 is registered with OpenDNS network ID 18470559.  In case this is your OpenDNS network, everything should work.
    https://dashboard.opendns.com/settings/

    Still not blocking websites you expect do be blocked and not collecting stats?

    Ensure that you have enabled the related categories for blocking, or that the domain names are on your "always block" list to the broadest level, e.g. not www.example.com, but example.com.  Regarding your stats, see if you have stats and logs enabled at your dashboard.  Stats are not real-time but take 3-24 hours to appear.

    If you still have problems, post examples of the domains you're having problems with.

  • Avatar
    krismerful

    Sorry! Here it is,

    Server:        192.168.1.254
    Address:    192.168.1.254#53

    Non-authoritative answer:
    Name:    www.internetbadguys.com
    Address: 67.215.92.210

     

    Alright, thanks!

  • Avatar
    rotblitz

    This 67.215.92.210 is the real address, not the one for blocking, so you most likely didn't use OpenDNS at this time, or you have phish protection disabled at your dashboard.  If not, it seems you don't use OpenDNS reliably, but randomly only.  You may have other non-OpenDNS resolver addresses configured somewhere.

    Now post the complete output of the following command:

    ipconfig /all

  • Avatar
    krismerful

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Britz
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : singnet.com.sg

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : singnet.com.sg
    Description . . . . . . . . . . . : D-Link DWA-125 Wireless N 150 USB Adapter
    (rev.A3)
    Physical Address. . . . . . . . . : 90-94-E4-F7-06-6D
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::74d2:c185:3a94:8529%12(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.82(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Monday, 18 November, 2013 1:59:49 PM
    Lease Expires . . . . . . . . . . : Monday, 18 November, 2013 5:59:48 PM
    Default Gateway . . . . . . . . . : 192.168.1.254
    DHCP Server . . . . . . . . . . . : 192.168.1.254
    DHCPv6 IAID . . . . . . . . . . . : 328242404
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-76-BC-A5-50-E5-49-58-31-F1

    DNS Servers . . . . . . . . . . . : 192.168.1.254
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : singnet.com.sg
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : 50-E5-49-58-31-F1
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.singnet.com.sg:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : singnet.com.sg
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6ab8:c35:19bd:d5c2:7566(Prefe
    rred)
    Link-local IPv6 Address . . . . . : fe80::c35:19bd:d5c2:7566%13(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

     

  • Avatar
    rotblitz

    That's fine, no extra DNS resolver addresses.  I ran out of ideas.  Best is to open a support ticket.

    Run these diagnostics first:
    Windows: http://www.opendns.com/download/windows/diagnostic
    Mac OS: http://www.opendns.com/download/mac/diagnostic

    Then open a support ticket at https://dashboard.opendns.com/support/ describing your problem, and also with the URL to the diagnostic result and the URL to this thread.

  • Avatar
    krismerful

    That's fine. Thanks so much for your help! You've been really friendly and helpful! 

    Wish there was a way to add rep or something to thank you! :) 

Please sign in to leave a comment.