Can't get OpenDNS to work.



  • Avatar

    The IP address is what OpenDNS sees from you with your DNS queries.  So this is the one which must be registered with your dashboard network.  As this IP address is registered with an OpenDNS network (ID 18802131) which is most likely not yours, you're using another user's settings who has registered this IP address with his network.

    You'll want to open a support ticket then.

    Also, fill all three Status DNS entries in the router with OpenDNS addresses out of,,,

  • Avatar


    I appreciate the response. I already have the router filled with three DNS entries. I will go ahead and open a support ticket. How is it that somebody might have already registered my IP address?

    Does the proxy from Comcast have anything to do with it. I have found out more information and complains from customer how they are hijacking peoples browser.

    here is the article dated 3-31-2013

    So, it seems that Comcast is trying to route all web traffic (port 80) through a transparent cachine Squid proxy.  Trouble is... They seem to routing a few states worth of traffic... through a single cluster of servers.  Also, it seems that some aspects of the proxy are that transparent either.  Websites aren't seeing my IP, but one of the squid proxy's front end IP's.  So, I'm practically NATed for all practical purposes web wise.  Thanks, glad to known I'm paying for that disservice.

  was godawful.

    IP sees:  (Front-end IP for proxy)  ( reports that too, and reveals the proxy's IP


    Proxy server's full ID:  1.1 (squid/3.1.16-20111129-r10400)


    Ping:  332ms

    Download Speed: 0.60 Mbps

    Upload Speed: 0.44 Mbps


    What thel?!  The point of a squid proxy is to create a local cache of commonly access web files... TO INCREASE SPEED and RESPONSE.  I've setup up one or two of them.  It pretty easy, but Comcast has figured a way to fail at this.


    First 300GB hard caps, now this?!   Any traffic coming from this proxy server better NOT be included in my monthly bandwidth total.  I'm paying to access the internet, not to access Comcast's embarassingly laughable WAN.


    For comparison, I fired up a TOR proxy client on my router and routed connections through it.  From an outlet point in France, I accessed the Manchester, England site.


    Ping: 193ms

    Download Speed: 1.75 Mbps

    Upload Speed: 1.20 Mbps


    I'm routing my web traffic through a complex proxy network system across the Atlantic Ocean to a place in France connecting to England... And I get a faster more responsive connection than whatever Comcast has cooked up!


    I'm paying WAY TOO MUCH for a connection to the INTERNET, not Comcast's horribly done proxy servers.  It's bad enough I couldn't opt out for the 300GB or "we charge you way too much for no reason other than to make more money and have an excuse not to upgrade our network" cap system...  But now, I have to suffer having my web traffic shoved through the same point 2+ million people are going through?!


    Oh, I await the day Google Fiber comes to town.  I will gleefully tear out every coax RG-6 line of this house and my family member's houses, crafting into an effigy of your company logo, and burn it all....  Just to cleanse the evil.


    Until then...  I know you monopolistical prats have no good motivation to do anything other than systematically screw over your customers for a higher profit margin, but is setting up a crappy squid proxy really going to save you on your bandwidth costs incomparison to the customer ire it'll breed and the customer service calls it will cause?  I know you charge the customer is for bandwidth is completley out of sensible proportion to your costs, but you are going to charge the ridiculous same while slowing down the connections AND skirting on the bandwidth use on your end?  Unbelievable.


    Just when you think a company can't get any lower.  Comcast, the EA of the ISP world.

  • Avatar

    Here are tools to check if you're behind an ISP's proxy or caching server:

    In this case the IP address the public internet sees from you may be shared with other users of the same ISP.  Also, source IP addresses for different protocols (e.g. HTTP and DNS) may be different.

    "How is it that somebody might have already registered my IP address?"

    Because this may not be your IP address, but a shared one.  Any user sharing it could have registered it with OpenDNS.  The first wins.  You shouldn't register such a shared IP address either.

    "Does the proxy from Comcast have anything to do with it."  -  So, yes.

  • Avatar



    I ran the proxy-test the results are as follow.


    Proxy Test

    This request appears to have come via a proxy.

    The proxy host is which has ip address

    The proxy server has announced itself as 1.1 (squid/3.1.16-20111129-r10400)

    The proxy informs us that the client host ip address was


    I guess my last question is their any hope for me?

  • Avatar

    And can I do anything about the IP address?

  • Avatar

    Whatever, you should raise a support ticket to get the address (range) banned from being able to be registered with OpenDNS, so that you are no longer bound to someone else's settings.

    Beside this, you cannot use the enhanced features of OpenDNS Home (configurable content filtering, stats, etc.) with this kind of internet connection.  You can still use the OpenDNS FamilyShield addresses for pre-defined static content filtering or the normal OpenDNS resolver addresses for pure DNS plus phishing and botnet protection.  Another alternative would be to use DNSCrypt on particular devices ( which may allow you to also use the enhanced features.

    You also can try to opt out of the ISP proxy, or to change the ISP.

  • Avatar

    I was having the same issue and and tried everything suggested on the discussion boards. Finally I looked the time zone set on my router and found it was set for a default of Pacific w/ daylight savings time. So set it for Phoenix (the time zone I'm in). Then I thought I should check that my time on the computer was syncing with the internet time servers and found it was off by 11 seconds. Told it to update the clock and low and behold OPENDNS app no longer says my IP is a mismatch. Hope someone finds this helpful and saves you hours of heartache and head scratching, that has been my experience. 

Please sign in to leave a comment.