Can't Get OpenDNS To Work - IP Mismatch Issue

Comments

37 comments

  • Avatar
    rotblitz

    It seems your ISP put you behind a proxy.  What does http://welcome.opendns.com/ say?

    See also https://support.opendns.com/entries/23644725-Can-t-get-OpenDNS-to-work-

  • Avatar
    rotblitz

    "IP Mismatch Issue"

    Your HTTP IP address:  http://myip.dnsomatic.com/
    Your DNS IP address :   nslookup myip.opendns.com.

  • Avatar
    bababooyah

    It seems your ISP put you behind a proxy.  What does http://welcome.opendns.com/ say?

    It says "Oops, you don't seem to be on OpenDNS, let's see if we can fix that".

    "IP Mismatch Issue"

    The two addresses do not match.

  • Avatar
    bababooyah

    Correction - when I run the DNS IP address command on my main computer which is wired to my network, I get a different IP address than my HTTP IP address.

    When I run the DNS IP address command on a computer that is connected via wireless, I get a timeout error, can't even get an address back.

    Maybe OpenDNS is just not cut out for me, or vice versa :)

    Thanks for your continued support.

  • Avatar
    rotblitz

    "I get a timeout error, can't even get an address back."

    Something is misconfigured on this computer.  Start with trying:

    nslookup -timeout=12 myip.opendns.com.

    You may want to copy & paste the complete plain text output of this here.

  • Avatar
    bababooyah

    Sorry, I'm not comforable pasting specific IP information about my network in an open forum.  Are you an OpenDNS employee?  Is there a secure email address or trouble ticket system that we can work through here? 

    Should I be taking these actions on the wired computer, the wireless computer, or should it even matter?

    Here's what I got:

    Microsoft Windows [Version 6.0.6002] Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\XXX>cd\

    C:\>nslookup -timeout=12 myip.opendns.com. DNS request timed out.     timeout was 12 seconds. Server:  UnKnown Address:  xxxx:xxxx:xx:ffxx:xxx:d::

    DNS request timed out.     timeout was 12 seconds. DNS request timed out.     timeout was 12 seconds. *** Request to UnKnown timed-out

  • Avatar
    rotblitz

    "Are you an OpenDNS employee?"   -   No, just a user like you.  But what you show is already sufficient.

    "Should I be taking these actions on the wired computer, the wireless computer, or should it even matter?"

    On the computer where you got this timeout when executing nslookup.

    "Here's what I got:"

    You don't have valid DNS resolver addresses configured or obtained on this device, or you don't have internet connectivity.  It even cannot show the DNS server address being used.

    Also, it seems you have IPv6 connectivity enabled.  You should disable this if you intend to use OpenDNS content filtering and stats and such.  These features do not work with IPv6 yet, just with IPv4, because you cannot register an IPv6 address with your OpenDNS network.

  • Avatar
    bababooyah
    I truly appreciate your input and assistance on this @rotblitz but I have reached a point where it's just getting too much and the potential downfalls of playing with settings that I am not entirely comfortable with outweigh any potential benefits that I might get from getting OpenDNS up and running. All of my systems are working perfectly right now, I am typing this from a remote wireless PC that clearly has full Internet access and I want to keep it that way. My hopes were that OpenDNS would simply be turned on and work with minimal changes in router or other settings, that is not the case. It is quite possible that I have a problem, or many problems, but they aren't apparent from my day to day network behavior, and no one has hacked in or created havoc otherwise in the 10+ years that I've been up and running here. I have many other safeguards implemented and will continue to do so, but for the foreseeable future, OpenDNS is just not going to work for me. Thanks anyway and best of luck to you.
  • Avatar
    Dominic Bannister

    Hi,

    It looks like you have already opened multiple support tickets regarding this issue and one of my colleagues is handling the request. In general, the mismatch maybe due to the way your ISP handles your DNS traffic and HTTP traffic. We will continue to investigate the issue in your support ticket. 

     

  • Avatar
    rustyiron

    Problem solved!   

    I just discovered that my desktop computer, which is hooked up to Time Warner Cable, was using their own DNS, despite my computer and routers being configured to use OpenDNS.  Time Warner is hijacking all DNS requests and rerouting them to their own servers. A call to the customer service people was a waste of time.  They're only helpful if you need to unplug your modem and plug it back in. I was on my own.  The clue that led me to the solution was my iPhone, which when connected to my home network, would use OpenDNS.  

    The iPhone connects to my Airport Extreme router, which is connected to the Time Warner router.  My desktops, although physically connected to the Airport Extreme, were using the IP number for the Time Warner router.  

    The solution was to configure my iMac manually, using the IP number for the Airport Extreme, rather than the IP number for the Time Warner router.  BAM!  Problem solved.  

  • Avatar
    melaneyc

    I am having this same problem, but I don't know how to configure my desktop manually using my router's IP instead of Time Warner's. Can anyone help me? I have a windows computer.

  • Avatar
    rotblitz

    Here you go: https://support.opendns.com/forums/21618384-Computer-Configuration

    Use your router's IP address instead of the OpenDNS resolver addresses then.

  • Avatar
    Chris Frost

    Since our resolvers will not understand your routers private IP address–you will need to input your networks public IP address. You can find your public IP address by visiting: http://www.whatismyip.com/.

  • Avatar
    rotblitz

    Confusing... confused now...

    I believe it was not about registering an IP address at  https://dashboard.opendns.com/settings/ but about configuring a DNS server address on a device behind a router configured for OpenDNS use.  The router's private LAN facing IP address is just right for this.  Even more, entering the public IP address will definitely break DNS, because this has most likely no DNS server behind it and cannot respond to DNS lookups at all.

  • Avatar
    Chris Frost

    My apologies melaneyc, I thought you were talking about registering your IP address--often users try register their private IP address (routers IP address). 

  • Avatar
    pklissas

    I was having the same issue and and tried everything suggested on the discussion boards. Finally I looked the time zone set on my router and found it was set for a default of Pacific w/ daylight savings time. So set it for Phoenix (the time zone I'm in). Then I thought I should check that my time on the computer was syncing with the internet time servers and found it was off by 11 seconds. Told it to update the clock and low and behold OPENDNS app no longer says my IP is a mismatch. Hope someone finds this helpful and saves you hours of heartache and head scratching, that has been my experience. 

  • Avatar
    achristean

    Don't know if anyone is still looking at this thread, but I can't get OpenDNS to work on Linux for me, either. When I got to whatismyip.com I get an address - inputting that address into OpenDNS to set up a network, it says it already exists. I've never set up OpenDNS therefore I assume I've been assigned an IP address by my carrier that has been used before. When I go to my router, I find a totally different address assigned by my carrier (I assume) via Dynamic IP. I can't use that IP because my browser, on every computer I have attached to the router, has a different address (the previous one, which OpenDNS says is already set up/recognized previously). Help?

  • Avatar
    achristean

    Also, I modified my router's DNS servers to use OpenDNS - with success, but I still can't add a network. Please tell me how to get around this!

  • Avatar
    mattwilson9090

    @achristean Are you having the same type of problem that the OP had, namely a reported IP address mismatch, or are you just posting to the first old thread you found where someone posted that they had a problem with OpenDNS?

    If you aren't having the same problem please start a new thread so that forum members can respond appropriately.

    If you are having the same problem please read the first two responses to this thread and provide answers to the questions asked in those posts.

  • Avatar
    pizdine

    OpenDNS can not fix this problem.  Internet Service Provider can fix it only, they are not going to change there proxy settings. I am going to get rid of  Cox for good.

  • Avatar
    achristean

    @mattwilson9090 - Yes, I am assuming I have the same issue, and therefore wondered if there was a new way around the service provider pushing you through a proxy or other address and therefore making it impossible to benefit from OpenDNS. My service provider on Saturday gave me the name of someone to talk with tomorrow, so I guess I'll see where it goes. As far as I can determine this is the issue - my service provider is giving me a public address different than what my router is being assigned, by them. I'll start a new thread if I need to, sorry for piggybacking here. I spent a bunch of time trying to find a thread that seemed similar, instead of opening a ticket or starting a new one. 

  • Avatar
    mattwilson9090

    How have you determined this? Assumption are useless for troubleshooting, especially when someone else is trying to help you remotely and can't directly access anything on your network.

    Since you have decided that you have this same issue please do as I asked in my first reply and provide the answers to the questions asked in the first two responses in this entire thread. There is nothing more that anyone in this forum can tell you without that basic diagnostic information.

  • Avatar
    mcace

    I have a client that receives a dynamic IP from an ISP. They have a modem/router that is supplied from the ISP. Up until recently, they were having success using the OpenDNS Updater. However, they recently started receiving an "IP Mismatch Issue". I logged on to their managed modem/router and changed the DNS server to what OpenDNS uses. After pointing to OpenDNS's static DNS IPs, they haven't had any issues. I'm not sure if this will relate to anyone else's issue, but I figured I would share.





  • Avatar
    rotblitz

    "I logged on to their managed modem/router and changed the DNS server to what OpenDNS uses."

    What was the settings before this change?  Where did they have configured the OpenDNS resolver addresses?  Also, seeing that there may be IPv6 connectivity which can come with additional troubles.

  • Avatar
    mcace

    This was the setting before the change: "Select DNS Server Interface from available WAN interface"

    "Where did they have configured the OpenDNS resolver addresses?" That's a great question. They didn't.They were just using the OpenDNS updater. Windstream was providing the DNS servers.

    They claimed everything was working at one time. Prior to having issues, they had a PC that had a wired and wireless connection. They ran a Windows 7 PC with a virtual XP mode that used the wireless connection. Both connections used Cisco Umbrella. However, the wired connection was on a different modem with a static public IP (They never have had issues with this and their VPN router\DHCP server points to the DNS servers from OpenDNS) and the wireless connection was connected to the modem in question (dynamic IP). I'm not sure if any of that was relevant, but I figured I would share.

    Unfortunately, I couldn't talk to the person who originally configured this, but I appreciate your posts. I learned a lot about OpenDNS/Cisco Umbrella reading your posts in the forum today.

     

  • Avatar
    rotblitz

    "That's a great question. They didn't.They were just using the OpenDNS updater."

    LOL, that's purposeless...
    This Updater will always complain, at least about not using OpenDNS or Umbrella.  And the "IP address mismatch" was certainly caused by these more than one public IP addresses and was not really an IP address mismatch, but their misconfigration.

    "They ran a Windows 7 PC with a virtual XP mode that used the wireless connection. Both connections used Cisco Umbrella."

    In this case the Updater should run exactly on this PC.

    Else they should ensure that their devices use indeed OpenDNS or Umbrella by visiting: 
    https://welcome.opendns.com/ 
    https://welcome.umbrella.com/ 

  • Avatar
    lisa.jane.langley

    I started using OpenDNS a few months ago (maybe Jan/Feb 2017). Like "mcace" posted, my internet provider is Windstream and my system was working just fine till about a month ago. I did what he posted, and like magic everything is working again. What's funny is I remember doing something similar when I first started using OpenDNS, so I guess my provider made changes or something that changed that setting. IDK. Thanks for those screenshots and help. I had tried a million other things and I'm not super tech savvy, so this was difficult for me.

  • Avatar
    shane412

    This probably won't work for everyone, but one thing that helped me was to uninstall my OpenDNS Updater and then reinstall it.  I think that worked for me...I was just trying all sorts of things and that seemed to do the trick!  (I had this message before: "Your OpenDNS filtering settings might not work due to DNS IP Address (xx.xx.xxx.xxx) and HTTP IP address (something other than xx.xx.xxx.xxx) mismatch".) 

  • Avatar
    rotblitz

    Correct, your measure helps only in case the Updater is confused and raises this message erroneously.  It does not help if the ISP routes your DNS traffic differently from the other traffic, so that you have a real "IP address mismatch".

  • Avatar
    shane412

    rotblitz: Thanks for the comment, I appreciate it.  Also, uninstalling/reinstalling the updater didn't end up working.  The IP address on the OpenDNS website dashboard says one IP address, while my OpenDNS updater says another IP address.  I still have the same error message on my OpenDNS updater: "Your OpenDNS filtering settings might not work..."  Frustrating! 

Please sign in to leave a comment.