Can't Get OpenDNS To Work - IP Mismatch Issue

Comments

37 comments

  • Avatar
    rotblitz (Edited )

    ---

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    If you have an "IP address mismatch", then you can hardly use your OpenDNS dashboard, but you can still use OpenDNS with its defaults.  To use all features you had to move to another ISP or another product of your ISP where there is no IP address mismatch between DNS and HTTP.

    See https://support.opendns.com/hc/en-us/articles/115003766106 where all is documented.

    0
    Comment actions Permalink
  • Avatar
    rheber31

    Soooo thankful I found this thread!

    I have been using OpenDNS for years, without any issues. Back in January, we were without cable and internet service for several days due to an outage. The outage caused my router to reset itself back to factory settings. It never "clicked" that I needed to reconfigure the DNS settings (because of the router factory reset) until a couple of days ago. Yesterday, I got everything set up, but kept getting the mismatch error from the OpenDNS Updater. I checked to see if Cox had us behind a proxy, which they do not. I could NOT figure it out! Why had it stopped working after all these years? My brain was hurting from battling this, so I finally went to bed and hoped to have a clearer mind today.

    Today, I decided to do another search and came upon this thread... Rotblitz's comment about disabling IPv6 stood out, so I did that. IT WORKED!! I'm guessing Cox has started using IPv6?

    So, thank you, Rotblitz, for that one comment and for all of the help you give to us!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Instead of disabling IPv6 connectivity altogether which is suboptimal, you may want to try with configuring your IPv6 DNS server settings from the following address list on the router or on the end user devices: 
    ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    With this you can still reach the IPv6 internet, else not.

    1
    Comment actions Permalink
  • Avatar
    rheber31

    Unfortunately, I am unable to configure the IPv6 DNS settings on the router (Netgear C3700-100NAS). Does this mean it would have to be done on each device connected to our home network? In our household, we all have Apple devices: 3 iPhones, an iPad, and an iMac. I can see where the IPv6 settings are located, but cannot see that they are able to be changed unless I'm overlooking something.

    Is it not safe to keep IPv6 disabled? IPv4 is enabled.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Yes, you would have to do it on all devices connected to this router and which get an IPv6 DNS server address assigned via DHCP.  It's easy to configure iOS devices with DNS resolver addresses.  You don't have to configure an IPv6 DNS address, the router's IPv4 address or OpenDNS resolver address is fine.  See the instructions provided by OpenDNS.

    As I said, disabling IPv6 connectivity makes IPv6-only destinations unreachable.  This may not be relevant for you yet, but may become important in the future when more destinations support only IPv6.

    1
    Comment actions Permalink
  • Avatar
    rheber31

    Got it. Thank you for your help!!

    0
    Comment actions Permalink

Please sign in to leave a comment.