Opendns and Asus ac66u

Comments

6 comments

  • Avatar
    rotblitz

    As you configured the OpenDNS resolver addresses correctly on the WAN side, they will never be propagated to the computer, so you'll not see them there, but will see that your computer's DNS is pointed to the router.  This is good, else your local name resolution would be broken or impacted.

    What message does http://welcome.opendns.com/ come back with?

    0
    Comment actions Permalink
  • Avatar
    ritzie

    Thanks rotblitz that was my thought but needed to talk it through. So now when I go to http://welcome.opendns.com the following comes up

    You aren't using OpenDNS yet.
    Let's fix that. If you haven't restarted your computer yet, please do that now.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You see now what the problem is.  Your router settings don't seem to take effect.  Your ISP may redirect your DNS queries to their DNS service.  Check it with this command:

    nslookup -type=txt which.opendns.com. 208.67.220.220

    0
    Comment actions Permalink
  • Avatar
    ritzie

    ok got it. here is the output

    Server:        208.67.220.220
    Address:    208.67.220.220#53

    Non-authoritative answer:
    which.opendns.com    text = "I am not an OpenDNS resolver."

    Authoritative answers can be found from:

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, your ISP redirects your DNS queries to their own DNS service.  Your router settings cannot take effect then.

    If you still want to use OpenDNS, try with DNSCrypt: http://dnscrypt.org/
    This may be able to circumvent your ISP's DNS redirection.

    0
    Comment actions Permalink
  • Avatar
    ritzie

    Thanks rotblitz. Appreciate your help. Ill give dnscrypt a try.

    0
    Comment actions Permalink

Please sign in to leave a comment.