OpenDNS not working on Linux only (works on Windows, Android)

Comments

3 comments

  • Avatar
    rotblitz

    Check your /etc/resolv.conf file for non-OpenDNS resolver addresses.

    If there are none, post the complete output of:

    ifconfig -a

    nslookup -type=txt which.opendns.com.
    - or -
    dig which.opendns.com  txt

  • Avatar
    qwaa

    resolv.conf has only: nameserver 127.0.0.1 (is this because of dnsmasq?)

     

    ifconfig -a

    eth0 Link encap:Ethernet HWaddr 00:23:8b:af:d4:e0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:9011 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9011 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:918660 (918.6 KB) TX bytes:918660 (918.6 KB)

    wlan0 Link encap:Ethernet HWaddr 00:22:fa:4f:c5:06
    inet addr:192.168.1.49 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: 2a01:e34:ed58:cb00:6949:6f5f:d6b0:1ef/64 Scope:Global
    inet6 addr: fe80::222:faff:fe4f:c506/64 Scope:Link
    inet6 addr: 2a01:e34:ed58:cb00:222:faff:fe4f:c506/64 Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:288800 errors:0 dropped:0 overruns:0 frame:0
    TX packets:207246 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:276114256 (276.1 MB) TX bytes:44594290 (44.5 MB)

    - and -

    dig which.opendns.com  txt

    ; <<>> DiG 9.8.1-P1 <<>> which.opendns.com txt
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56410
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;which.opendns.com. IN TXT

    ;; ANSWER SECTION:
    which.opendns.com. 1779 IN TXT "I am not an OpenDNS resolver."

    ;; AUTHORITY SECTION:
    opendns.com. 558084 IN NS auth1.opendns.com.
    opendns.com. 558084 IN NS auth2.opendns.com.
    opendns.com. 558084 IN NS auth3.opendns.com.

    ;; ADDITIONAL SECTION:
    auth1.opendns.com. 146761 IN A 208.69.39.2
    auth2.opendns.com. 144625 IN A 67.215.92.66
    auth3.opendns.com. 125330 IN A 208.69.39.2

    ;; Query time: 42 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Jan 15 01:49:58 2014
    ;; MSG SIZE rcvd: 185

     

    Thanks.

  • Avatar
    rotblitz

    Ah yes.  There are two show-stoppers:

    1. You must configure DNSMasq to forward all DNS requests to your router or to OpenDNS directly.   This has to be done for both IPv4 and IPv6. 
      This doesn't seem to be the case now, and your DNS queries go somewhere else, not to OpenDNS.
    2. In case you want to use OpenDNS content filtering reliably, you'll have to disable IPv6 connectivity as a whole, because you cannot register an IPv6 address with OpenDNS yet, and therefore OpenDNS would not associate your DNS queries with your settings as long as IPv6 is being used.

    After you've done that, visit http://welcome.opendns.com/ to see if you're using OpenDNS then.

    "resolv.conf has only: nameserver 127.0.0.1 (is this because of dnsmasq?)"

    Yes, that's fine.

Please sign in to leave a comment.