Has anyone gotten dd-wrt working directly w/ OpenDNS?

Comments

18 comments

  • Avatar
    rotblitz

    "URL - https://updates.opendns.com/nic/update?hostname=
    DYNDNS Server - updates.opendns.com
    "

    As seen from the Wiki http://www.dd-wrt.com/wiki/index.php/OpenDNS, DD-WRT may not be able to raise HTTPS updates, therefore you must go through DNS-O-Matic with HTTP.

    http://updates.dnsomatic.com/nic/update?hostname=

    DynDNS Server: updates.dnsomatic.com

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Thanks rotblitz,

    I did see that page but it didn't come right and say that dd-wrt couldn't connect directly to the OpenDNS server.

    I'll give DNS-O-Matic a try.

    Jim

    0
    Comment actions Permalink
  • Avatar
    Brian Hartvigsen

    You can use DD-WRT directly with OpenDNS over HTTP.  The key is that you have to contact OpenDNS Support and request an update only password (which will be randomly configured and sent to you by support.)  Your normal account password will not work over HTTP and, as rotblitz mentioned, DD-WRT/inadyn (the client DD-WRT uses) do not natively support HTTPS.

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Thanks Brian,

    I was originally able to get DD-WRT working using rotblitz's DNS-O-Matic suggestion. After reading your post however, I re-checked the DDNS status and I'm now however getting this error...

    Thu Feb 6 11:02:34 2014: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater. 
    Thu Feb 6 11:02:34 2014: I:INADYN: IP address for alias 'all.dnsomatic.com' needs update to 'xx.xx.xx.xx' 
    Thu Feb 6 11:02:34 2014: I:INADYN: Alias 'all.dnsomatic.com' to IP 'xx.xx.xx.xx' updated successfully. 
    Thu Feb 6 11:22:48 2014: INADYN:IP: Error 0x83 in recv() 
    Thu Feb 6 11:22:48 2014: W: DYNDNS: Error 'RC_IP_RECV_ERROR' (0x15) when talking to IP server 
    Thu Feb 6 11:22:48 2014: W:'RC_IP_RECV_ERROR' (0x15) updating the IPs. (it 2) 

    The successful connection occurred immediately after changing the URL to the https version. Then 20 minutes later it failed.

    My settings currently are:

    • DDNS Service - Custom
    • DYNDNS Server - updates.dnsomatic.com
    • Username - <My OpenDNS username>
    • Password - <My OpenDNS Password>
    • Hostname - all.dnsomatic.com
    • URL - https://updates.dnsomatic.com/nic/update?hostname=
    • Additional DDNS Options - <empty>
    • Do not use external ip check - No

    Also tried URL of https://updates.dnsomatic.com/nic/update?hostname=   and    /nic/update?hostname=

    Any thoughts? Would the update only password and direct connect to OpenDns be a better solution?

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Did you configure OpenDNS at https://www.dnsomatic.com/ ?  You must!

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Yes using my OpenDNS account information.

    Here's the history from the last couple of days (not sure about the time-zone); the last entry minutes(11:44:10) coincides with the latest time stamp that was successful. (Changed URL back to http...). Same scenario as my previous post. Initial connection works; subsequent ones fail. The minutes (11:02:34) of the https initial request coincides with the second-from-the-top DNS-O-MATIC history entry.

     

    Thu Feb 6 11:44:10 2014: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater. 

    Thu Feb 6 11:44:10 2014: I:INADYN: IP address for alias 'all.dnsomatic.com' needs update to 'xx.xx.xx.xx' 
    Thu Feb 6 11:44:10 2014: I:INADYN: Alias 'all.dnsomatic.com' to IP 'xx.xx.xx.xx' updated successfully. 
    Thu Feb 6 12:34:42 2014: INADYN:IP: Error 0x83 in recv() 
    Thu Feb 6 12:34:42 2014: W: DYNDNS: Error 'RC_IP_RECV_ERROR' (0x15) when talking to IP server 
    Thu Feb 6 12:34:42 2014: W:'RC_IP_RECV_ERROR' (0x15) updating the IPs. (it 5) 

    History

    xx.xx.xx.xx, Feb 6, 2014 4:44 pm, OK
    xx.xx.xx.xx, Feb 6, 2014 4:02 pm, OK
    xx.xx.xx.xx, Feb 6, 2014 2:24 pm, OK
    xx.xx.xx.xx, Feb 5, 2014 1:08 pm, OK
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "not sure about the time-zone"

    You configure your time zone here: https://www.dnsomatic.com/account/

    You'll have to look (or ask) in an inadyn specific forum to find out what "Error 0x83 in recv()" and "RC_IP_RECV_ERROR' (0x15) updating the IPs. (it 5) " really mean.  These are not codes returned by DNS-O-Matic or any DDNS service...

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Thanks rotblitz,

    Updated the time-zone accordingly.

    I do realize the errors are from inadyn but I was hoping someone has had some success in getting this working properly. There are lots of posts and suggestions but nothing that has lead me to a stable set up. I've tried specifying alternate ip servers but all I get in the log is "Connecting to server".

    I've decided to try setting the "Do not use external ip check" flag in the DDNS setup. Supposedly that will allow inadyn to just use the WAN ip address from the router rather than attempting to connect to an ip server. I'll just need to check my ip against what OpenDns shows occasionally to see if it gets out of sync.

    0
    Comment actions Permalink
  • Avatar
    Brian Hartvigsen

    That error indicates there is an issue in checking your external IP address.  Do you still have that disabled?  If not you might want to.  Maybe that it's using an old service that is no longer supported.

    There is no need to do a check when updating dns-o-matic.  We use the IP address the request came from anyway so just make the request and save yourself the lookup.

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Hi Brian,

    I do have it disabled. As I stated in my previous post I'm using the switch that lets inadyn use my router's WAN ip so it shouldn't be an issue.

    I'll keep monitoring the WAN ip on my router and at OpenDns for a while and make sure they remain synchronized.

    Jim

    0
    Comment actions Permalink
  • Avatar
    Brian Hartvigsen

    The error you are seeing, "W: DYNDNS: Error 'RC_IP_RECV_ERROR' (0x15) when talking to IP server" does impact whether the router will send updates.  It seems to happen if you request checkip.org more then once a minute or so (so if you hit Apply Settings a bunch in a short period of time.)  inadyn will do nothing and wait for the next check time (every minute by default.)  So if those errors happening repeatedly it will mean your IP won't be up-to-date.  You could add "--forced_update_period 900" to your "Advanced DDNS Options" to force it to send an update every 15 minutes regardless of whether it could find your IP or thinks there needs to be a change sent (this overwrites the default of 10 days under the "Force Update Interval" setting.)

    Toggling the "Do not use external ip check" seems to have no effect on the parameters stored in /tmp/ddns/inadyn.conf on my DD-WRT router and I have no idea where/how it modifies the code path used by inadyn.  Classic inadyn does not have such a flag from what I can tell.

    You could add "--verbose 5" to the "Advanced Settings" as well to get a better idea of what is happening, but from my testing that didn't spit out any useful information for this particular error.

    This is obviously a bit above and beyond what we normally support (since we aren't DD-WRT, just so happens I use that firmware personally.)  You may want to reach out to that community for additional clarrification/questions.  Here's my setups:

    DNS-O-Matic

    DDNS Service Custom
    DYNDNS Server updates.dnsomatic.com
    Username [MY_EMAIL_ADDRESS]
    Password [MY_PASSWORD]
    Host Name [NETWORK_LABEL_IN_OPENDNS]
    URL /nic/update?hostname=
    Additional DDNS Options --forced_update_period 900
    Do not use external ip check Yes
    Force Update Interval 1

    OpenDNS

    DDNS Service Custom
    DYNDNS Server updates.opendns.com
    Username [MY_EMAIL_ADDRESS]
    Password [UPDATE_PASSWORD_FROM_SUPPORT]
    Host Name [NETWORK_LABEL_IN_OPENDNS]
    URL /nic/update?hostname=
    Additional DDNS Options --forced_update_period 900
    Do not use external ip check Yes
    Force Update Interval 1

    Hope this helps someone out :)

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Thanks Brian,

    I also noticed the configuration file didn't change when setting the 'Do not use external ip' flag. My thoughts is that it just sets a flag in code that forces the inadyn software to skip the ip check and use what the router currently has.

    I did try using the --ip_server_name flag to have inadyn use a different ip server (tried a couple different ones) but every time I tried it I would just get the 'Connecting to server' message in the log.

    I'll leave my setup with the flag set for a while and see what happens. Who knows, maybe it'll work!

    I'll report back when my ip changes and let you know if it works or not. If it doesn't work, I'll try your suggestions above.

    Jim

    0
    Comment actions Permalink
  • Avatar
    Brian Hartvigsen

    I did a little research and found that DD-WRT modified inadyn in order to provide that functionality.  They read that setting directly from nvram.

    0
    Comment actions Permalink
  • Avatar
    jblitzie

    Very cool. So, in theory it should work!

    0
    Comment actions Permalink
  • Avatar
    Brian Hartvigsen

    Definitely.  I have it working on my home router ;-)

    0
    Comment actions Permalink
  • Avatar
    giallograle

    Very helpful thanks Brian, however I needed to change the URL to get your DNS-O-Matic settings to work on my dd-wrt router.

    The following works for me:

    DNS-O-Matic

    DDNS Service Custom
    DYNDNS Server updates.dnsomatic.com
    Username [MY_EMAIL_ADDRESS]
    Password [MY_PASSWORD]
    Host Name all.dnsomatic.com
    URL /nic/update?
    Additional DDNS Options --forced_update_period 900
    Do not use external ip check Yes
    Force Update Interval 1
    0
    Comment actions Permalink
  • Avatar
    zamanoof

    sorry for this 

    this correct one 

    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=277481

    0
    Comment actions Permalink

Please sign in to leave a comment.