Google won't be blocked

Comments

8 comments

  • Avatar
    rotblitz

    What exactly did you do to block Google and Yahoo?

    Is your IP address registered with your OpenDNS network?  https://dashboard.opendns.com/settings/

    Only if yes, post the complete plain text output of the following command here:

    nslookup -type=txt debug.opendns.com.

    0
    Comment actions Permalink
  • Avatar
    akubik

    Yes. I already said, the test page works, and other things that I have previously blocked are also blocked as well. I ticked off the "search engine" and "visual search engine" boxes in the settings dashboard (they're custom settings).

    However, please tell me where I'm supposed to put the "nslookup -type=txt debug.opendns.com" command. What am I supposed to put the command into? I tried putting it into command prompt and it says my network name (for server), my router's local IP address. and then it says that it can't find debug.opendns.com (that it's a non-existent domain).

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "then it says that it can't find debug.opendns.com (that it's a non-existent domain)."

    You did it right, and the result indicates that you didn't use OpenDNS for your DNS queries at that time.

    Post a screen shot from the router's page where you have entered the OpenDNS resolver addresses.

    0
    Comment actions Permalink
  • Avatar
    akubik

    I *think* I may have solved the problem. I read another tutorial which explained to fill in the static DNS 3 field: http://blog.cantonwebservices.com/1345/protect-your-entire-network-with-opendns-with-dd-wrt.html

    If it is left at the default 0.0 0.0 then my provider's ISP can still sometimes be used. Maybe that is what is happening? It's hard to tell. I am doing this for a friend's router and I set up a PPTP server to connect through VPN (I have Windows 8 on my computer and used the "Connect to a Workplace" feature. However, though I can access the router (usually) with no problems, I can never seem to get a reliable connection to test the OpenDNS and router settings on my computer. I want my computer to completely act as if it's on their network.

    I am attempting to set up OpenVPN (following this step-by-step tutorial: http://www.howtogeek.com/64433/how-to-install-and-configure-openvpn-on-your-dd-wrt-router/) but I can't find OpenVPN Daemon. So I am at a loss. Not sure how I'm going to properly test all this!




    ScreenShot.png
    0
    Comment actions Permalink
  • Avatar
    akubik

    I was there yesterday when I was having this problem (and posted the original question while there). However, by the time you responded, I was at home. I am still at my home (not there).

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, you didn't say that you have a Linksys router.  With these routers you fill the Static DNS 3 field with one of 208.67.222.220 or 208.67.220.222, else you will not reliably use OpenDNS, but randomly also your ISP's DNS.  Do not fill the WINS field, i.e. leave it at 0.0.0.0.

    0
    Comment actions Permalink
  • Avatar
    akubik

    I followed these instructions: http://www.dd-wrt.com/wiki/index.php/PPTP_Tunneling 

    I got all the way through, and then followed the instructions Disable IPSec and L2TP Passthrough and now I can't access the router (I've been accessing the router via VPN from my house in order to do this). 

    It looks like I am on their network because the things that I have blocked on their network now work while I am connected. But I CANNOT connect back to the router!

    So I can't put 0.0.0.0 in the WINS field. What is it, anyway? I don't remember ever putting anything in it.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I followed these instructions: http://www.dd-wrt.com/wiki/index.php/PPTP_Tunneling "

    I do not see a relationship wth configuring a DNS service like OpenDNS with the page you linked to.  In case your Linksys router is flashed with DD-WRT, the right page would be:
    http://www.dd-wrt.com/wiki/index.php/OpenDNS

    If you got troubles while configuring the wrong stuff, you'll have to refer to DD-WRT support.  Here are the OpenDNS experts, the DD-WRT experts are somewhere else.

    0
    Comment actions Permalink

Please sign in to leave a comment.