OpenDNS failing to block sites when using Apple Airport Extreme

Comments

5 comments

  • Avatar
    rotblitz

    Maybe more than one problem:

    1. "Screenshot of configuration is attached."
      You're maybe using an IPv6 connection, but you cannot register an IPv6 address with your OpenDNS network, so OpenDNS cannot associate your IPv6 DNS queries with your settings.  If you want to use content filtering, stats and customization, you'll have to disable IPv6 connectivity.
    2. "None of the basic test domains (welcome to OpenDNS, etc) work at this time."
      This can indicate that your DNS queries are redirected by your ISP to their own DNS service.  Check it with the following command:
      nslookup -type=txt which.opendns.com.  208.67.220.220
  • Avatar
    gtobias

    1.  I cannot find any way to disable IPv6 connectivity in the Airport Utility program.  But would that really be an issue when I'm using a static IP address?

    2.  Here is what I got:

    Server: 208.67.220.220
    Address: 208.67.220.220#53

    Non-authoritative answer:
    which.opendns.com text = "5.ash"

  • Avatar
    rotblitz

    Good news, point 2 is not an issue.  Your ISP does not redirect your DNS queries.

    Point 1: This would be an issue, because, as I said, you cannot register an IPv6 address with your OpenDNS network.  It really doesn't matter if you got a static or dynamic IP address.

    Does http://welcome.opendns.com/ still indicate that you're not using OpenDNS?
    Ensure that at least your correct (static?) IPv4 address is registered at https://dashboard.opendns.com/settings/

    Then post the complete plain text output of the command(s):
    nslookup example.com.
    where example.com is from the domains which should be blocked for you but aren't.

  • Avatar
    mretondo

    I've been using and AirPort Express for many years and now an Apple TimeCapsule with now problems even though starting with Lion IPv6 is on by default. Make sure your using your ISP address which will be IPv4. I use the address Comcast assigns me. Also on the router set it from Automatic to Link-Local. That makes it only IPv6 within your local network.

     

    To turn off IPv6 on your Mac use one or both of the following terminal commands. One will turn IPv6 Off for Wi-Fi and the other for Ethernet. Open Terminal and cut and paste one of the lines below. To turn IPv6 back on again just open the Network preference panel and set it back to Automatic.

    networksetup -setv6off Wi-Fi

    networksetup -setv6off Ethernet

  • Avatar
    mretondo

    Forgot, you should add sudo in front of the commands, like so:

    sudo networksetup -setv6off Wi-Fi

Please sign in to leave a comment.