Dynamic DNS settings for AVM FritzBox router

Comments

39 comments

  • Avatar
    rotblitz

    To (almost) prevent this warning message to appear, you'll have to use a real dynamic DNS hostname which is updated as well and points to your IP address then.  The reason is: your router checks for the success of the update afterwards, and any made-up hostname like "dnsomatic" or "dnsomatic.com" or "OpenDNSusername.opennds.com" or "OpenDNSusername_networkname.opennds.com" causes the test to fail and to raise this warning message if the hostname does not exist or points to the wrong IP address.

    See at DNS-O-Matic what services are supported, and select a free service from there to subscribe to it to get a hostname you can enter in your router, and keep this updated through DNS-O-Matic as well, same as your OpenDNS service.

    Btw, the update URL of Config 1 is most likely the right one.  I would not know that AVM devices support HTTPS at all.  But I may be wrong.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    While we are working on this case in your ticket, I will hold this space as a placeholder for DDNS information regarding the AVM Fritz!Box 7330 router. 

    It may be the case that this router only supports DDNS updates for a dynamic IP hostname to allow remote connections into the router, and may not support OpenDNS IP updates out of the box. 

    0
    Comment actions Permalink
  • Avatar
    dirtyharry_28

    Hello Rotblitz,

     

    thanks for your post. That´s what I found out in the meantime but as some say it works with whatever you add as domain name (dnsomatic, localhost etc) I was confused.

    In the meantime I have registered a DDNS account at one of the services supported by DNS-O-Matic and added this server name to my Fritz!Box as domain name. For 2 days I still got this "Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung war erfolgreich, anschließend trat jedoch ein Fehler bei der DNS-Auflösung auf." error but only 2 times and only when the box reconnects after the forced 24h ISP disconnect, before it was every ~30mins. Today I did not get any error after reconnect, no idea why.

    What service do you use with the "domain name" field? Did you enable remote access via HTTPS for the box?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "For 2 days I still got this "Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung war erfolgreich, anschließend trat jedoch ein Fehler bei der DNS-Auflösung auf.""

    But the update was successful, as the message says.  And this is the important point.  You may still occasionally get this error message. You can safely ignore it, or ask AVM to increase the time after they check whether or not the update was successful.  They apparently don't wait long enough to check.  It should be at least one minute, better three, not just a few seconds.  DDNS updates take a short while, depending on many factors like the TTL and local and remote caching.

    Also, there is no rule (and most likely no need) to check afterwards for a DNS resolution (DNS-Auflösung) against the configued hostname.  Rather to the contrary: some official APIs forbid this checking against hostnames.  AVM are not compliant with these rules.

    "before it was every ~30mins."

    This could have several reasons.  Your ISP may have changed your IP address so often, or your AVM device has a severe bug raising unnecessary (abusive) DDNS updates too often under certain circumstances where using an non-existent hostname (as you did) would be a good reason for.

    All that said, you can't do anything more except to provide AVM with these options: either getting rid of this unnecessary check or make it optional (preferred), or increasing the wait time before they check.

    0
    Comment actions Permalink
  • Avatar
    dirtyharry_28

    It seems random when I get these 2 errors, some days I get them, some days I don´t. But I can live with that.

    I don´t think AVM will increase the timeout only for me :) Found several tutorials how to add a new DDNS service via editing an exported settings file where you can manually set values like time out / TTL but I don´t want to brick my box by importing an edited settings file which is not 100% correct .

    IP address is definitely only changed once (if DSL sync does not lost) and always between 4 and 5 AM (as set in the Fritz!Box). My assumption is that (before I added the "dummy" DDNS service as domain name) it frequently tries to resolve and if it does not work it tries again and again. But now with adding a dummy DDNS service, for which I created an account but not use it, the box will stop showing the error as soon as the domain name could be resolved before the defined time out of the box.

    So far, I am fine with it. Hope this may help other Fritz!Box users.

    @Support: I once opened a support ticket asking if you need a short description with screenshots for an AVM Fritz!Box to add to your router tutorials as AVM models are completely missing there and this type of router is very popular in Germany as they are sold by a big German ISP together with their service.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    I've reached out to you on a support ticket so we can work together to create some FritzBox documentation on our router configuration guide. We'd love to have screenshots and descriptions!

    0
    Comment actions Permalink
  • Avatar
    jantietje.de
    Is there a documentation for FritzBoxes yet? I could not find it. I would love to have one and i would also like to support or test a documentation.
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    The documentation is your AVM user manual.

    0
    Comment actions Permalink
  • Avatar
    dirtyharry_28
    @Alexander & Jantietje: I could share my experience and settings with an AVM Fritz!Box using OpenDNS if you like
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    We all know:

    First you must register your OpenDNS service at https://www.dnsomatic.com/ 
    And you register a hostname with any other (free) DDNS provider supported by DNS-O-Matic which you register at DNS-O-Matic too.

    Then you configure your FritzBox.  The same is valid for most other AVM supplied routers like Speedports.

    Service: user defined (or DNS-O-Matic if supported)
    Update URL: updates.dnsomatic.com/nic/update?myip=<ipaddr> 
    Domainname: the hostname registered with this other DDNS provider 
    Username: Your e-mail address registered with OpenDNS/DNS-O-Matic 
    Password: your OpenDNS/DNS-O-Matic password 

    That's all!

    0
    Comment actions Permalink
  • Avatar
    jantietje.de
    Thank for your support, my FritzBox is doing fine with opendns. I just want to ret rid of the error messages and looking forward to "some FritzBox documentation on our router configuration guide" with "screenshots and descriptions".
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Isn't that too trivial?

    0
    Comment actions Permalink
  • Avatar
    marcben

    I'm using Fritz!Box 7490 and it gives me the same message.

    Anyway, it works correctly and all of the 6 services that are configured on the DNS-O-Matic service are correctly updated.

    I think it should just be regarded as a warning, rather than a real error.

    This is confirmed by the following help text you obtain clicking on the error message:

     

    Dynamic DNS error: The dynamic DNS update was successful, but an error occurred during the subsequent DNS resolution.

    This is an event message from the "Internet Connection" area.

    The update request was confirmed by the DynDNS provider, but has not been implemented yet. After a few minutes your IP address will be converted automatically.

    If you would like to check it, open your domain in a web browser.

    If the connection cannot be established even after a long wait, contact your DynDNS provider.

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    And what is your question?

    This error message is the same in English as reported in German by the original poster dirtyharry_28, and this has been answered by me, so nothing should be open to be answered.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    The error is due to OpenDNS not actually updating a DDNS domain so there would be no DNS to resolve at the end of it so as long as the DNS update is successful it's good to go. 

    0
    Comment actions Permalink
  • Avatar
    dicks1

    On my 7270v3 these are my settings. The Fritzbox throws an occasional "Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung war erfolgreich, anschließend trat jedoch ein Fehler bei der DNS-Auflösung auf." but I think this is an issue related to the too short time set for the FritzBox to check the DNS update.

    My settings (which work fine, even with just having only OpenDNS and no other DNS service configured in dnsomatic):

    Dynamic DNS-Anbieter: Benutzerdefiniert

    Update-URL: http://updates.dnsomatic.com/nic/update?hostname=all.dnsomatic.com&myip=<ipaddr>&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG

    Domainname: all.dnsomatic.com

    Benutzername: [name von opendns-konto]

    Kennwort: [kennwort von opendns-konto]

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I think this is an issue related to the too short time set for the FritzBox to check the DNS update."

    I see that you didn't read this thread from begin.  It could be the short timeout, but in your case it isn't.  Because the FritzBox (or anything else) can't resolve the domain name all.dnsomatic.com, this is non-existent.  If you want to prevent from happening this error message, you'll have to read and follow my first response and advices above.

    Also, you can shorten your Update-URL for DNS-O-Matic to the following (exactly as you see it here and like the original author posted it): 
    updates.dnsomatic.com/nic/update?myip=<ipaddr> 

    Everything else is obsolete and of no use.

    0
    Comment actions Permalink
  • Avatar
    dicks1

    I did read your original post.

    Re. "See at DNS-O-Matic what services are supported, and select a free service from there to subscribe to it to get a hostname you can enter in your router, and keep this updated through DNS-O-Matic as well, same as your OpenDNS service." -> I tried this and added an additional domain to dnsomatic (the created domain from afraid.org).

    There is absolutely no difference in the Fritzbox error log when I have the DDNS from afraid.org or the all.dnsomatic.com address in "Domainname".

    Also, I have tried both versions of the Update-URL, also there is no difference in the amount of errors in the Fritzbox log.

    In all cases you will see "Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung war erfolgreich, anschließend trat jedoch ein Fehler bei der DNS-Auflösung auf."

    However the good news is, in all cases the IP is updated correctly.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "There is absolutely no difference in the Fritzbox error log when I have the DDNS from afraid.org or the all.dnsomatic.com address in "Domainname"."

    Ah yes, this is new information and throws a different light on it!  Sure, with the afraid.org DDNS name it is the too short timeout of the FritzBox firmware then.  With all.dnsomatic.com it will be always, no matter what the timeout value would be.

    You may want to go back to AVM to report this problem with your firmware version, and you may check if there's a firmware update available where this bug may be fixed already.

    0
    Comment actions Permalink
  • Avatar
    g2655970

    Since I’m having the same issue with all these „errors“ in my FritzBox-logs, I just emailed AVM and asked for assistance, e.g. settings especially for OpenDNS, with no need for the „domainname“-field :)

    Hoping to get a somehow helpful answer!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Try with the following in the domain name field:  myip.opendns.com
    A DNS lookup to this domain returns the source IP address (in case of using OpenDNS' resolvers), and this is what the AVM DDNS check routine does...

    1
    Comment actions Permalink
  • Avatar
    g2655970

    Thank you so much, again! Works like a charm!

    0
    Comment actions Permalink
  • Avatar
    g2655970

    Dear rotblitz,

    I think it would be best to place the further discussion here:

    I inserted „myip.opendns.com“ into the specific field. As I wrote, the update worked fine and I didnt receive the „errors“.

    Here comes the problem:

    It seems as if the FritzBox, does not initiate the updates, when it gets a new IP (ISP reconnect every 24 hours :()

    Instead it seems as if the FritzBox first checks out, which IP „myip.opendns.com“ returns. Since this requests returns my actual IP and not the old IP, which OpenDNS has in store, the FritzBox thinks, that everything is fine, OpenDNS is up-to-date, and there is no need for an update :/

    So unfortunately this also doesn’t work for me, since the updates are now completely paused.

     

    Is there a way/url to get the IP, which OpenDNS has in store for my network?

    This would help to initiate updates, when needed, and pause them, when OpenDNS has the latest IP…

    I’d appreciate any further idea you have ;)

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yep, confirmed, I made now the same experience with a Speedport router (produced by AVM).  The "domain name" must not have the current IP address, else no update takes place. :(

    Then you must return to what I suggested and tested above: you must fill the domain field with another domain name from a DDNS service.  And you may continue to bother AVM with firmware change requests like an option to not check the "domain name" before the update after an IP address change, and/or an option not to check the update result after the update.

    "Is there a way/url to get the IP, which OpenDNS has in store for my network?"

    I only know this: https://dashboard.opendns.com/settings/
    But this most likely doesn't help either to get the AVM router problem solved...

    0
    Comment actions Permalink
  • Avatar
    g2655970
    Mmh ok, thanks for this confirmation! Than let's see how cooperative AVM is ;) Thanks for all your help so fare!
    0
    Comment actions Permalink
  • Avatar
    gcrisci

    someone have update about what the AVM assistence have replied about the domainname field?

    I have configured all as pointed in this thread, and I get the error every few minutes by my avm fritzbox ...

     

    Thank you in any case for all the instructions

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I get the error every few minutes by my avm fritzbox"

    This looks like a totally different problem, unrelated to the topic of this thread.  It seems you have an internet connection timeout defined on your router, or your ISP forces one on you.  See if you have an option like "always online" in your router settings, and enable this.

    0
    Comment actions Permalink
  • Avatar
    dirtyharry_28

    I made a short guide how I setup my FritzBox 7362 SL with OpenDNS. Hope this helps some of you.

    Although I sometimes get this error "Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung war erfolgreich, anschließend trat jedoch ein Fehler bei der DNS-Auflösung auf." which means that DNS update was successful but an error occured afterwards the update of my IP to OpenDNS functions without problems.

    After that set your DNS server in the FritzBox to the ones of OpenDNS and you are done:

    IPv4:
    208.67.222.222
    208.67.222.220

    IPv6:
    2620:0:ccc::2
    2620:0:ccd::2

    Using this method now for approx. 2 years without any issues.

     




    OpenDNS.pdf
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    IPv6:
    2620:0:ccc::2
    2620:0:ccd::2

    If you're doing this, you almost cannot make use of the enhanced OpenDNS features like content filtering and stats, for all DNS traffic going through IPv6.  Because you cannot register an IPv6 address at https://dashboard.opendns.com/settings/ yet, OpenDNS cannot associate your related DNS queries over IPv6 with your settings.

    If you want to use this features, you must disable IPv6 traffic, at least for the DNS traffic.

    0
    Comment actions Permalink
  • Avatar
    dirtyharry_28

    My OpenDNS dashboard shows the correct IPv4 address and the FritzBox uses the IPv4 DNS 208.67.222.222 as standard server so this should be fine, right?

    0
    Comment actions Permalink

Please sign in to leave a comment.