Filter porn

Comments

30 comments

  • Avatar
    rotblitz

    Are you using OpenDNS at all?  http://welcome.opendns.com/ 
    If not, correct the configuration of the OpenDNS resolver addresses: https://store.opendns.com/start

    Is your IP address information correctly assigned with your dashboard network?  https://dashboard.opendns.com/settings/ 
    If not, correct this.  You may need to run an Updater further on.

    "Furthermore would I like to enable this without having the access, to disable the settings."

    Not sure what you exactly want to say here.  If you don't have access, you can't enable or disable anything...

  • Avatar
    dps0001

    Hi,

    Thank you for the prompt response.
    Yes, I am using the Family Shield Router configuration, where my D-Link device is configured with the specified DNS addresses.

    I am ashamed to say this, the reason for me not wanting access, to change anything it due to the fact that I am a addict.  I want to block it wherever I can.  Without having a way to remove the configuration.

    I hope you can help.

  • Avatar
    rotblitz

    "I am using the Family Shield Router configuration, where my D-Link device is configured with the specified DNS addresses."

    As I understand now, you want to use FamilyShield with  the resolver addresses 208.67.222.123 and 208.67.220.123.  Ensure that you used only these addresses and that all DNS fields are filled.

    You do not need any dashboard configuration with FamilyShield unless you want stats and want blocked more than just adult content.

    If you have flushed both, your local resolver cache and your browser cache, then www.exampleadultsite.com should be blocked for you. 
    If still not, post the complete plain text output of the following commands here: 

    nslookup -type=txt debug.opendns.com.

    nslookup -type=txt which.opendns.com. 208.67.220.123

    nslookup www.exampleadultsite.com.

    "not wanting access, to change anything"

    No problem.  As the configuration is on your router, ask a good friend to protect your router with a strong password only known to him or her.

  • Avatar
    Kristy Patullo

    If you are using our default DNS servers (208.67.222.222 an 208.67.220.220) only internet level malware, botnets, and phishing is blocked by default.  You would need to configure custom content filtering for your network in the dashboard to block porn with this service.  If you would like to block porn without having to change settings as rotblitz mentioned above you will want to use our FamilyShield DNS settings 208.67.222.123 and 208.67.220.123 which block Pornography, Nudity, Proxy/Anonymizer, and Sexuality by default.

  • Avatar
    dps0001

    I thank-you all very much.  It works perfectly! 

    God bless!

  • Avatar
    terilyn.smith

    I just enabled the family filter DNS on our Cable One router due to our autistic 14yo grandson's switching between Baby Einstein and Lonely Bitches .... thanks so much for helping us put up the good fight against that mind rotting porn garbage. We know things slip through but it wont' do so here without a fight. The Smith Family is very grateful.

  • Avatar
    khirdaji

    I did block block Pornography, Nudity, Proxy/Anonymizer, and Sexuality and seems to work fine. nut if I search google for porn images its still not blocked. Please advise.

  • Avatar
    cobalt-phoenix

    Simple: you didn't block Google.  You need to block Google to block Google and porn presented by it.  What else?

  • Avatar
    jbc944

    I need help I did all of the steps for windows 10 and still wont block anything 

     

  • Avatar
    mattwilson9090

    @jbc944 What steps did you follow? Either cut and paste or provide a link to them so we know what you are talking about. Have you confirmed that the domains that you are concerned about are categorized as pornography? Have you followed any of the troubleshooting or testing steps that were discussed in this thread that you posted in?

  • Avatar
    jbc944

    I Followed the windows 10 guide.  Can it be be done through a netgear extender?

  • Avatar
    mattwilson9090

    @jbc944 What Windows 10 guide are you referring to? Again either cut and paste or provide a link so we have some idea what you are talking about.

    And again, have you confirmed that the domains that you are concerned about are categorized as pornography? Have you followed any of the troubleshooting or testing steps that were discussed in this thread that you posted in?

    What would a netgear extender have to do with OpenDNS?

    People here are willing to help you, but you have to be a part of the process, including answering questions that are asked of you, and including enough information so that we know what is going on and have some clue what you are talking about. If you answer the questions that have already been posed to you specifically, or to others in this thread we'll be able to do that.

  • Avatar
    rotblitz

    Again, you provided zero information.  You need to follow the steps above in this thread, although they are two years old.  How else could one see where the problem lies?

  • Avatar
    jbc944

    https://support.opendns.com/entries/95614747-Windows-10-Configuration-Instructions

    I tried troubleshooting and yes they are considered porn sites 

  • Avatar
    rotblitz

    I was talking about the step described in the messages from June 24, 2014, 07:25 and from June 24, 2014, 08:09.

  • Avatar
    jbc944

    No i did not it did not seem clear to me 

  • Avatar
    rotblitz

    So, do now!  If something isn't clear, then simply identify it and ask for it.

  • Avatar
    mhdalshami

    I used family shield and it's work ,but when someone use vpn application as "psiphon" on android device the porn sites isn't block and steel working ..
    is there any way to resolve this problem?

  • Avatar
    mattwilson9090

    VPN connections are supposed to work this way, you cannot filter or control the traffic that goes through the VPN tunnel with a security tool such as OpenDNS. If you want to provent this you'll need to prevent the VPN connection from occurring in the first place (which OpenDNS may or not be able to do). However, since this is on an Android whatever method you use may not have an effect if the android connects to the internet via it's data plan instead of your Wi-Fi

  • Avatar
    rotblitz

    To prevent from VPN connections being used, you have to find out what domain names, protocols, ports and IP addresses are being used by a VPN connection.  You can block the domain names with OpenDNS. Protocols (TCP, UDP), ports and IP addresses can usually be blocked on the router. This works only as long as the device uses the internet from within your LAN, of course. You do not have control over an e.g. cellular (mobile) connection or WiFi somewhere, as mattwilson9090 said.

  • Avatar
    alyemail

    Hi @cobalt-phoenix

    Can you please explain how to block Google to block Google?

    Thanks

  • Avatar
    alyemail

    @cobalt-phoenix This is with reference to the message posted on May 14 2016.

    I would like stop Google showing indecent images/photos?

    Thanks.

  • Avatar
    rotblitz (Edited )

    (I'm the same person as cobalt-phoenix.)

    If you want to block Google as a whole with OpenDNS, add google.com to your "always block" list.

    If you want to stop only "indecent images/photos" on Google, you'll want to enforce Google's SafeSearch feature.
    https://support.opendns.com/hc/en-us/articles/227986807
    Please note, this is not an OpenDNS function, but a Google function.

  • Avatar
    alyemail

    Thanks!

    I could not follow how to create CNAME as in the article, so I physically setup Google safe search from the Google settings on my laptop and my I-phone. This did the job but I would rather have this configured on the server. Any suggestions?

     

    More importantly, I added the IP addresses below on my router, but the network is a slow now. Is the third one correct?

    208.67.222.123

    208.67.220.123

    208.67.222.220

  • Avatar
    alyemail

    Also, Skype is no longer working. It takes very long for connecting, but it does not connect. Is this related to the DNS change or it is a known "side effect"?
    Thanks in advance...!

     

     

  • Avatar
    rotblitz

    "I would rather have this configured on the server."

    What server?  Do you operate a server?  That's fine.  Install a free distro of a DNS server program on it and configure the CNAMEs for Google and YouTube there.

    "Is the third one correct?"

    This 208.67.222.220 is an OpenDNS resolver address, but in contrast to the *.123 FamilyShield addresses it doesn't filter anything by default unless you configured the filtering in your dashboard.

    "the network is a slow now"

    Oops, you're now coming up with an item being off-topic in and unrelated to this thread which is about "filter porn".  Regarding slow responses see e.g. https://support.opendns.com/hc/en-us/community/posts/239165928

  • Avatar
    alyemail

    I meant the 'router" not the server.

    I have 3 static DNS spaces in my router. I added three IP addresses below and the intention is to prevent porn in all shapes and forms (videos, pictures, etc.). Can you also let me know if the third IP address is correct and if not what do I need to use instead?

    208.67.222.123

    208.67.220.123

    208.67.222.220

     

  • Avatar
    rotblitz

    Not sure why you ask the same question again.  Read my last message above. I've said everything about 208.67.222.220 already and have nothing to add.

  • Avatar
    starbroadbandhyd

    Hi i want to block porn websites on my server using dns i have tried every open dns  on my local network they are not working  properly i am using Mikrotek CCR1009

  • Avatar
    rotblitz (Edited )

    You must be much more specific about "not working properly" to get help here.  A good starting point would be to copy & paste the complete plain text output of these diagnostic commands to here:

    nslookup -type=txt debug.opendns.com.
    nslookup www.exampleadultsite.com.

     

Please sign in to leave a comment.