Help Configuration TP-Link

Comments

32 comments

  • Avatar
    rotblitz

    You have two options:

    Network  >  WAN

    X    Use These DNS Servers
    Primary DNS:       208.67.222.222
    Secondary DNS:  208.67.220.220

    - or -

    DHCP  >  DHCP Settings

    Primary DNS:       208.67.222.222
    Secondary DNS:  208.67.220.220


    The first option is preferred if it works.

  • Avatar
    Kristy Patullo

    In addition to Rotblitz's recommendations if you need more visual directions page 22 of this user guide shows where you can configure static WAN DNS settings if you have a dynamic IP http://www.tp-link.com/Resources/document/TL-WR841N_V8_User_Guide.pdf.  You add the Primary and Secondary DNS setting listed above.

     

  • Avatar
    marcusgpg

    I came to this site for a tutorial by TecnoBlog.Net site, which says that when everything is set up right you enter on next page (http://www.opendns.com/welcome/) and has the following image appears. .
    I did everything the guy up there said, and went on that page and did not show that message can help me some more, I'll put some pictures here of how it is configured on the router and on TCP/IPv4.
    If anyone else can help me set up just right to the point image of Welcome min appear to be very happy.

    Thanks in advance, Marcus

     




    Page Welcome.jpg
    Config. Router.png
    Config. TPC-IPv4.png
  • Avatar
    rotblitz

    There's nothing wrong with your router configuration.  Configuring the OpenDNS resolver addresses on the computer is not necessary.

    The test page is http://welcome.opendns.com/

    If it does not work, it is likely that your ISP redirects your DNS lookups to their own DNS service.  To see this you'll want to copy & paste the complete plain text output of the following command here (after having opened a Command Prompt window: cmd):

       nslookup -type=txt which.opendns.com. 208.67.220.220

  • Avatar
    marcusgpg

    I tried to give the command you told me friend, how did it ever got a little kkk.
    Look what they gave.




    CMD.png
  • Avatar
    rotblitz

    You didn't enter it correctly.  Try again.

    nslookup   -type=txt   which.opendns.com.   208.67.220.220

    This shouldn't be too difficult.

  • Avatar
    devdee

    Hi rotblitz, i have a problem i setting a network using 

    TP-LINK TL-WR841N

    in wan setting i use opndns ip in dhcp setting i use open dns ip, in my pc i use open dns manually. but when i chake seting its gatting oops.  

  • Avatar
    mattwilson9090

    Please provide screenshots (using the links on this forum, not a third-party file sharing service) of these pages/settings you are referring to, especially the one that displays "oops"

    Also, please copy and paste the output from the command that rotblitz provided in his reply to this thread a year ago.

  • Avatar
    danne_silver

    hi!

    im using ppoe connection (russian) and it doesnt work with this method!

  • Avatar
    rotblitz

    This is right, PPPoE/Russian doesn't seem to offer entering DNS resolver addresses.
    As always in these cases, this leaves you with the following options:

    • Replace this router by another where you can enter DNS resolver addresses.
    • Flash the router with alternative firmware where you can enter DNS resolver addresses.
    • Put another inner router behind this outer router where you configure DNS resolver addresses on the inner router.
    • Configure the OpenDNS resolver addresses on the devices instead of on the router.

    The latter is the easiest, not requiring any additional hardware or software.

  • Avatar
    cocoyc

    Can't seem to get this to work in my DSL (dynamic private ip) line with a TPlink wifi router. Already configured DDNS. Still able to access bad sites. Here's the output of my NSLookup - 

    nslookup   -type=txt   which.opendns.com.   208.67.220.220

    Server: 208.67.220.220

    Address: 208.67.220.220#53

     

    Non-authoritative answer:

    which.opendns.com text = "7.sin"

     

    Authoritative answers can be found from:

     

     

  • Avatar
    cocoyc

    I use a TPLink MR3220 and PPPoE as authentication method

  • Avatar
    cobalt-phoenix

    Your command output indicates that you can use OpenDNS if you're actually using it.  I.e. your ISP doesn't hi-jack your DNS traffic.

    "Already configured DDNS."

    Why this?  This has nothing to do with using OpenDNS.   Same you could have said: "I already cleaned my car and my shoes".

    Post the complete plain text output of the following diagnostic command:

       nslookup -type=txt debug.opendns.com.

  • Avatar
    cocoyc

    Pls ignore this request, I realized the one causing the issue is because my free OpenDNS account for the home is just for one network only. I'm trying to add another broadband line .

    I also had a wrong assumption that to get it to work with dynamic IP, that DDNS should be enabled in the router

  • Avatar
    cocoyc

    Pls ignore this request, I realized the one causing the issue is because my free OpenDNS account for the home is just for one network only. I'm trying to add another broadband line .

    I also had a wrong assumption that to get it to work with dynamic IP, that DDNS should be enabled in the router

  • Avatar
    luqifar

    I use TP- Link 300M Wireless N Router (Model No. TL-WR841N v10.0) and my ISP (alliance cable broadband) gave me Static IP. I tried all the way I notice in the forum but nothing is changes in welcome page. What am I doing wrong? I don't have much knowledge about Static and Dynamic IP. I just want to add web filter to increase productivity and help my family to avoid unnecessary content. Please help me to configure my router.

  • Avatar
    mattwilson9090

    @luqifar We have no idea what you've actually done, so we can't tell you what you've done wrong.

    You either need to tell us what you've actually done, and how things are currently configured, or, since there don't seem to be specific instructions for your router model, begin following the directions from this page https://signup.opendns.com/homefree. If you haven't already created an account it will step you through creating one, otherwise you can sign up with the account you already have and continue from there.

  • Avatar
    rotblitz

    @luqifar
    "What am I doing wrong?"

    You don't read thoroughly enough. ;-)  Else you would have posted the command outputs of:

    nslookup -type=txt debug.opendns.com.

    nslookup -type=txt debug.opendns.com. 208.67.220.220

    "I tried all the way I notice in the forum"

    What exactly was this "all the way" you tried?  You may post a screen shot of the related router page.

    "I don't have much knowledge about Static and Dynamic IP. "

    Well a static IP address is static and doesn't change, and a dynamic IP address is dynamic and therefore can change at any time.  But this is rather unrelated to configuring OpenDNS.  The only difference is that you should run an update client if you've got a dynamic IP address.

  • Avatar
    shgr11111 (Edited )

    My router is TP-link TL-WR841n PPoE Russian. I've replaced firmware with DDWRT. I've done everything on this page http://www.dd-wrt.com/wiki/index.php/OpenDNS (including DNS-O-Matic for users with a Dynamic IP) and nothing works.

    I dont have static IP, it's dynamic. To have static IP you should pay for that.

    This is command output of nslookup -type=txt which.opendns.com. 208.67.220.220

    ╤хЁтхЁ: resolver2.opendns.com
    Address: 208.67.220.220

    Не заслуживающий доверия ответ: //My comment! It means "THe answer can't be trusted" in russian.
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    opendns.com nameserver = auth3.opendns.com
    opendns.com nameserver = auth2.opendns.com
    opendns.com nameserver = auth1.opendns.com
    auth1.opendns.com internet address = 208.69.39.2
    auth1.opendns.com AAAA IPv6 address = 2620:119:30::53
    auth2.opendns.com internet address = 146.112.60.53
    auth2.opendns.com AAAA IPv6 address = 2a04:e4c0:53::53
    auth3.opendns.com internet address = 208.69.39.2

     

    This is command output of nslookup -type=txt debug.opendns.com.

    ╤хЁтхЁ: DD-WRT
    Address: 192.168.1.1

    DNS request timed out.
    timeout was 2 seconds.
    *** DD-WRT не удалось найти debug.opendns.com: Non-existent domain

     

    This is command output of nslookup -type=txt debug.opendns.com. 208.67.220.220

    ╤хЁтхЁ: resolver2.opendns.com
    Address: 208.67.220.220

    *** resolver2.opendns.com не удалось найти debug.opendns.com.: Non-existent domain
  • Avatar
    rotblitz (Edited )
    "I am not an OpenDNS resolver."

    Your ISP hi-jacks / redirects your DNS traffic to their own DNS service, so it doesn't matter what you configure and what router and firmware you use. :-(

    You may call your ISP to see if you can opt out from this restriction, or you may try to circumvent this restriction by using https://dnscrypt.org/ - you may be able to include this in DD-WRT, see here.

    "I dont have static IP, it's dynamic. To have static IP you should pay for that."

    I doubt that having a static IP address alone would free you up from their DNS hi-jacking.  The one has nothing to do with the other.  If they say they do, request a written confirmation from them that providing you with a static IP address would also allow you to use any 3rd party DNS service.

  • Avatar
    vocalis

    My network is with the TP-Link Archer C7 AC 1750 router connected to a Thomson DWG874B cable modem. I have correctly adjusted the Opendns server settings on the router according to the instructions of the site but still not blocking anything, not even the test page. there is the image of the response to the command nslookup -type=txt which.opendns.com. 208.67.220.220. Please, rotblitz... guys... help me!
    ... help me!

  • Avatar
    rotblitz

    This command proves that your ISP does not hi-jack your DNS traffic and that you could use OpenDNS.  But your symptoms indicate you not using OpenDNS yet.  You must have configured the OpenDNS addresses at the wrong place, or your device is unimpressed about the configuration.  In case your cable modem is a NAT device, you must configure OpenDNS there.

    Copy & paste the complete plain text output of the following commands to here:

    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

     

  • Avatar
    vocalis

    It's a bit strange, because I set it up agum time and after many attempts it worked. Then, that Friday, without having changed anything, it simply stopped blocking. Yesterday it went back to work and today it stopped again.

  • Avatar
    vocalis

  • Avatar
    rotblitz (Edited )

    This is not plain text, but screen shots. :(

    "without having changed anything"

    Yes, this is almost the reason why something doesn't work, because the world changes, and you must keep up with these changes.

    In this case: your ISP has enabled IPv6 connectivity, and you must now configure also DNSv6, same as you configured DNSv4 before.  As clearly can be seen, your DNS traffic goes to your ISP's DNSv6 service, not to OpenDNS, or at best randomly.  So configure ::ffff:d043:dedc and ::ffff:d043:dcde as DNS servers in your IPv6 settings of your router, and you should be using OpenDNS reliably again without losing IPv6 connectivity.

  • Avatar
    vocalis (Edited )

    Thank you, rotblitz, you're the guy! I am sure that this will help other people here in Brazil. Well ... Now my kids will not be very happy about that. Until the day when they will have their own children ... :-)

  • Avatar
    vocalis

    rotblitz, I solved the problem more easily by disabling the ipv6 function on the router. But... if I need to use ipv6 ... and probably I will ... how do I make the correct settings on that page? Can you help me?

  • Avatar
    rotblitz

    As I said above already, you enter ::ffff:d043:dedc and ::ffff:d043:dcde into the two IPv6 DNS fields, after you checked the option "Use the following IPv6 DNS Servers".

  • Avatar
    mryan1

    I entered the dns fields, but the router didn't like the address.  What did I do wrong?

  • Avatar
    rotblitz

    It's not you, it's TP-Link.  These addresses are public.  You may need to disable IPv6 connectivity altogether.

Please sign in to leave a comment.